Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

is 'ip ospf demand-circuit' the default?

Hello,

I have a site where once ISDN comes up, OSPF stops sending hellos and the adjacency stays up after ISDN drops. Looking into this I read about ospf demand circuit.

I verified this by running 'show ip ospf interface dialer' and saw the line "Run as demand circuit'.

Neither ISDN site has the command in it's running config, yet all the examples I find show it must be explicitly configured.

Is this the default behavior of OSPF over ISDN now? If so, when did it become default?

Thanks,

Bryan

3 REPLIES
Hall of Fame Super Silver

Re: is 'ip ospf demand-circuit' the default?

Bryan

It has been a while since I dealt with OSPF demand circuit. It certainly did not used to be a default behavior and I would be very surprised if the default had changed. I believe that somewhere in one of the configs there is something that is setting the interface as demand circuit.

Would it be possible to post the router configs?

HTH

Rick

New Member

Re: is 'ip ospf demand-circuit' the default?

Thanks Rick. Here are the dialer spoke and hub configs. They are quite lengthy so I just have isdn related info:

DIAL SPOKE

----------

interface BRI0/2/0

no ip address

encapsulation ppp

no ip route-cache cef

no ip mroute-cache

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-ni

isdn point-to-point-setup

isdn spid1 11111111111111 1111111

isdn spid2 22222222222222 2222222

no cdp enable

!

interface Dialer1

ip address x.x.x.x 255.255.255.0

encapsulation ppp

no ip route-cache cef

no ip mroute-cache

ip ospf network point-to-multipoint

ip ospf cost 16600

dialer in-band

dialer idle-timeout 130

dialer enable-timeout 6

dialer map ip x.x.x.x name HUB broadcast 1xxxxxxxxxx

dialer load-threshold 5 either

dialer watch-disable 15

dialer watch-group 8

dialer-group 1

no peer neighbor-route

no cdp enable

ppp authentication chap

ppp multilink

!

router ospf 64

log-adjacency-changes

network x.x.x.x 0.0.0.255 area 0

network x.x.x.x 0.0.0.0 area 0

!

dialer watch-list 8 ip 255.255.255.255

dialer watch-list 8 delay route-check initial 60

dialer watch-list 8 delay disconnect 15

dialer-list 1 protocol ip list 101

SPOKE#show ip ospf int dialer1 | inc Run

Run as demand circuit.

DIAL HUB

--------

interface Serial1/0:23

no ip address

encapsulation ppp

no ip route-cache cef

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-5ess

no cdp enable

!

interface Serial1/1:23

no ip address

encapsulation ppp

no ip route-cache cef

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-5ess

no cdp enable

!

interface Dialer0

ip address x.x.x.x 255.255.255.0

encapsulation ppp

no ip route-cache cef

no ip mroute-cache

ip ospf network point-to-multipoint

ip ospf cost 16600

dialer in-band

dialer idle-timeout 130

dialer enable-timeout 6

dialer map ip x.x.x.x name xxxxxxxxxx broadcast

dialer map ip x.x.x.x name xxxxxxxxxx broadcast

dialer load-threshold 10 either

dialer-group 1

no peer neighbor-route

no cdp enable

ppp authentication chap

ppp multilink

!

router ospf 64

log-adjacency-changes

redistribute bgp 65500 subnets

network x.x.x.x 0.0.0.255 area 0

!

router bgp 65500

redistribute ospf 64 match internal external 1 external 2

no auto-summary

dialer-list 1 protocol ip permit

Gold

Re: is 'ip ospf demand-circuit' the default?

I just checked with one of the OSPF coders, and it's not "supposed" to be. If the config shows otherwise, I can go poke at the code to make certain this is correct--I'm on the road this week, so I can't poke at it right this second.

:-)

Russ

128
Views
0
Helpful
3
Replies
CreatePlease to create content