Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IS-IS Level-2 into Level-1

Hi group,

I'm looking for an example or sample configuration which shows redistributing ISIS level 2 routes into level 1 with multiple ISIS instances on a single router. Any help would be appreciated.

Regards,

Rasal.

3 REPLIES
New Member

Re: IS-IS Level-2 into Level-1

Hello!

In 12.4T no problem!

Here is example.

Null process is level-1-2, l1-1 process is level-1.

Route-map is blank, so any l2-route is passing.

!

interface Serial1/0

ip address 10.60.1.1 255.255.255.252

ip router isis

!

interface Serial1/1

ip address 10.11.0.1 255.255.255.252

ip router isis l1-1

!

router isis

net 47.0000.1921.6810.0002.00

metric-style wide

log-adjacency-changes

!

router isis l1-1

net 47.0001.1921.6810.0002.00

is-type level-1

metric-style wide

log-adjacency-changes

redistribute isis ip level-2 into level-1 route-map r1

!

route-map r1 permit 10

!

But.....I tried the same config on 12.2SRC - not working! :(

Auto l1->l2 redistribution is absent!

LSPs ATT-bit in level-1 is set to zero, so l1-default is absent too!

Like two different domains!?

Tried manual redistribution between processes....no success.

Combined configuration is working fine!

Any ideas?

New Member

Re: IS-IS Level-2 into Level-1

Hi there,

Thanks for you reply. What i'm trying to achieve is below ;

router isis

net 47.0000.1921.6810.0002.00

metric-style wide

is-type level-1

redistribute isis LEVEL2 ip level-2 into level-1 route-map r1

!

router isis LEVEL2

net 47.0001.1921.6810.0002.00

is-type level-2

metric-style wide

The probem i'm facing is when i try to enter "redistribute isis LEVEL2 ip level-2 into level-1 route-map r1" under the router isis process, the router fails to accept. I get an error saying

Rack1R1(config-router)#redistribute isis TEST ?

% Unrecognized command

Any clue why this is happening.

Thanks.

New Member

Re: IS-IS Level-2 into Level-1

Hi!

Try to chahge your isis process LEVEL2 to is-type level-1-2, because this is an area border router.

And try to use redistribution commnand in that way:

redistribute isis ip level-2 into level-1 route-map r1

(without LEVEL2)

183
Views
0
Helpful
3
Replies