Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Is QoS implementation possible on Internet Links?

Hi Folks,

I have a quick question? Is QoS implementation possible on Internet Links? If yes, what are the technical considerations need to take before implementaion. If the above details are not adequate to conclude the solution, please let me know what information is required to provide the solution.

8 REPLIES
Gold

Re: Is QoS implementation possible on Internet Links?

Its "possible". But of marginal use.

I's sure there are cases where customers have a qos policy to their ISP, but after that there is no means to insure that any one else will honor the QOS markings.

Super Bronze

Re: Is QoS implementation possible on Internet Links?

Answer depends on what you want to accomplish and how you plan to use your Internet links.

You can do pretty much whatever you want outbound, but beyond your router, Internet routers are out of your control.

Inbound, you're very limited what you can effectively accomplish.

With the above in mine, in some special situations you can obtain results often like what can be accomplished across a private link. For instance, if you build a VPN connection across the Internet, and don't share those Internet links for non-VPN traffic, and implement QoS configured to manage bandwidth bottleneck, performance is often much like a dedicated link. Reason for this, Internet congestion often found mostly at customer links to/from ISP.

New Member

Re: Is QoS implementation possible on Internet Links?

Thanks for replying!!!

I'd like to put more light on it.

Actually we have two Internet routers which are having two seperate links of 35 MB bandwidth to internet Service providers (SP1 and SP2) and configured load balancing the between two ISPs. We are having many client VPN traffic and client http sites which are passing through internet Links and chocking both the lines at business hours eventhough QoS policies are in place. Find below the QoS policy config for your reference and kindly suggest me for an appropriate solution to how to reduce congestion by configuring QoS on the links.

!

class-map match-any ACTIVE24

match access-group 140

class-map match-any Internet_Rate

match access-group name INDIA_RATE

!

!

policy-map ACTIVE24_BW_POLICING

description limiting BW for ACTIVE24 - Limelight access using port 1935

class ACTIVE24

police 7000000 conform-action transmit exceed-action drop violate-action drop

policy-map INT_RATE

class Internet_Rate

police 1536000 384000 384000 conform-action transmit exceed-action drop violate-action drop

!

!

!

!

!

interface Loopback0

ip address 10.1.5.1 255.255.255.255

!

interface FastEthernet0/0

description to Firewall

ip address 10.1.4.2 255.255.255.0

no ip redirects

no ip proxy-arp

load-interval 30

speed auto

full-duplex

no cdp enable

standby 1 ip 10.1.4.1

standby 1 timers 2 5

standby 1 priority 105

standby 1 preempt

standby 1 authentication INDIAINT12

!

interface FastEthernet0/1

bandwidth 35000

ip address 111.11.1.110 255.255.255.252

ip access-group SP1_INBOUND_INTERFACE_FILTER in

no ip redirects

no ip proxy-arp

ip accounting output-packets

ip flow ingress

ip flow egress

ip route-cache flow

load-interval 30

speed auto

full-duplex

no cdp enable

Gold

Re: Is QoS implementation possible on Internet Links?

What sort of data do you have regarding link utilization?

Who manages the routers at the edge of this network?

If you do, you could consider a traffic marking scheme,

Super Bronze

Re: Is QoS implementation possible on Internet Links?

I don't see the policy-map applied.

For outbound, you might start with something like this:

policy-map QoS_policy

class class-default

fair-queue

interface fastE 0/1

service-policy outbound QoS_policy

As I noted in my prior post, inbound is a problem. You could implement some kind of policer, as in your posting, but such don't usually well keep the inbound traffic from bursting on your circuit upstream of the policer. I.e. you can control the downstream rate (from the policer), but the issue is congestion on the WAN link, which is why you ideally want QoS on the ISP side, outbound.

(BTW, I have done outbound ACK rate shaping, which can influence inbound TCP traffic rates, but tricky to get "just right".)

Don't believe Cisco has a product that addresses this issue, but 3rd party products like Packeteer's, for TCP, can.

New Member

Re: Is QoS implementation possible on Internet Links?

Thanks for your response....

As per my managers point of view for implementaion of inbound policy we need to implement QOSpolicies also on the ISP side and for that they would be charging for providing the QoS service. So keeping cost in our mind he wants me to come up with such solution that the congestion would be reduced with the implementation of outbound policy or with prioritization techniques.

Can you send me the cofiguration steps how to implement outbound policies based on the 35 MBbandwidth on the link. Your help is much appriciated for one more time.

Super Bronze

Re: Is QoS implementation possible on Internet Links?

Regarding ISP charging for inbound QoS, if the inbound bandwidth is oversubscribed, it might be a good deal. You would need to compare additional cost vs. impact of doing nothing, or and other other approaches (e.g. more bandwidth or 3rd party device).

Two techniques that can be used with effect with inbound TCP traffic to regulate their bandwidth consumption, is policing it (so packets drops slow sender rate) or shaping outbound TCP ACKs.

For outbound, again, I would start with a FQ queuing configuration. However, since you mention 35 Mbps and have shown fast Ethernet interfaces, you'll likely want to shape the traffic to the available bandwidth. This can be done using just a generic traffic shaper (which generally also implements WFQ) or using a shaper within CBWFQ (which allows you later on to prioritize different traffic differently). For Ethernet, you often need the shaper set slower than "nomimal" bandwidth to allow for L2 overhead (this depends on what the ISP is measuring).

e.g.

policy-map asample

class class-default

shape average (30 Mbps)

interface fastethernet #

service-policy output asample

or

interface fastethernet #

traffic-rate rate (30 Mbps)

New Member

Re: Is QoS implementation possible on Internet Links?

Hi Joseph,

Thanks for the information.

Will look forward to implement these techniques and will let you the outcome. If have stuck in the middle then i'll again trouble you this again :-) :-)

Once again thanks for the information and looking forward to learn more on this.

188
Views
0
Helpful
8
Replies