Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Is there a way to force an EIGRP route update

Reason - remote router has 2 equal routes for a desitnation network, but we want to influence traffic over a specific router. We have changed the delay value on the remote routers inbound interface, but the delay value is not being seen on the local router and is keeping 2 equal cost paths.

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Is there a way to force an EIGRP route update

Hello,

The 'ip summary-address' command and the 'delay' statements are completely independent. I have no idea why your predecessor would have believe that there was a relationship between them.

Hope that helps.. pls rate posts that are helpful.

Regards,

Paresh.

16 REPLIES

Re: Is there a way to force an EIGRP route update

Hi,

you could modify the value outbound on the sending router.

Hope this helps

Martin

P.S.: could you post your configs to allow checking what you did?

Re: Is there a way to force an EIGRP route update

You must have misconfigured it. I suppose that you must alter the delay on the router whose routing table needs to be altered. There is a document on this, I found it by searching on eigrp & delay:

http://www.cisco.com/en/US/customer/tech/tk365/technologies_tech_note09186a00800c2d96.shtml

Regards,

Leo

Purple

Re: Is there a way to force an EIGRP route update

Hi,

Setting the delay on the remote router will not change the calculation of the metric on the local router. With EIGRP, the "local" router will update the advertised metric from its neighbors based on locally configured values of bandwidth/delay etc on the interfaces on which the advertisement was received.

To get the desired effect, change the delay on the interface on the local router.

Hope that helps,

Paresh.

New Member

Re: Is there a way to force an EIGRP route update

Thanks all for responding. Due to change control restrictions, it will take a few days before I can do anything. I will update this post once I have more

Thanks!

New Member

Re: Is there a way to force an EIGRP route update

A little more information and explanation.

### Information / Confi ####

*** "Local" Router Config

Router L1

Outbound Interface

int fa0/0.1

description interface to\from remote OpCos

ip address 10.128.3.2

speed 100

duplex full

*** "Remote" Routers config

Router R1 (preferred router)

int fa0/0.1

description interface to/from remote OpCos

ip summary address 10.120.0.0 255.252.0.0 5

ip address 10.128.3.8

speed 100

duplex full

router eigrp 10499

redistribute static

network 10.0.0.0

no auto-summary

Router R2 (failover router - at least intended)

int fa0/0.1

description interface to/from remote OpCos

ip address 10.128.3.9

ip summary address 10.120.0.0 255.252.0.0 5

DELAY 110

speed 100

duplex full

router eigrp 10499

redistribute static

network 10.0.0.0

no auto-summary

*** Local router show output

L1#sh ip route 10.120.0.0

Routing entry for 10.120.0.0/14

Known via "eigrp 10499", distance 90, metric 28160, type internal

Redistributing via eigrp 10499

Last update from 10.128.3.9 on FastEthernet0/0.1, 2d12h ago

Routing Descriptor Blocks:

* 10.128.3.9, from 10.128.3.9, 2d12h ago, via FastEthernet0/0.1

Route metric is 28160, traffic share count is 1

Total delay is 100 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 6/255, Hops 1

10.128.3.8, from 10.128.3.8, 2d12h ago, via FastEthernet0/0.1

Route metric is 28160, traffic share count is 1

Total delay is 100 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 2/255, Hops 1

L1#sh ip eigrp topo 10.120.0.0 255.252.0.0

IP-EIGRP (AS 10499): Topology entry for 10.120.0.0/14

State is Passive, Query origin flag is 1, 2 Successor(s), FD is 28160

Routing Descriptor Blocks:

10.128.3.9 (FastEthernet0/0.1), from 10.128.3.9, Send flag is 0x0

Composite metric is (28160/256), Route is Internal

Vector metric:

Minimum bandwidth is 100000 Kbit

Total delay is 100 microseconds

Reliability is 0/255

Load is 6/255

Minimum MTU is 1500

Hop count is 1

10.128.3.8 (FastEthernet0/0.1), from 10.128.3.8, Send flag is 0x0

Composite metric is (28160/256), Route is Internal

Vector metric:

Minimum bandwidth is 100000 Kbit

Total delay is 100 microseconds

Reliability is 0/255

Load is 2/255

Minimum MTU is 1500

Hop count is 1

L1#

### Problem / Confusion ###

Our intention or attempt is to have the "Local" router L1 see 2 routes 10 the 10.120.0.0/14 network;

* R1 be the active / primary

* R2 be in standby mode - by using the DELAY statement to influence the route metric

If I'm interpreting the output from L1 correctly, what I seem to have is Destination load sharing - equal cost paths to both R1 and R2.

Q. Am I interpreting the output correctly

Q. Can I accomplish what I describe (or at least what I hope I'm describing)

Q. It seems no matter what I change the DELAY to on R2, no change to metric on L1 for is reflected.

Thanks in advance for everyone's response.

P.S. I did read the link posted on the example for influencing route selection. I interpreted it as the DELAY would propagate to down\up stream routers.

Gold

Re: Is there a way to force an EIGRP route update

Set the delay on int fa0/0.1 on L1 (the local router). If you have this:

A---B---C

Now, suppose:

-- A's delay towards B is 100.

-- B's delay towards A is 110.

-- B's delay towards C is 100.

-- C's delay towards B is 110.

If A originates a route with a delay of 0, somehow, the total delay at C will be 220. A will send the route with a delay of 0, and B will add it's delay towards A to the total delay. B will send the route, with a delay of 110, to C, and C will add 110, it's delay towards B, to the delay, so the total is 220.

Now, if we work in the opposite direction, and C originates a route with a delay of 0, the total delay when it reaches A will be 200. The receiving router always adds the delay of the link to reach the neighbor the route was received from, and advertises the route to its neighbors with the delay just as it is in the local topology table.

This is the same way RIP works--the hop count is added inbound, not outbound.

HTH.

:-)

Russ.W

New Member

Re: Is there a way to force an EIGRP route update

the layout of what we are trying to influence is;

----B---

| |

A ------| |--LAN

| |

----C---

Routers B & C share networks behind them and summarize to 10.120.0.0 255.252.0.0.

On the inbound interface on B (from the LAN side), we have a DELAY, whereas on C, we do not.

Our intention is to have router A choose Router C as the primary path to 10.120.0.0. What we are seeing instead is that Router A sees equal cost paths to B & C in order to get to 10.120.0.0/14.

We have also changed the AD on the route summary on B, still with no luck --> ip summary-address eigrp xxxx 10.120.0.0 255.252.0.0 110

We believe our 3 options to accomplish what we are after are;

1) Delay (preferred technique)

2) Offset List

3) Setting the AD (least preferred, generally not recommended)

Are we misunderstanding something here?

Purple

Re: Is there a way to force an EIGRP route update

Looking at your 3 options:

1. Adjusting the delay parameter on A will not accomplish anything since this will impact all routes learned via the Ethernet interface - those from B as well as C.

2. This is the best option. You need to use an outbound offset-list on B to increase its metric as such;

access-list 10 permit 10.120.0.0 0.3.255.255

offset-list 10 out eth0/0

Choose a large enough metric offset here to make the route from B less preferable. Note that this must be applied on router B.

3. This could work. You would simply assign a higher AD to routes learned via B. However, this would be specific to the router A. You mentioned that you changed the AD on router B. This would have no effect on router A since the AD is specific to the router and not communicated between routers.

Pls try out option 2 and see how you go.

Pls also rate the post if it helps.

Paresh.

New Member

Re: Is there a way to force an EIGRP route update

I didn't catch the mistake in my post of the connections between A, B, & C.

A has a single line connection to B & C, with B & C being in parallel

A --B&C

Would you reply still be the same.

Purple

Re: Is there a way to force an EIGRP route update

Hi,

I'm not sure what you mean by B & C being in parallel. So you are saying that A has a link to B. How are B and C connected ? Maybe you could attach a file with your exact topology.

Paresh.

Purple

Re: Is there a way to force an EIGRP route update

Hi again,

If A, B and C are sitting on the same LAN segment, my previous post still applies.

However, if the topology is different to that, we need to know what it is...

Paresh.

New Member

Re: Is there a way to force an EIGRP route update

Attached is a drawing. It's a rough depiction, but I hope it gives enough information.

Purple

Re: Is there a way to force an EIGRP route update

Hi again.

Excellent diagram - that does indeed make things clearer.

As per my previous post, if you apply that offset-list statement to router B, you will get the desired effect. Just be careful to not make that offset so big that the router B is no longer a feasible successor.

Also, you might want to get rid of the non-default delay you have configured on router C. It is not helping you in this case and may cause you issues in the future.

Hope that helps,

Paresh.

Purple

Re: Is there a way to force an EIGRP route update

Hello yet again..

I had another thought about how you could do this, although the first method I suggested (using the offset-list) should work.

You could also increase the delay on the interface on router B that goes to the Core switch. Firstly, determine what the current delay is on the interface using 'show interface'. Then use the 'delay' command on that interface to set it to a higher value than the current value. Just be aware that the parameter used with the delay command is specified in 10s of microseconds so if you want to configure a delay of 100 microseconds, you will need to use 'delay 10'.

Hope that helps,

Paresh.

New Member

Re: Is there a way to force an EIGRP route update

Hello Paresh,

The offset-list did the trick.

One last question, does the ip summary-address influence (negate) the delay statement in any way? Reason I ask is, my predecessor believed that without the ip summary-address, the delay statement worked and we did not need the offset-list.

Thanks in advance for all your help.

Purple

Re: Is there a way to force an EIGRP route update

Hello,

The 'ip summary-address' command and the 'delay' statements are completely independent. I have no idea why your predecessor would have believe that there was a relationship between them.

Hope that helps.. pls rate posts that are helpful.

Regards,

Paresh.

689
Views
8
Helpful
16
Replies