Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Is there any cisco device/firewall which support two ISP

I have two ISP with respective public IP which are used natting server.Our main purpose is Load balancing and redundancy between two ISP link.If one ISP link is fail access from outside will be live.

6 REPLIES

Re: Is there any cisco device/firewall which support two ISP

Hi,

You can use a Cisco router with NAT for the load balancing, it should look something like this:

!

interface FastEthernet0/0

ip address

ip nat inside

!

interface Serial0/0

description ***ISP1***

ip address

ip nat outside

!

interface Serial0/1

description ***ISP2**

ip address

ip nat outside

!

!

ip nat inside source route-map ISP1_NAT ...

ip nat inside source route-map ISP2_NAT ...

!

access-list 1 permit

!

route-map ISP1_NAT permit 10

match ip address 1

match interface Serial0/0

!

route-map ISP2_NAT permit 10

match ip address 1

match interface Serial0/1

!

ip route 0.0.0.0 0.0.0.0 serial0/0

ip route 0.0.0.0 0.0.0.0 serial0/1

HTH,

Mohammed Mahmoud.

New Member

Re: Is there any cisco device/firewall which support two ISP

hi,

Thanks a lot for ur reply,but is it supported to redundancy purpose?

For accessing server from outside,they are natted on firewall.our router's fastethernet ip is public ip which is connected to the firewall.please tell me any scenario if u have.

Re: Is there any cisco device/firewall which support two ISP

Hi,

Yes this establishes load-sharing / redundancy.

HTH,

Mohammed Mahmoud.

Re: Is there any cisco device/firewall which support two ISP

Hi,

Sorry my reply was before you edited your post and added this part "For accessing server from outside,they are natted on firewall.our router's fastethernet ip is public ip which is connected to the firewall.please tell me any scenario if u have".

Cay you please elaborate more on your topology.

BR,

Mohammed Mahmoud.

New Member

Re: Is there any cisco device/firewall which support two ISP

Hi,

My main purpose is redundancy and load shairing between two ISP.If i take public ip from ISP1 and my ISP1 link fail,i can access internet via ISP2 but external user cant access internal server which are natted on firewall with ISP1 public IP.I cant configure one private ip with two public IP on my current firewall.so is there any device?please help me.Please see attachment.

Is it possible with BGP?is it supported redundancy and load shairing between two ISP?

if possible please send me config example.

Re: Is there any cisco device/firewall which support two ISP

This is possible. WE have implemented this with Reliance & Bharti.

Check the following urls i used them

http://www.cisco.com/warp/public/459/40.html

http://www.cisco.com/warp/public/459/27.html

HTH - Pls rate if it helps

116
Views
0
Helpful
6
Replies
CreatePlease to create content