Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ISDN Backup Interface

Hi,

The ISDN backup design as follow:

1) R1 will dial to R2 when leased line between R1-R2 down.

2) The client/hosts at R2 normally initiated the ip connection. R1 host is server.

I had tested the backup, it work but the ISDN connection is not initiate from R1 unless I ping from R1 ro R2 hosts.

If I ping from R2 side of hosts to R1 side of server continuously , the R1 never dial to R2.

I believed the problem is due to R1 end of server do not initiate connection therefore the ISDN cannot be up.

Question is that a way to make ISDN up immediately, when the leased line failed. Even no traffic is initiate from R1 hosts.

R1

----

interface Serial0/0/0:1

ip address 172.31.4.194 255.255.255.252

backup delay 5 60

backup interface BRI0/1/0

interface BRI0/1/0

ip address 172.31.4.226 255.255.255.252

encapsulation ppp

dialer idle-timeout 180

dialer map ip 172.31.4.225 name M2M-MCCT-R2 broadcast 56280203

dialer load-threshold 50 either

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

isdn send-alerting

isdn sending-complete

ppp authentication chap

ppp multilink

14 REPLIES
Community Member

Re: ISDN Backup Interface

Do you mean backup 0 60 , where "0" wil immediate with up the ISDN even no interesting traffic at all from R1 ?

Re: ISDN Backup Interface

Hi CHOH KOON TAN, backup delay is used for the time in sec “before backup line up or down transitions”. See you never know when your primary will down, and that time which traffic is passing through your network. If primary fails then 0 sec takes the backup interface charge imm, now you can specify the interesting traffic by using ACL for your network. Thanks Goutam

Re: ISDN Backup Interface

Hi CHOH KOON TAN, backup delay is used for the time in sec “before backup line up or down transitions”. See you never know when your primary will down, and that time which traffic is passing through your network. If primary fails then 0 sec takes the backup interface charge imm, now you can specify the interesting traffic by using ACL for your network. Thanks Goutam

Re: ISDN Backup Interface

Hi CHOH KOON TAN, backup delay is used for the time in sec “before backup line up or down transitions”. See you never know when your primary will down, and that time which traffic is passing through your network. If primary fails then 0 sec takes the backup interface charge imm, now you can specify the interesting traffic by using ACL for your network. Thanks Goutam

Community Member

Re: ISDN Backup Interface

Mnually shut down the serial interface & try whether it is up or not if not plz check out ISDN link & Dialer no whether it is working or not it happen some time dial no is not working that why it is unable to estblished the ISDN connection

Community Member

Re: ISDN Backup Interface

1) ISDN backup work when leased line down, NO problem at all. R1 can dial to R2 if I ping from R1 host to R2 host, then pull the leased line, ISDN dial in and backup the leased line. Perfectly.

2) Actual fact the host at R1 basically is server, and never initiate any connection.

3) Hosts/client at R2 basically will initiate connection to R1 server.

4) Only R1 dial to R2, R2 will NOT dial to R1.

5) So at R2 I had very active client that always make connection to R1 server.

6) ..Leased down.

7) all connection lost. All TCP session terminate.

8) Backup ISDN interface active now.

9) Only client from R2 try making new connection to R1 server. Of course the packet never reach R1 server at the moment.

10) Server at R1, keep 'quite" as he do not received any connection to R2 client. Server never reply nor initiate connection to clients (as I mentioned it is "passive " server).

11) Therefore no interesting traffic send by server to R2 client..therefore dialer will not initiate at all.

Well what is the best solution ?

Or just have batch file in server actively perform ping test to clients ?

So when leased line failed, it can initiate the R1 to dial to R2 ?

Regards

Hall of Fame Super Gold

Re: ISDN Backup Interface

Choh

When the leased line goes down there must be interesting traffic to bring up the backup interface. If there is not going to be traffic initiated from R1 to R2 then it was not a good design to set up backup interface and restrict dialing to R1.

There are several alternatives to consider. Which one will be "best" will depend on some things in your environment and your requirements which we can not know at this point. So I will point out some alternatives and you must choose which of them seems best for your situation.

- Let R2 dial to R1 would be the most simple solution consistent with use of backup interface. Apparently there is some reason why you do not want R2 to dial?

- Get some device on the network of R1 that will periodically attempt to access some resource on R2. Possibly it could be a separate device, or perhaps some application on the server could initiate traffic, or perhaps you could configure IP SLA on R1 to do this. Your suggestion of a batch file on the server would fit in this suggestion.

- Perhaps you might consider the use of dialer watch instead of backup interface. I believe that dialer watch will dial when it detects the loss of certain specified routes from the routing table. This would make it easier for the dialing to be done from R1.

HTH

Rick

Community Member

Re: ISDN Backup Interface

Hi Rick,

Well, look like dialer watch fit the environment, as it can dial without the need of interesting traffic.

Thanks !

Community Member

Re: ISDN Backup Interface

Hi Rick,

Dialer watch not work either, I think it might due to I am not using dynamic routing.

Below url, stated it do not support static/direct connected route.

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009457d.shtml#bi_cons

Routing-Backup initialization is linked to the dynamic routing protocol rather than a specific interface or static route entry. Therefore, both primary and backup interfaces can be any interface type, and can be used across multiple interfaces and multiple routers. Dialer watch also relies on convergence which is sometimes preferred over traditional DDR links.

Routing protocol independent-Static routes or dynamic routing protocols such as Interior Gateway Routing Protocol (IGRP), Enhanced IGRP (EIGRP) or Open Shortest Path First (OSPF) can be used.

Regards

Community Member

Re: ISDN Backup Interface

Hi Rick,

The debug shown below message.

*Apr 1 11:27:08.030: DDR: Dialer Watch: watch-group = 10

*Apr 1 11:27:08.030: DDR: network 172.31.4.192/255.255.255.252 DOWN,

*Apr 1 11:27:08.030: DDR: primary DOWN

*Apr 1 11:27:08.030: DDR: Dialer Watch: Dial Reason: Primary of group 10 DOWN

*Apr 1 11:27:08.030: DDR: Dialer Watch watch-group 10 -

dialer map/string not present on BR0/1/0

My config did have dialer map and dialer string, but it complaint it. Not sure why. Or due to it not support Connected route watch ?

interface Serial0/0/0:1

ip address 172.31.4.194 255.255.255.252

load-interval 30

keepalive 5

!

interface BRI0/1/0

ip address 172.31.4.226 255.255.255.252

encapsulation ppp

dialer idle-timeout 180

dialer map ip 172.31.4.225 name R2 broadcast 56280xxx

dialer load-threshold 50 either

dialer watch-group 10

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

isdn send-alerting

isdn sending-complete

ppp authentication chap

ppp multilink

dialer watch-list 10 ip 172.31.4.192 255.255.255.252

dialer-list 1 protocol ip permit

Hall of Fame Super Gold

Re: ISDN Backup Interface

Choh

I thought that dialer watch would be a good solution to your issue. I am surprised that it is not working. The error message does seem to indicate some issue with the dialer map though what you post does seem to have a dialer map and I do not see anything wrong with it.

If dialer watch is not working I wonder if you could resolve the issue by configuring a floating static route for 172.31.4.192 with 172.31.4.225 as the next hop. It might look something like this:

ip route 172.31.4.192 255.255.255.252 172.31.4.225 250

so as long as the primary line was up that route would be in the routing table and if that line went down, its route would withdraw from the routing table and the floating static would be inserted into the routing table and it would cause the router to dial the BRI.

HTH

Rick

Community Member

Re: ISDN Backup Interface

Hi Rick,

Workaround is I add the ospf command in R1 and place ISDN interface in area 0 (althought I run static, but placing BRI in OSPF area 0 it does generate intersting traffic). Problem resolved is can dial when leased line down.

Hope Cisco can improve Backup Interface, by allow backup interface to dial it self without interest trafic.

Regards

Community Member

Re: ISDN Backup Interface

I've got my own dialer watch issues, but i think you need to add the following to your bri

dialer map ip 172.31.4.192 name R2 broadcast 56280xxx

For every watched route you need a matching dialer map for it.

179
Views
13
Helpful
14
Replies
CreatePlease to create content