Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN backup stay connected

Hello! I have 3 routers. 2 of them are connected over frame relay and third router is used for backup. All 3 using eigrp and backup router is using static floating route to make backup. The problem is that ISDN stay connected when frame relay become up.

24 REPLIES
Silver

Re: ISDN backup stay connected

Hello,

Can you post the config and a diagram? One of the possible reasons is the interesting traffic definied by the dialer-list includes the routing protocol traffic so the eigrp hellos will keep the ISDN active.

Hope it helps,

Krisztian

New Member

Re: ISDN backup stay connected

Well The interesting traffic exclude eigrp updates

Here is the acccess list for dialer-group

access-list 115 deny eigrp any any

access-list 115 permit ip any any

The thing is that isdn backup is not on the same router where is primary link. It seems that backup router does not get the eigrp update about new primary route.

Silver

Re: ISDN backup stay connected

I don't think that the problem is that the backup router is notified about the primary route, because if there is no traffic through it there is no need for the ISDN to stuck. The ISDN will go down after the idle timeout. There must be some traffic which keeps it active. A config would be helpful together with show ip route output. The reason why the primary route is not installed with eigrp is might be the floating static route metric is less than 90 or 170 (depends how the prefix is annonced through eigrp). So the floating static will have higher preference over eigrp route, but if the isdn goes down the eigrp route should be put in the routing table.

Silver

Re: ISDN backup stay connected

Hi ,

can you paste the config of the 3'rd router...

The following link is very useful where isdn is used backup for eirgp links...

http://www.cisco.com/en/US/tech/tk713/tk237/technologies_configuration_example09186a00800a3b77.shtml

Thanks,

Satish

New Member

Re: ISDN backup stay connected

Here is the configuration .....

BACKUP ROUTER

interface BRI0

ip address XXXXXXX

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 180

dialer map ip REMOTEIP name REMOTE broadcast NUMBER

dialer load-threshold 5 either

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

router eigrp 20

redistribute static

network XXXXXX LANS

network XXXXXX WANS (include ISDN and FRAME RELAY)

no auto-summary

no eigrp log-neighbor-changes

ip route REMOTE LAN 200

dialer-list 1 protocol ip list 115

access-list 115 deny eigrp any any

access-list 115 permit ip any any

REMOTE ROUTER

interface BRI0

ip address XXXXXXX

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 180

dialer map ip BACKUPIP name BACKUP broadcast

dialer load-threshold 5 either

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

router eigrp 20

network XXXXXX LANS

network XXXXXX WANS (include ISDN and FRAME RELAY)

no auto-summary

no eigrp log-neighbor-changes

ip route CENTRAL LAN 200

access-list 116 deny eigrp any any

access-list 116 permit ip any any

dialer-list 1 protocol ip list 116

Silver

Re: ISDN backup stay connected

Which router is the default gateway for the hosts on the central LAN? If you can post the whole config of the 3 routers that would be fine.

Let's try to remove the network XXXXXX WANS (include ISDN and FRAME RELAY) from the backup router and enable eigrp for only to the FR link. You have static route in both side for the LAN's so no need to run eigrp through the ISDN.

New Member

Re: ISDN backup stay connected

It is little complicated.....I use route summarization on wans and ISDNS with one B class and remote and local LANS other B class.

Silver

Re: ISDN backup stay connected

How is your LAN connected on the central site to the two routers. Which router is the default gateway. A full config from both routers would be still helpful. I think it is a routing issue, because after the ISDN brought up the traffic is still goes through it even if the primary link will come up. Let's check the routing first.

New Member

Re: ISDN backup stay connected

You have example with pseudo IP

....just example

so conf is

ROUTER2

interface eth0

ip address 192.168.100.2/24

interface BRI0

ip address 192.168.4.1/24

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 180

dialer map ip 192.168.4.2 name REMOTE broadcast NUMBER

dialer load-threshold 5 either

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

router eigrp 20

redistribute static

network 192.168.0.0

no auto-summary

no eigrp log-neighbor-changes

ip route 192.168.2.0 255.255.255.0 200

ip route 0.0.0.0 0.0.0.0 192.168.1.1

dialer-list 1 protocol ip list 115

access-list 115 deny eigrp any any

access-list 115 permit ip any any

ROUTER3

interface etho

IP address 192.168.2.1/24

int ser0

ip address 192.168.3.2

...

interface BRI0

ip address 192.168.4.2/24

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 180

dialer map ip 192.168.4.1 name BACKUP broadcast

dialer load-threshold 5 either

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

router eigrp 20

network 192.168.0.0

no auto-summary

no eigrp log-neighbor-changes

ip route 192.168.1.0/24 bri0 200

ip route 0.0.0.0 0.0.0.0 192.168.1.1

access-list 116 deny eigrp any any

access-list 116 permit ip any any

dialer-list 1 protocol ip list 116

ROUTER1

interface etho

IP address 192.168.100.3/24

int ser0

ip address 192.168.3.1

...

router eigrp 20

network 192.168.0.0

no auto-summary

no eigrp log-neighbor-changes

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ROUTER

eth0

ip address 192.168.100.4/24

eth1

ip address 192.168.1.1/24

router eigrp 20

network 192.168.0.0

This is the logic........of the conf......

See the picture

THANKS

Silver

Re: ISDN backup stay connected

If you use the network 192.168.0.0 than eigrp will active only on the interfaces in the 192.168.0.0/24 so it won't cover the 192.168.100.0/24, 192.168.4.0/24 etc. Let's check on which interfaces running the eigrp.

show ip eigrp interfaces

show ip eigrp neighbors

New Member

Re: ISDN backup stay connected

No i dont use the 192.168

this is just

an example the 192.168.....in my case is B class adreses

Silver

Re: ISDN backup stay connected

Then pls check the show ip route and show ip eigrp topology for the remote LAN prefix on the ROUTER when the ISDN and FR are both up to see which path is preferred by eigrp. You can try to increase the delay under the bri so it will increase the metric of eigrp.

New Member

Re: ISDN backup stay connected

how to increase delay under bri and eigrp metric with hold down timmers?

Silver

Re: ISDN backup stay connected

As eigrp by default confider only bandwidth and delay of the path you have two choices to influence the metric. The holddown timer is to how long

interfacew bri0

delay 2000

bandwidth 40

If you take a look to the show ip eigrp topology x.x.x.x/y you will see it.

Anyway the hold-down timer is to detect the neighbor is dead and not used for the metric calculation. Hope it helps

New Member

Re: ISDN backup stay connected

If I put the bandwidth 40 will this decrease speed on logical level.....on ISDN? Or is it a just used for best route calculation?

Silver

Re: ISDN backup stay connected

The bandwidth and delay configuration only affects the routing protocol metric calculation and does not affect the physical behaviour of the link.

New Member

Re: ISDN backup stay connected

Here is the EIGRP topology and neigbors after all link are up

BACKUP ROUTER

EIGRP Neighbour

D 172.20.91.0 [90/40514560] via 172.30.30.2, (this is ISDN IP)

EIGRP Topology

P 172.20.91.0/24, 1 successors, FD is 40514560

via 172.30.30.2 (40514560/28160), BRI2/7

FRAME RELAY ROUTER

EIGRP NEighbor (It puts ISDN router in eigrp table not serial link)

D 172.20.91.0 [90/40517120] via 172.30.100.3, 00:02:57, FastEthernet1

EIGRP Topology

P 172.20.91.0/24, 1 successors, FD is 40517120

via 172.30.100.3 (40517120/40514560), FastEthernet1 (This is eigrp route over ISDN ROUTER )

via 172.30.160.2 (297246976/28160), Tunnel1

(This is EIGRP route over frame relay that is encapsulated in GRE)

What to configure on ISDN BACKUP router and Frame relay router in order to get

172.30.160.2 (297246976/28160), Tunnel1

As primary EIGRP route....

It seems that tunnel traffic have a big delay so ISDN is brinnging up and say up

Silver

Re: ISDN backup stay connected

You didn't mentioned so far there is a GRE tunnel through the FR link.

In this case eigrp will calculate the metric based on the bandwidth and delay of the tunnel interface.

Let's set the bandwidth under tunnel interface to much higher than on bri. What's the cir of the FR link? Anyway why do you use GRE over FR? It just introduce additional overhead.

New Member

Re: ISDN backup stay connected

It is little complicated......this is not real point to point frame relay........I must have VPN for solution and also want to use EIGRP as my routing protocol in topology.....so i encapsulate EIGRP in GRE.... CIR is 512 Kbps

New Member

Re: ISDN backup stay connected

I have also few same EIGRP....GRE...ISDN static floating combinations and they working fine....just this one making a problem....

Silver

Re: ISDN backup stay connected

So the problem is with GRE is that its default bandwidth is 9kbit/s and the delay is also very high.

For instance:

Tunnel0 is up, line protocol is down

Hardware is Tunnel

MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

So let's change it to 512 and if needed reduce the delay here or increase the delay on bri.

You will see how the FD changed on the ROUTER using the show ip topology.

You have to alter these values until the route table will be changed.

Another solution is to use eigrp offset list to anounce the remote LAN prefix with much higher delay but now try the above.

New Member

Re: ISDN backup stay connected

THANKS A LOT! Give You the feedback!

New Member

Re: ISDN backup stay connected

It seems that is working. After I put bandwidth to Tunnel interface ISDN stay down....THANKS AGAIN!

Silver

Re: ISDN backup stay connected

Happy to help.

137
Views
5
Helpful
24
Replies