Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ISDN connection is not working.

Hi,

I have two Cisco 2811 routers connecting my Head office and Branch office via Metro E link. I have setup and configured ISDN link as backup for this MetroE link. I am testing on the ISDN connectivity. I am getting disconnected with in a second after the connection is established. The debug error says " ISDN_HANGUP received. I didn't configure anything on this (or I may unknowingly configured it). Please help to identify the problem and let me know how can i correct it.

Taj

The configuration and debug is attached

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: ISDN connection is not working.

Hello Taj,

now that I see the whole configurations I see that you have enabled AAA new model.

I've reviewed some configurations I used in a similar scenario:

I would add the following in global config:

aaa authentication ppp default local

on both routers

Hope to help

Giuseppe

13 REPLIES
Community Member

Re: ISDN connection is not working.

Here is the attachment.

Hall of Fame Super Silver

Re: ISDN connection is not working.

Hello Mohammed,

I cannot open your attachment it says file not exists

However:

check if there are issues with isdn caller screening

I shouldn't be a ppp authentication issue but also depends from the debug you have enabled

I would suggest

debug isdn q921

debug isdn q931

debug ppp negotation

debug ppp authentication

Make other attempts with all of these debugs active and post the output (sorry if you have already done)

Hope to help

Giuseppe

Hall of Fame Super Gold

Re: ISDN connection is not working.

Taj

I am not sure why Guiseppe had problems opening your file, but it opened just fine for me. I have looked at it and believe that there are 2 lines that are especially significant:

Dec 3 07:06:32.890: ISDN Se1/0:15 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x0007

Dec 3 07:06:32.950: ISDN Se1/0:15 EVENT: UserIdle: callid 0x8008 received ISDN_HANGUP (0x1)

this shows that your head office sends CONNECT_ACK which is a sign that things are processing normally on the head office. Then you recieve ISDN_HANGUP which is a sign that the issue is at the branch office since the branch office is the one that initiated the hang up. I believe that to solve the issue that you will need debugs from the branch office. In addition to the debug isdn q931 that you were running it might be helpful to run debug ppp negotiation and debug ppp authentication.

HTH

Rick

Hall of Fame Super Silver

Re: ISDN connection is not working.

Hello Taj, Rick

it was a problem of my office PC I can open the file.

I see

Dec 3 07:06:32.950: ISDN Se1/0:15 EVENT: UserIdle: callid 0x8008 received ISDN_HANGUP (0x1)

Dec 3 07:06:32.950: ISDN Se1/0:15 EVENTd: process_disconnect: call id 0x8008, call type is DATA, b_idb 0x44C92608, ces 1, cause Normal call clearing(0x10)

Dec 3 07:06:32.950: ISDN Se1/0:15 EVENTd: calltrkr_call_disconnected: isdn_info=0x44C9A3FC, call_id=0x8008

Dec 3 07:06:32.950: ISDN Se1/0:15 EVENTd: process_disconnect: Raw Release Message

Probably a PPP authentication failure repeat your tests with the debugs I listed in my first post that are the same suggested by Rick

Hope to help

Giuseppe

Community Member

Re: ISDN connection is not working.

Hi Rick, Giuseppe,

Thanks for helping me out on this. I have attached the debug logs both from my Head Office and Branch Office.

Community Member

Re: ISDN connection is not working.

could you pls post debug ppp auth?

Nishith

Hall of Fame Super Silver

Re: ISDN connection is not working.

Hello Taj,

I've given a look to the last debug outputs.

There is no authentication issue but it is something else that happens on the heade end:

Hdoffice

Dec 4 02:34:47.009: Se1/0:30 PPP: Phase is FORWARDING, Attempting Forward

Dec 4 02:34:47.009: Se1/0:30 PPP: Phase is ESTABLISHING, Finish LCP

Dec 4 02:34:47.009: Se1/0:30 PPP: Phase is VIRTUALIZED

Dec 4 02:34:47.013: Se1/0:30 PPP: Sending Acct Event[Down] id[1E6]

Dec 4 02:34:47.013: Se1/0:30 PPP: Phase is TERMINATING

Dec 4 02:34:47.013: Se1/0:30 LCP: O TERMREQ [Open] id 14 len 4

Dec 4 02:34:47.013: Vi1 PPP: Phase is DOWN, Setup

Dec 4 02:34:47.013: Se1/0:30 IPCP: LCP not open, discarding packet

Dec 4 02:34:47.021: Se1/0:30 LCP: I TERMACK [TERMsent] id 14 len 4

Dec 4 02:34:47.301: ISDN Se1/0:15 Q931: RELEASE_COMP pd = 8 callref = 0x000

and the exchange of messages is:

HD : Dec 4 02:34:47.013: Se1/0:30 LCP: O TERMREQ [Open] id 14 len 4

Branch: Dec 4 02:34:47.030: Se1/0:0 LCP: I TERMREQ [Open] id 14 len 4

Branch: Dec 4 02:34:47.030: Se1/0:0 LCP: O TERMACK [Open] id 14 len 4

HD: Dec 4 02:34:47.021: Se1/0:30 LCP: I TERMACK [TERMsent] id 14 len 4

May you provide a filtered version of head end configuration something doesn't work after the message virtualized

Dec 4 02:34:47.009: Se1/0:30 PPP: Phase is FORWARDING, Attempting Forward

Dec 4 02:34:47.009: Se1/0:30 PPP: Phase is ESTABLISHING, Finish LCP

Dec 4 02:34:47.009: Se1/0:30 PPP: Phase is VIRTUALIZED

Dec 4 02:34:47.013: Se1/0:30 PPP: Sending Acct Event[Down] id[1E6]

the head end router terminates the call as you can see above and the branch router agrees.

Your configuration can be missing some command to setup VPDN or be in the middle between classic ISDN and VPDN

Hope to help

Giuseppe

Community Member

Re: ISDN connection is not working.

Hi Giuseppe,

thanks for the information. Please let me know how can I find out the working configuration for my ISDN setup. From the first glance, I dont see any configuration issue, I may be wrong on this. How can i find out that my isdn is VPDN or classic ISDN.

Thanks

Taj

Community Member

Re: ISDN connection is not working.

Hi Giuseppe,

I did another test of isdn with the following debug commands.

debug vpdn event

debug ppp authentication

debug ppp multilink events

debug ppp negotiation

P.S. - Please note that I have renamed router Hdoffice to KimChuan.

If you notice that there is one error message "Vi1 MLP: Invalid dialer Se1/0:30". I am confused why the isdn is trying to establish connection for interface se1/0:30. Do i need to configure ser1/0:30 in the router.

Dec 9 03:11:22.988: Se1/0:30 PPP: Phase is VIRTUALIZED

Dec 9 03:11:22.988: Se1/0:30 MLP: Adding link to bundle

Dec 9 03:11:22.988: Vi1 MLP: Invalid dialer Se1/0:30

Dec 9 03:11:22.988: Se1/0:30 PPP: Sending Acct Event[Down] id[2A]

Dec 9 03:11:22.988: Se1/0:30 PPP: Phase is TERMINATING

Taj

Hall of Fame Super Gold

Re: ISDN connection is not working.

Taj

interface se1/0:30 is a channel on the PRI for the ISDN. I do not believe that you need to configure that channel specifically. In a previous post you gave a very abreviated configuration of the serial interfaces. If there are any other aspects of the serial interface configuration not included in your post it would be good to see them. It might also be helpful if you would post the configuration of the controller of the router for the serial interface.

HTH

Rick

Community Member

Re: ISDN connection is not working.

Hi Rick,

I have attached the configuration from the Hdoffice (Kimchuan) and Broffice (cuppage) routers.

Please let me know what additional configuration i required for this. Also is there any information I need to gather from local Telco on this.

Thanks a lot for your help

Taj

Hall of Fame Super Silver

Re: ISDN connection is not working.

Hello Taj,

now that I see the whole configurations I see that you have enabled AAA new model.

I've reviewed some configurations I used in a similar scenario:

I would add the following in global config:

aaa authentication ppp default local

on both routers

Hope to help

Giuseppe

Community Member

Re: ISDN connection is not working.

Hi Giuseppe,

I have added the 'aaa' statement in the configuration. Additional to that I have also added the following commands in the interface. It is working perfectly now.

aaa authentication ppp default local

!

interface Serial1/0:15

load-interval 30

dialer idle-timeout 600

ppp authentication chap

!

interface Dialer0

load-interval 30

dialer idle-timeout 600

!

I did the 'isdn test call' command and the connection worked very well. The isdn connectivity was up until the idle timeout expired. However I want to know is there any way to forcely close the isdn connection. I did a 'shut/no shut' on int ser1/0:15 to force close the isdn connection. Is this the correct way or is there a better way to do this. However this is not a big concern to me now just would like to know.

My Sincere thanks to you and Rick for walking me through this problem.

My next task would be to make configuration changes so that isdn can auto-establish the conection once the main link is down. The challenge I am forseeing is that the main link (MetroE) is residing in another switch. So I need to configure such that the dialer interface can monitor the MetroE link and initiate isdn once the metroE link is down. I know I need to configure routing with higher metric etc etc. Let me try to figure this out, if I encounter any problem, I know where and who to look for.

Once again thanks a lot to Giuseppe and Rick. Your help is much appreciated.

Regards

Taj

858
Views
0
Helpful
13
Replies
CreatePlease to create content