Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Dial On Demand Issue

Hi all,

I have an issue with isdn ddr.

I have a backup isdn enable by dialer watch; furthemore I have configured a dialer list to enable isdn to make a kind of isdn test with icmp to verify periodic connectivity.

Here yo are my config:

interface BRI0/1/0

no ip address

encapsulation ppp

dialer pool-member 2

snmp trap isdn-calls

isdn switch-type basic-net3

isdn point-to-point-setup

no cdp enable

!

interface Dialer2

ip address negotiated

encapsulation ppp

dialer pool 2

dialer idle-timeout 20

dialer string XXX

dialer max-call 2

dialer watch-group 1

dialer-group 1

keepalive 5

no cdp enable

ppp authentication pap callin

ppp pap XXX

ppp multilink

ppp multilink links minimum 2

!

ip route 10.10.10.10 255.255.255.255 Dialer2

!

access-list 101 permit ip host 192.168.27.82 host 10.10.10.10

dialer watch-list 1 ip 213.39.245.49 255.255.255.255

dialer watch-list 1 delay route-check initial 120

dialer watch-list 1 delay connect 5

dialer watch-list 1 delay disconnect 10

dialer-list 1 protocol ip list 101

Periodically (once a day) I make a ping to test isdn connectivity (ping source 192.168.27.82 dest 10.10.10.10).

After a reload all works fine but

The problem is that...after a while (few days after the reload) the DDR seems not working no more...

With a debug dialer, the same ping doesn't work..

I've just make IOS upgrade/downgrade..but nothing.

Any ideas?

Just an info: in this period ISDN line is out-of-order so all the attempts are in the failure state (about 51..).

Can it correlate to my problem? As after a certain number of failure trials, the ddr is blocking?

Many thanks in advance for your support

Gianluca

  • WAN Routing and Switching
7 REPLIES
Hall of Fame Super Silver

Re: ISDN Dial On Demand Issue

Gianluca

It would be helpful if you would post the output of show isdn status and the output of debug dialer. If we had this information it might show us the problem or at least give some help in what direction to look for the problem.

HTH

Rick

New Member

Re: ISDN Dial On Demand Issue

Hi Rick,

thanks for your support.

Here my output before make my test ping to try to activate DDR:

router#sh isdn status

Global ISDN Switchtype = basic-net3

ISDN BRI0/1/0 interface

dsl 2, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 79, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 2 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

router#sh dialer

BRI0/1/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0/1/0:1 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

BRI0/1/0:2 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Di1 - dialer type = DIALER PROFILE

Idle timer (20 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Number of active calls = 0

Dial String Successes Failures Last DNIS Last status

Di2 - dialer type = DIALER PROFILE

Idle timer (20 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is call pending

Number of active calls = 0

Dial String Successes Failures Last DNIS Last status

019161 0 69 02:18:31 failed Default

As yuo can see there are a lot of failure becuase there is a problem on the isdn concentrator...but this no matter at the moment..

The problem is that if I make a 'debug dialer' and ping with source 192.168.27.82 destination 10.10.10.10...the DDR doesn't work:

router#sh deb

Dial on demand:

Dial on demand events debugging is on

(Of course I'm in terminal monitor...)

ASG-SITE-TEST-2#p

Protocol [ip]:

Target IP address: 10.10.10.10

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 192.168.27.82

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 195.230.254.99, timeout is 2 seconds:

Packet sent with a source address of 192.168.27.82

.....

Success rate is 0 percent (0/5)

ASG-SITE-TEST-2#sh dialer

....output omitted.....

Dial String Successes Failures Last DNIS Last status

019161 0 69 02:25:10 failed Default

THE PING DOESN'T ACTIVATE THE DDR...(last call is 2h ago...)..even if I've configured the dialer list.

I've no output with my debug dialer...

I don't understand why...

If I make a reload..all works fine..

I've tried IOS 12.3(14T7) ; 12.4(13) ; 12.4(18)..same behavior..

Any idea?

Many Thanks

Gianluca

Hall of Fame Super Silver

Re: ISDN Dial On Demand Issue

Gianluca

Thank you for posting the additional details. It is interesting that when you attempt to initiate the call that there is no output in debug dialer. And that is consistent with your observation that not much is happening.

I think that there is a clue to the problem in this line of output from the show dialer for dialer 2:

Dialer state is call pending

if the router thinks that there is a call pending then that might explain why it does not initiate another call. I have not experienced a symptom quite like this and I wonder if a shut/no shut or a clear interface (perhaps on both the BRI as well as the dialer) might clear this up.

HTH

Rick

New Member

Re: ISDN Dial On Demand Issue

Ok Rick, very interesting....

'Call pending', It could be linked to the fact that I've a lot of failure DNIS??

I've done shut/no shut of bri and dialer interface...and a strange message appear after no shut(I'm always with debug dialer on):

router(config-if)#int dialer2

router(config-if)#shut

router(config-if)#

router(config-if)#

router(config-if)#no shutdown

Jan 28 17:45:54.083: Di2 DDR is shutdown, could not clear interface.

Any idea?

After I've done a clear to of both bri and dialer...

Now with show dialer the state is changed:

Dialer state is idle

But the ping doesn't work yet...

Many many thanks for all your support..very important!

Gianluca

Hall of Fame Super Silver

Re: ISDN Dial On Demand Issue

Gianluca

I wonder if this is related to having dialer watch configured on this dialer. As a temporary measure could you remove the dialer watch configuration and see if the behavior changes?

HTH

Rick

New Member

Re: ISDN Dial On Demand Issue

Rick I've removed dialer-watch and the ping doesn't work yet.

Shut/no shut again:

router(config-if)#int dialer2

router(config-if)#sh

router(config-if)#shutdown

Jan 28 18:02:39.226: Di2 DDR: dialer shutdown complete

Jan 28 18:02:41.226: %LINK-5-CHANGED: Interface Dialer2, changed state to administratively down

router(config-if)#int bri0/1/0

router(config-if)#no sh

router(config-if)#no shutdown

Jan 28 18:02:55.758: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to down

Jan 28 18:02:55.758: %LINK-3-UPDOWN: Interface BRI0/1/0:2, changed state to down

Jan 28 18:02:55.810: %LINK-3-UPDOWN: Interface BRI0/1/0, changed state to up

router(config-if)#int dialer2

router(config-if)#no shutdown

router(config-if)#

Jan 28 18:03:06.170: %LINK-3-UPDOWN: Interface Dialer2, changed state to up

Show dialer:

ASG-SITE-TEST-2#sh dialer

BRI0/1/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0/1/0:1 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

BRI0/1/0:2 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Di1 - dialer type = DIALER PROFILE

Idle timer (20 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Number of active calls = 0

Dial String Successes Failures Last DNIS Last status

Di2 - dialer type = DIALER PROFILE

Idle timer (20 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Number of active calls = 0

Dial String Successes Failures Last DNIS Last status

019161 0 69 03:22:55 failed Default

The ping doesn't work yet...siggh...

Gianluca

New Member

Re: ISDN Dial On Demand Issue

Hi Rick,

the problem seems related to call-pending state of dialer as you suggest: every time the dialer goes in this state..tha DDR is blocking.

I think that call-pendinding happens since all the ISDN calls fail since there is a problem in the isdn cloud.

The question is: is it normal that I'm obliged to reload the router to restart DDR? With sht/no shut dialer move to 'idle state'..but DDR remain bolcked.

Many thanks for your support.

Gianluca

422
Views
0
Helpful
7
Replies
This widget could not be displayed.