Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

ISDN host_disconnect_ack: Unfound B-channel

Hi,

I am having problems getting and isdn link up on a cisco 800 series router. I have tested the link on another router and it works fine so the link is good. anyone got any ideas?

5 REPLIES
Hall of Fame Super Gold

Re: ISDN host_disconnect_ack: Unfound B-channel

What is the configuration and IOS version on both working and not working routers ?

New Member

Re: ISDN host_disconnect_ack: Unfound B-channel

Hi.

version that works - 12.2(4r)

Version thats not working - 12.4

I have replaced the BRI card but still the same problem and error message.

thanks

New Member

Re: ISDN host_disconnect_ack: Unfound B-channel

here is my config

Current configuration : 4236 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log datetime localtime show-timezone

service password-encryption

no service dhcp

!

hostname burns

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

!

no aaa new-model

!

resource policy

!

clock timezone GMT 0

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip source-route

ip cef

!

!

no ip dhcp use vrf connected

!

!

no ip bootp server

no ip domain lookup

isdn switch-type basic-net3

!

!

interface Loopback1

description Management Interface

ip address 172.16.9.212 255.255.255.255

!

interface FastEthernet0/0

ip address 10.245.0.211 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

speed 100

full-duplex

no cdp enable

standby 10 ip 10.245.0.209

standby 10 priority 95

standby 10 preempt

standby 10 authentication 9uhfdj

!

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

isdn caller 8701100

isdn caller 4301111

no cdp enable

ppp authentication chap

ppp multilink

!

interface Ethernet1/0

ip address 172.16.9.126 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

full-duplex

no cdp enable

!

interface Dialer0

ip address 172.16.9.58 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name mdrdial

dialer order round-robin

dialer string 4301111

dialer string 8701100

dialer hold-queue 50

dialer load-threshold 128 either

dialer-group 107

no cdp enable

ppp authentication chap

ppp multilink

!

router eigrp 33

redistribute connected

redistribute static

network 172.16.9.124 0.0.0.3

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0 180

ip route 172.16.8.116 255.255.255.255 Dialer0

!

no ip http server

!

logging facility local1

logging source-interface Loopback1

access-list 1 permit 10.245.0.210 log

access-list 1 permit 172.16.8.212 log

access-list 1 permit 172.16.8.213 log

access-list 1 permit 172.16.8.196 log

access-list 1 permit 172.16.8.197 log

access-list 1 permit 172.16.9.125 log

access-list 1 deny any log

access-list 5 permit 172.16.8.212

access-list 5 permit 172.16.8.213

access-list 5 permit 172.16.8.196

access-list 5 permit 172.16.8.197

access-list 5 deny any log

access-list 101 permit icmp 10.245.0.32 0.0.0.15 10.245.0.0 0.0.0.255

access-list 101 permit udp 10.245.0.32 0.0.0.15 10.245.0.0 0.0.0.255 eq isakmp

access-list 101 permit esp 10.245.0.32 0.0.0.15 10.245.0.0 0.0.0.255

access-list 101 permit udp 10.245.0.32 0.0.0.15 host 224.0.0.2 eq 1985

access-list 101 deny ip any host 255.255.255.255

access-list 101 deny ip any any log

access-list 107 permit icmp 0.0.0.112 255.255.255.0 0.0.0.112 255.255.255.0

access-list 107 deny icmp any any

access-list 107 deny udp any any eq syslog

access-list 107 deny udp any any eq ntp

access-list 107 deny udp any any eq snmp

access-list 107 deny udp any any eq snmptrap

access-list 107 permit ip any any

dialer-list 107 protocol ip permit

RO 5

no cdp run

!

Hall of Fame Super Gold

Re: ISDN host_disconnect_ack: Unfound B-channel

hello,

I would try to upgrade the route to 12.(4) latest as first step, then do "term mon" and "debug isdn q931" to see what happens when the router tries to place a call. If call is accepted normally, please do "debug ppp packet" to see the why the ppp handshare is failing.

Hope this helps, please rate post if it does!

Silver

Re: ISDN host_disconnect_ack: Unfound B-channel

Hi ,

configure username and password on router.

username mdrdial password XXXX.

You problem will be sorted out after configuring username and password as you are using "chap " for authentication.

Thanks,

Satish

1435
Views
0
Helpful
5
Replies
CreatePlease to create content