Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN issue only on inbound

Hi all,

I'm a bit lost with an issue on ISDN interfaces...

I'm using ISDN for satellite needs and I'm facing a strange issue on one vessel. Let me explain the case :

  • From the vessel to the HQ ISDN concentrator : everything is OK (here is the debug isdn q931) :

RTLIBERTY-204INMARSAT#ping 172.16.22.185 repeat 30

Type escape sequence to abort.
Sending 30, 100-byte ICMP Echos to 172.16.22.185, timeout is 2 seconds:

*May 22 20:56:03.531: ISDN BR0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 0033496110959#
*May 22 20:56:03.535: ISDN BR0 Q931: TX -> SETUP pd = 8  callref = 0x06
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
                Preferred, B1
        Called Party Number i = 0x80, '0033496110959#'
                Plan:Unknown, Type:Unknown
*May 22 20:56:03.591: ISDN BR0 Q931: RX <- CALL_PROC pd = 8  callref = 0x86
        Channel ID i = 0x89
                Exclusive, B1
        Progress Ind i = 0x8481 - Call not end-to-end ISDN, may have in-band info ..
*May 22 20:56:07.023: %SEC-6-IPACCESSLOGDP: list 110 permitted icmp 172.16.22.150 -> 172.16.22.185 (8/0), 2 packets ...
*May 22 20:56:13.475: ISDN BR0 Q931: RX <- CONNECT pd = 8  callref = 0x86
*May 22 20:56:13.479: %DIALER-6-BIND: Interface BR0:1 bound to profile Di0
*May 22 20:56:13.479: ISDN BR0 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x06..
*May 22 20:56:17.019: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 76 percent (23/30), round-trip min/avg/max = 864/866/872 ms
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#
*May 22 20:56:48.603: ISDN BR0 Q931: RX <- DISCONNECT pd = 8  callref = 0x86
        Cause i = 0x8490 - Normal call clearing
*May 22 20:56:48.607: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di0
RTLIBERTY-204INMARSAT#
*May 22 20:56:48.611: ISDN BR0 Q931: TX -> RELEASE pd = 8  callref = 0x06
        Cause i = 0x8090 - Normal call clearing
*May 22 20:56:48.651: ISDN BR0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x86
RTLIBERTY-204INMARSAT#
*May 22 20:56:49.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to down
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#

  • From the HQ ISDN concentrator to the vessel to : nothing is working... I give you a quite detailed debug (debug isdn q921, debug isdn q931, debug dialer and debug ppp authentication) from both sides :

    • From the Vessel :

RTLIBERTY-204INMARSAT#show isdn status
Global ISDN Switchtype = basic-net3
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0
RTLIBERTY-204INMARSAT#
*May 22 21:14:09.939: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=64 nr=12
*May 22 21:14:09.951: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=64 nr=20
RTLIBERTY-204INMARSAT#
*May 22 21:14:13.059: ISDN BR0 Q921: User RX <- UI sapi=0 tei=127
*May 22 21:14:13.059: ISDN BR0 Q931: SETUP pd = 8  callref = 0x40
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x89
                Exclusive, B1
        Called Party Number i = 0x80, '600971578'
                Plan:Unknown, Type:Unknown
*May 22 21:14:13.063: BR0:1: interface must be fifo queue, force fifo
*May 22 21:14:13.067: %DIALER-6-BIND: Interface BR0:1 bound to profile Di0
*May 22 21:14:13.067: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=20 nr=12
*May 22 21:14:13.071: ISDN BR0 Q931: CALL_PROC pd = 8  callref = 0xC0
        Channel ID i = 0x89
                Exclusive, B1
*May 22 21:14:13.071: BR0:1 PPP: Using dialer call direction
*May 22 21:14:13.071: BR0:1 PPP: Treating connection as a callin
*May 22 21:14:13.071: BR0:1 PPP: Session handle[18000025] Session id[26]
*May 22 21:14:13.083: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=69
*May 22 21:14:13.095: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=21
*May 22 21:14:13.099: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=21 nr=12
*May 22 21:14:13.099: ISDN BR0 Q931: CONNECT pd = 8  callref = 0xC0
*May 22 21:14:13.099: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=70
*May 22 21:14:13.119: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=64, ns=12 nr=21
*May 22 21:14:13.119: ISDN BR0 Q931: RELEASE pd = 8  callref = 0x40
        Cause i = 0x849A - Non-selected user clearing
*May 22 21:14:13.119: ISDN BR0 Q921: User TX -> RR sapi=0 tei=64 nr=13
*May 22 21:14:13.123: BR0 DDR: has total 0 call(s), dial_out 0, dial_in 0
*May 22 21:14:13.123: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di0
*May 22 21:14:13.127: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=62 nr=70
*May 22 21:14:13.127: ISDN BR0 Q931: CONNECT_ACK pd = 8  callref = 0x40
*May 22 21:14:13.127: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=22
*May 22 21:14:13.127: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=22 nr=13
*May 22 21:14:13.131: ISDN BR0 Q931: RELEASE_COMP pd = 8  callref = 0xC0
*May 22 21:14:13.139: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=64, ns=13 nr=22
*May 22 21:14:13.139: ISDN BR0 Q931: STATUS pd = 8  callref = 0x40
        Cause i = 0x84E5 - Message not compatible with call state
        Call State i = 0x13
*May 22 21:14:13.143: ISDN BR0 Q921: User TX -> RR sapi=0 tei=64 nr=14
RTLIBERTY-204INMARSAT#
*May 22 21:14:13.143: ISDN BR0 **ERROR**: L3_BadPeerMsg: event 0x7D cr 0xC0 callid 0x0
*May 22 21:14:13.151: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=23
*May 22 21:14:13.155: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=23 nr=14
*May 22 21:14:13.155: ISDN BR0 Q931: RELEASE pd = 8  callref = 0xC0
        Cause i = 0x80E5 - Message not compatible with call state
*May 22 21:14:13.171: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=24
RTLIBERTY-204INMARSAT#
*May 22 21:14:17.571: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=63 nr=70
*May 22 21:14:17.571: ISDN BR0 Q931: DISCONNECT pd = 8  callref = 0x40
        Cause i = 0x8490 - Normal call clearing
*May 22 21:14:17.595: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=71
*May 22 21:14:17.603: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=64 nr=71
*May 22 21:14:17.603: ISDN BR0 Q931: RELEASE_COMP pd = 8  callref = 0x40
RTLIBERTY-204INMARSAT#
*May 22 21:14:23.171: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=64 nr=14
*May 22 21:14:23.183: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=64 nr=24
RTLIBERTY-204INMARSAT#
*May 22 21:14:27.487: ISDN BR0 Q921: User RX <- UI sapi=0 tei=127
*May 22 21:14:27.487: ISDN BR0 Q931: SETUP pd = 8  callref = 0x40
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x89
                Exclusive, B1
        Called Party Number i = 0x80, '600971578'
                Plan:Unknown, Type:Unknown
*May 22 21:14:27.491: BR0:1: interface must be fifo queue, force fifo
*May 22 21:14:27.491: %DIALER-6-BIND: Interface BR0:1 bound to profile Di0
*May 22 21:14:27.495: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=24 nr=14
*May 22 21:14:27.495: ISDN BR0 Q931: CALL_PROC pd = 8  callref = 0xC0
        Channel ID i = 0x89
                Exclusive, B1
*May 22 21:14:27.499: BR0:1 PPP: Using dialer call direction
*May 22 21:14:27.499: BR0:1 PPP: Treating connection as a callin
*May 22 21:14:27.499: BR0:1 PPP: Session handle[A9000026] Session id[27]
*May 22 21:14:27.511: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=72
*May 22 21:14:27.523: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=25
*May 22 21:14:27.523: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=25 nr=14
*May 22 21:14:27.523: ISDN BR0 Q931: CONNECT pd = 8  callref = 0xC0
*May 22 21:14:27.527: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=73
*May 22 21:14:27.547: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=64, ns=14 nr=25
*May 22 21:14:27.547: ISDN BR0 Q931: RELEASE pd = 8  callref = 0x40
        Cause i = 0x849A - Non-selected user clearing
*May 22 21:14:27.547: ISDN BR0 Q921: User TX -> RR sapi=0 tei=64 nr=15
*May 22 21:14:27.551: BR0 DDR: has total 0 call(s), dial_out 0, dial_in 0
*May 22 21:14:27.551: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di0
*May 22 21:14:27.551: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=65 nr=73
*May 22 21:14:27.551: ISDN BR0 Q931: CONNECT_ACK pd = 8  callref = 0x40
*May 22 21:14:27.555: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=26
*May 22 21:14:27.555: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=26 nr=15
*May 22 21:14:27.555: ISDN BR0 Q931: RELEASE_COMP pd = 8  callref = 0xC0
*May 22 21:14:27.567: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=64, ns=15 nr=26
*May 22 21:14:27.567: ISDN BR0 Q931: STATUS pd = 8  callref = 0x40
        Cause i = 0x84E5 - Message not compatible with call state
        Call State i = 0x13
*May 22 21:14:27.571: ISDN BR0 Q921: User TX -> RR sapi=0 tei=64 nr=16
RTLIBERTY-204INMARSAT#
*May 22 21:14:27.571: ISDN BR0 **ERROR**: L3_BadPeerMsg: event 0x7D cr 0xC0 callid 0x0
*May 22 21:14:27.579: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=27
*May 22 21:14:27.579: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=64, ns=27 nr=16
*May 22 21:14:27.579: ISDN BR0 Q931: RELEASE pd = 8  callref = 0xC0
        Cause i = 0x80E5 - Message not compatible with call state
*May 22 21:14:27.599: ISDN BR0 Q921: User RX <- RR sapi=0 tei=64 nr=28
RTLIBERTY-204INMARSAT#
*May 22 21:14:31.999: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=66 nr=73
*May 22 21:14:31.999: ISDN BR0 Q931: DISCONNECT pd = 8  callref = 0x40
        Cause i = 0x8490 - Normal call clearing
*May 22 21:14:32.023: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=74
*May 22 21:14:32.027: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=67 nr=74
*May 22 21:14:32.027: ISDN BR0 Q931: RELEASE_COMP pd = 8  callref = 0x40
RTLIBERTY-204INMARSAT#
*May 22 21:14:37.599: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=64 nr=16
*May 22 21:14:37.611: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=64 nr=28
RTLIBERTY-204INMARSAT#ter no mon
*May 22 21:14:42.039: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=66 nr=74
RTLIBERTY-204INMARSAT#ter no mon
RTLIBERTY-204INMARSAT#
RTLIBERTY-204INMARSAT#

    • From the HQ ISDN Concentrator :

MA2811#
*Nov 10 18:07:12.171: ISDN BR0/1/0 **ERROR**: handle_l2d_srq_mail: Layer 1 inactive
*Nov 10 18:07:12.331: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/1/0, TEI 65 changed to up
*Nov 10 18:07:12.335: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8  callref = 0x05
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:12.475: ISDN BR0/1/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x85
        Channel ID i = 0x89
*Nov 10 18:07:12.767: ISDN BR0/1/0 Q931: RX <- CALL_PROC pd = 8  callref = 0x85
        Channel ID i = 0x89
*Nov 10 18:07:19.063: ISDN BR0/1/0 Q931: RX <- ALERTING pd = 8  callref = 0x85
*Nov 10 18:07:19.375: ISDN BR0/1/0 Q931: RX <- CONNECT pd = 8  callref = 0x85
*Nov 10 18:07:19.379: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to up
*Nov 10 18:07:19.383: %DIALER-6-BIND: Interface BR0/1/0:1 bound to profile Di150
*Nov 10 18:07:19.383: %ISDN-6-CONNECT: Interface BRI0/1/0:1 is now connected to 00870600971578 N/A
*Nov 10 18:07:19.383: ISDN BR0/1/0 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x05
*Nov 10 18:07:22.667: %ISDN-6-CONNECT: Interface BRI0/1/0:1 is now connected to 00870600971578 bourbon-liberty204
*Nov 10 18:07:22.667: %ISDN-6-DISCONNECT: Interface BRI0/1/0:1  disconnected from 00870600971578 bourbon-liberty204, call lasted 3 seconds
*Nov 10 18:07:22.671: ISDN BR0/1/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x05
        Cause i = 0x8090 - Normal call clearing
*Nov 10 18:07:22.831: ISDN BR0/1/0 Q931: RX <- RELEASE pd = 8  callref = 0x85
*Nov 10 18:07:22.835: %LINK-3-UPDOWN: Interface BRI0/1/0:1, changed state to down
*Nov 10 18:07:22.839: %DIALER-6-UNBIND: Interface BR0/1/0:1 unbound from profile Di150
*Nov 10 18:07:22.839: ISDN BR0/1/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x05
*Nov 10 18:07:22.855: ISDN BR0/1/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00870600971578
*Nov 10 18:07:22.855: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8  callref = 0x06
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:22.995: ISDN BR0/1/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x86
        Channel ID i = 0x89
*Nov 10 18:07:23.275: ISDN BR0/1/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x86
        Cause i = 0x8791 - User busy
*Nov 10 18:07:23.283: ISDN BR0/1/0 Q931: TX -> RELEASE pd = 8  callref = 0x06
        Cause i = 0x8091 - User busy
*Nov 10 18:07:23.303: ISDN BR0/3/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00870600971578
*Nov 10 18:07:23.315: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 65 changed to up
*Nov 10 18:07:23.319: ISDN BR0/3/0 Q931: TX -> SETUP pd = 8  callref = 0x07
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:23.363: ISDN BR0/1/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x86
*Nov 10 18:07:23.455: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x87
        Channel ID i = 0x89
*Nov 10 18:07:23.459: ISDN BR0/3/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x87
        Channel ID i = 0x89
*Nov 10 18:07:23.747: ISDN BR0/0/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x87
        Cause i = 0x8791 - User busy
*Nov 10 18:07:23.747: ISDN BR0/3/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x87
        Cause i = 0x8791 - User busy
*Nov 10 18:07:23.751: ISDN BR0/3/0 Q931: TX -> RELEASE pd = 8  callref = 0x07
        Cause i = 0x8091 - User busy
*Nov 10 18:07:23.839: ISDN BR0/0/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x87
*Nov 10 18:07:23.839: ISDN BR0/3/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x87
*Nov 10 18:07:23.863: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00870600971578
*Nov 10 18:07:23.875: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 64 changed to up
*Nov 10 18:07:23.879: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x08
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:24.031: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x88
        Channel ID i = 0x89
*Nov 10 18:07:24.031: ISDN BR0/3/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x88
        Channel ID i = 0x89
*Nov 10 18:07:24.327: ISDN BR0/0/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x88
        Cause i = 0x8791 - User busy
*Nov 10 18:07:24.327: ISDN BR0/3/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x88
        Cause i = 0x8791 - User busy
*Nov 10 18:07:24.339: ISDN BR0/0/0 Q931: TX -> RELEASE pd = 8  callref = 0x08
        Cause i = 0x8091 - User busy
*Nov 10 18:07:24.407: ISDN BR0/0/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x88
*Nov 10 18:07:24.407: ISDN BR0/3/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x88
*Nov 10 18:07:24.423: ISDN BR0/3/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00870600971578
*Nov 10 18:07:24.423: ISDN BR0/3/0 Q931: TX -> SETUP pd = 8  callref = 0x09
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:24.559: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x89
        Channel ID i = 0x89
*Nov 10 18:07:24.559: ISDN BR0/3/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x89
        Channel ID i = 0x89
*Nov 10 18:07:24.863: ISDN BR0/0/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x89
        Cause i = 0x8791 - User busy
*Nov 10 18:07:24.863: ISDN BR0/3/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x89
        Cause i = 0x8791 - User busy
*Nov 10 18:07:24.867: ISDN BR0/3/0 Q931: TX -> RELEASE pd = 8  callref = 0x09
        Cause i = 0x8091 - User busy
*Nov 10 18:07:24.875: ISDN BR0/2/0 **ERROR**: handle_l2d_srq_mail: Layer 1 inactive
*Nov 10 18:07:24.939: ISDN BR0/0/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x89
*Nov 10 18:07:24.939: ISDN BR0/3/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x89
*Nov 10 18:07:25.043: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/2/0, TEI 64 changed to up
*Nov 10 18:07:25.047: ISDN BR0/2/0 Q931: TX -> SETUP pd = 8  callref = 0x0A
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:25.171: ISDN BR0/2/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x8A
        Channel ID i = 0x89
*Nov 10 18:07:25.443: ISDN BR0/2/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x8A
        Cause i = 0x8791 - User busy
*Nov 10 18:07:25.447: ISDN BR0/2/0 Q931: TX -> RELEASE pd = 8  callref = 0x0A
        Cause i = 0x8091 - User busy
*Nov 10 18:07:25.515: ISDN BR0/2/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8A
*Nov 10 18:07:25.543: ISDN BR0/3/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00870600971578
*Nov 10 18:07:25.543: ISDN BR0/3/0 Q931: TX -> SETUP pd = 8  callref = 0x0B
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
        Called Party Number i = 0x80, '00870600971578'
                Plan:Unknown, Type:Unknown
*Nov 10 18:07:25.679: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x8B
        Channel ID i = 0x89
*Nov 10 18:07:25.679: ISDN BR0/3/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x8B
        Channel ID i = 0x89
*Nov 10 18:07:25.975: ISDN BR0/0/0 Q931: RX <- CALL_PROC pd = 8  callref = 0x8B
        Channel ID i = 0x89
*Nov 10 18:07:25.979: ISDN BR0/3/0 Q931: RX <- CALL_PROC pd = 8  callref = 0x8B
        Channel ID i = 0x89
*Nov 10 18:07:27.279: ISDN BR0/1/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2
*Nov 10 18:07:28.399: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 64 changed to down
*Nov 10 18:07:28.403: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2
*Nov 10 18:07:29.475: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/2/0, TEI 64 changed to down
*Nov 10 18:07:29.479: ISDN BR0/2/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2
*Nov 10 18:07:33.531: ISDN BR0/0/0 Q931: RX <- ALERTING pd = 8  callref = 0x8B
*Nov 10 18:07:33.531: ISDN BR0/3/0 Q931: RX <- ALERTING pd = 8  callref = 0x8B
*Nov 10 18:07:33.771: ISDN BR0/0/0 Q931: RX <- CONNECT pd = 8  callref = 0x8B
*Nov 10 18:07:33.771: ISDN BR0/3/0 Q931: RX <- CONNECT pd = 8  callref = 0x8B
*Nov 10 18:07:33.775: %LINK-3-UPDOWN: Interface BRI0/3/0:1, changed state to up
*Nov 10 18:07:33.775: %DIALER-6-BIND: Interface BR0/3/0:1 bound to profile Di150
*Nov 10 18:07:33.775: %ISDN-6-CONNECT: Interface BRI0/3/0:1 is now connected to 00870600971578 N/A
*Nov 10 18:07:33.779: ISDN BR0/3/0 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x0B
*Nov 10 18:07:37.063: %ISDN-6-CONNECT: Interface BRI0/3/0:1 is now connected to 00870600971578 bourbon-liberty204
*Nov 10 18:07:37.063: %ISDN-6-DISCONNECT: Interface BRI0/3/0:1  disconnected from 00870600971578 bourbon-liberty204, call lasted 3 seconds
*Nov 10 18:07:37.067: ISDN BR0/3/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x0B
        Cause i = 0x8090 - Normal call clearing
*Nov 10 18:07:37.243: ISDN BR0/0/0 Q931: RX <- RELEASE pd = 8  callref = 0x8B
*Nov 10 18:07:37.243: ISDN BR0/3/0 Q931: RX <- RELEASE pd = 8  callref = 0x8B
*Nov 10 18:07:37.247: %LINK-3-UPDOWN: Interface BRI0/3/0:1, changed state to down
*Nov 10 18:07:37.247: %DIALER-6-UNBIND: Interface BR0/3/0:1 unbound from profile Di150
*Nov 10 18:07:37.251: ISDN BR0/3/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0B
*Nov 10 18:07:41.203: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 65 changed to down
MA2811#


Another thing to add, there are only 3 or 4 vessels on which we are encountering this issue. Approximately a hundreed others are running quite well with exactly the same configs.

I give you the Vessel ISDN Config, a Cisco 876 router running (Cisco IOS Software, C870 Software (C870-ADVENTERPRISEK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)) :

RTVESSELINMARSAT#sh run
Building configuration...

<...>

!
multilink bundle-name authenticated
isdn switch-type basic-net3
!
!
username xxx privilege 15 secret 5 xxx
username xxx password 7 xxx
username xxx password 7 xxx
username xxx privilege 3 secret 5 xxx
username xxx privilege 15 secret 5 xxx
!
!
<...>
!        
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
isdn point-to-point-setup
no keepalive
no cdp enable
!
<...>
!
interface Dialer0
description ### MARSEILLE 0033496110959 ###
ip address 172.16.22.150 255.255.255.0
ip nat inside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer remote-name ma2610b
dialer idle-timeout 15
dialer string "0033496110959#"
dialer-group 1
no keepalive
ppp chap hostname liberty-204
!
<...>

!
access-list 110 permit ip 172.16.150.228 0.0.0.1 172.16.18.126 0.0.0.1 log
access-list 110 permit tcp 172.16.22.150 0.0.1.0 eq telnet host 172.16.18.151 log
access-list 110 permit icmp 172.16.22.150 0.0.1.0 host 172.16.18.151 log
access-list 110 permit icmp 172.16.22.150 0.0.1.0 172.16.22.185 0.0.1.0 log
access-list 110 deny   ip any any
dialer-list 1 protocol ip list 110
!

<...>
!
scheduler max-task-time 5000
ntp server 192.168.254.251
end

I give you the HQ ISDN Concentrator Config, a Cisco 2811 router with WIC-1B-S/T-V3 (3) running (Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(19), RELEASE SOFTWARE (fc1)) :

MA2811#sh run int dial150
Building configuration...

Current configuration : 364 bytes
!
interface Dialer150
description ### LIBERTY-204 00870600971578 #V# ###
ip unnumbered Loopback1
ip access-group Acl_Dialer150-out out
encapsulation ppp
dialer pool 1
dialer remote-name liberty-204
dialer idle-timeout 10
dialer string 00870600971578
dialer-group 1
no keepalive
no cdp enable
ppp authentication chap pap
ppp chap hostname ma2610b
end

Many thanks for your help !!!

/plg

1 REPLY
Hall of Fame Super Silver

Re: ISDN issue only on inbound

Hello Plg,

>> May 22 21:14:13.119: ISDN BR0 Q931: RELEASE pd = 8  callref = 0x40

        Cause i = 0x849A - Non-selected user clearing

you may refer to the tables reported in the following link to decode the error message

http://www.cisco.com/en/US/docs/ios/11_3/debug/command/reference/disdn.html

"vessel side" is so fast in disconnecting that later other side is still attempting to proceed

>> *May 22 21:14:13.139: ISDN BR0 Q931: STATUS pd = 8  callref = 0x40

        Cause i = 0x84E5 - Message not compatible with call state

        Call State i = 0x13

>> RTLIBERTY-204INMARSAT#

*May 22 21:14:13.143: ISDN BR0 **ERROR**: L3_BadPeerMsg: event 0x7D cr 0xC0 callid 0x0

Hope to help

Giuseppe

1612
Views
0
Helpful
1
Replies
CreatePlease login to create content