Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ISDN outband call not working or not permitted?

Hi guys

I got a 2 devices CPE_BE and DC_UK. From CPE_BE I cannot perform any ISDN outband call (international and national) however from the DC_UK I can call the ISDN line of CPE_BE, I can see the authentication etc etc, call is setup properly.

I think it could be the telco supplier not permitting the outband call on their ISDN line.. I am not sure it can be a network issue else if the inbound call shouldn't work?

Log from CPE_BE when I tried to call DC_UK:

*Aug 19 12:51:27.935 UTC: ISDN BR0/0/0 Q921: L2_EstablishDataLink: sending SABME
*Aug 19 12:51:27.935 UTC: ISDN BR0/0/0 Q921: User TX -> SABMEp sapi=0 tei=68
*Aug 19 12:51:28.019 UTC: ISDN BR0/0/0 Q921: User RX <- UAf sapi=0 tei=68
*Aug 19 12:51:28.019 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 68 changed to up
*Aug 19 12:51:28.043 UTC: ISDN BR0/0/0 Q921: User TX -> INFO sapi=0 tei=68, ns=0 nr=0
*Aug 19 12:51:28.043 UTC: ISDN BR0/0/0 Q931: SETUP pd = 8  callref = 0x29
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
                Preferred, B1
        Called Party Number i = 0x80, '00XXXXXXXXXX'
                Plan:Unknown, Type:Unknown
*Aug 19 12:51:28.159 UTC: ISDN BR0/0/0 Q921: User RX <- RR sapi=0 tei=68 nr=1
*Aug 19 12:51:28.615 UTC: ISDN BR0/0/0 Q921: User RX <- INFO sapi=0 tei=68, ns=0 nr=1
*Aug 19 12:51:28.615 UTC: ISDN BR0/0/0 Q931: SETUP_ACK pd = 8  callref = 0xA9
        Channel ID i = 0x89
                Exclusive, B1
*Aug 19 12:51:28.619 UTC: ISDN BR0/0/0 Q921: User TX -> RR sapi=0 tei=68 nr=1
*Aug 19 12:51:31.931 UTC: ISDN BR0/0/0 Q921: User TX -> INFO sapi=0 tei=68, ns=1 nr=1
*Aug 19 12:51:31.931 UTC: ISDN BR0/0/0 Q931: DISCONNECT pd = 8  callref = 0x29
        Cause i = 0x8090 - Normal call clearing
*Aug 19 12:51:32.035 UTC: ISDN BR0/0/0 Q921: User RX <- RR sapi=0 tei=68 nr=2
*Aug 19 12:51:32.475 UTC: ISDN BR0/0/0 Q921: User RX <- INFO sapi=0 tei=68, ns=1 nr=2
*Aug 19 12:51:32.475 UTC: ISDN BR0/0/0 Q931: RELEASE pd = 8  callref = 0xA9
*Aug 19 12:51:32.479 UTC: ISDN BR0/0/0 Q921: User TX -> RR sapi=0 tei=68 nr=2
*Aug 19 12:51:32.479 UTC: ISDN BR0/0/0 Q921: User TX -> INFO sapi=0 tei=68, ns=2 nr=2
*Aug 19 12:51:32.479 UTC: ISDN BR0/0/0 Q931: RELEASE_COMP pd = 8  callref = 0x29
*Aug 19 12:51:32.595 UTC: ISDN BR0/0/0 Q921: User RX <- RR sapi=0 tei=68 nr=3
*Aug 19 12:51:42.543 UTC: ISDN BR0/0/0 Q921: User RX <- RRp sapi=0 tei=68 nr=3
*Aug 19 12:51:42.543 UTC: ISDN BR0/0/0 Q921: User TX -> RRf sapi=0 tei=68 nr=2
*Aug 19 12:51:47.699 UTC: ISDN BR0/0/0 Q921: User RX <- DISCp sapi=0 tei=68
*Aug 19 12:51:47.699 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 68 changed to down
*Aug 19 12:51:47.707 UTC: ISDN BR0/0/0 Q921: User TX -> UAf sapi=0 tei=68
*Aug 19 12:51:47.719 UTC: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

CPE_BE #sh isdn stat

Global ISDN Switchtype = basic-net3
ISDN BRI0/0/0 interface
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 68, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0

Thanks in advance for your suggestion

17 REPLIES
Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

Which exact IOS is this? Seems REALLY OLD as the frame direction at layer 3 is not reported.

However it seems it is teh BE router itself disconnecting.

Update router as necessary and repeat layer 3 trace. No layer 2 trace is necessary.

New Member

Re: ISDN outband call not working or not permitted?

The IOS is  c1841-advipservicesk9-mz.124-15.T6.bin, but I also got the same issue with an other site with the IOS c1841-advipservicesk9-mz.124-15.T9.bin. However I got already a site with the IOS c1841-advipservicesk9-mz.124-15.T9.bin which is calling out without any issue

Is there is way to know from the router if the call out aren't permitted?

I did try debug isdn q93/92 and erros, but the log doesn't seem talking

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

Please send "show isdn timers".

There is no progress from network after setupc ack, so router waits 4 secodns and disconnects.

New Member

Re: ISDN outband call not working or not permitted?

When I take the debug isdn q931 I haven 't a lot of details:

*Aug 19 13:50:21.978 UTC: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00xxxxxxxxxxxx
*Aug 19 13:50:22.058 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 68 changed to up
*Aug 19 13:50:22.078 UTC: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x32
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
                Preferred, B1
        Called Party Number i = 0x80, '
00xxxxxxxxxxxx'
                Plan:Unknown, Type:Unknown
*Aug 19 13:50:22.638 UTC: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0xB2
        Channel ID i = 0x89
                Exclusive, B1
*Aug 19 13:50:25.974 UTC: ISDN BR0/0/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x32
        Cause i = 0x8090 - Normal call clearing
*Aug 19 13:50:26.530 UTC: ISDN BR0/0/0 Q931: RX <- RELEASE pd = 8  callref = 0xB2
*Aug 19 13:50:26.534 UTC: ISDN BR0/0/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x32
*Aug 19 13:50:41.746 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 68 changed to down
*Aug 19 13:50:41.762 UTC: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

When I take the debug isdn TGRM I have the below:

*Aug 19 13:49:42.670 UTC: ISDN BR0/0/0 TGRM: get_tgrm_avail_state: idb 0x64A3460C bchan 1 service_state 0 call_state 1 false busy 0x0 dsl 0
*Aug 19 13:49:42.670 UTC: ISDN BR0/0/0 TGRM: update_tgrm_call_status: idb 0x64A3460C bchan 1 availability state 1 call state(prev,new) (0,1), dsl 0
*Aug 19 13:49:42.670 UTC: ISDN BR0/0/0 TGRM: update_tgrm_call_status: Calling TGRM with tgrm_call_isdn_update: idb 0x64A3460C bchan 1 call state 2 call type 1 call dir 2
*Aug 19 13:49:42.770 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 68 changed to up
*Aug 19 13:49:43.366 UTC: ISDN BR0/0/0 TGRM: get_tgrm_avail_state: idb 0x64A3460C bchan 1 service_state 0 call_state 2 false busy 0x0 dsl 0
*Aug 19 13:49:43.370 UTC: ISDN BR0/0/0 TGRM: update_tgrm_call_status: idb 0x64A3460C bchan 1 availability state 1 call state(prev,new) (1,2), dsl 0
*Aug 19 13:49:43.370 UTC: ISDN BR0/0/0 TGRM: update_tgrm_call_status: Calling TGRM with tgrm_call_isdn_update: idb 0x64A3460C bchan 1 call state 1 call type 1 call dir 2
*Aug 19 13:49:47.350 UTC: ISDN BR0/0/0 TGRM: get_tgrm_avail_state: idb 0x64A3460C bchan 1 service_state 0 call_state 0 false busy 0x0 dsl 0
*Aug 19 13:49:47.350 UTC: ISDN BR0/0/0 TGRM: update_tgrm_call_status: idb 0x64A3460C bchan 1 availability state 1 call state(prev,new) (2,0), dsl 0
*Aug 19 13:49:47.350 UTC: ISDN BR0/0/0 TGRM: update_tgrm_call_status: Calling TGRM with tgrm_call_isdn_update: idb 0x64A3460C bchan 1 call state 0 call type 0 call dir 1

*Aug 19 13:50:02.582 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 68 changed to down

and

show isdn timers
    ISDN BRI0/0/0 Timers (dsl 0) Switchtype = basic-net3
        ISDN Layer 2 values
         K     =   1 outstanding I-frames
         N200  =   3 max number of retransmits
         N202  =   2 max number of TEI ID Request retransmits
         T200  =   1.000 seconds
         T202  =   2.000 seconds
         T203  =  10.000 seconds
        ISDN Layer 3 values
         T301  = 180.000 seconds
         T303  =   4.000 seconds
         T304  =  30.000 seconds
         T305  =  30.000 seconds
         T306  =  30.000 seconds
         T307  = 180.000 seconds
         T308  =   4.000 seconds
         T309    Disabled
         T310  =  40.000 seconds
         T313  =   4.000 seconds
         T316  = 120.000 seconds
         T318  =   4.000 seconds
         T319  =   4.000 seconds
         T322  =   4.000 seconds
         T3OOS =   5.000 seconds
         TGUARD=   3.000 seconds, Expiry = REJECT_CALL
        *** dsl 1 is not configured
        *** dsl 2 is not configured
        *** dsl 3 is not configured
        *** dsl 4 is not configured
        *** dsl 5 is not configured
        *** dsl 6 is not configured
        *** dsl 7 is not configured
        *** dsl 8 is not configured
        *** dsl 9 is not configured
        *** dsl 10 is not configured
        *** dsl 11 is not configured
        *** dsl 12 is not configured
        *** dsl 13 is not configured
        *** dsl 14 is not configured
        *** dsl 15 is not configured
        *** dsl 16 is not configured
        *** dsl 17 is not configured
        *** dsl 18 is not configured
        *** dsl 19 is not configured
        *** dsl 20 is not configured
        *** dsl 21 is not configured
        *** dsl 22 is not configured
        *** dsl 23 is not configured
        *** dsl 24 is not configured
        *** dsl 25 is not configured
        *** dsl 26 is not configured
        *** dsl 27 is not configured
        *** dsl 28 is not configured
        *** dsl 29 is not configured
        *** dsl 30 is not configured
        *** dsl 31 is not configured

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

Q931 is all what we need.

The router is behaving strange. Disconnect is sent 4 seconds after initial message. But, you should have "dialer-wait-for-carrier" left to the default of 30 seconds.

Incidentally, there are few T3xx timers set to 4 seconds, but none is relevant to this case.

Conclusion: either router is not waiting enough for the call to complete, or the BE telco has interconnection trouble.

What is sure, if telco could complete call in the typical 1 - 2 seconds, there would be no trouble

New Member

Re: ISDN outband call not working or not permitted?

disconnection after 4 is caused by my command : dialer wait-for-carrier-time 4. By removing it it's still the same issue the L2 came always down instead of staying up:

Aug 19 14:00:30.054 UTC: ISDN BR0/0/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x35
        Cause i = 0x8090 - Normal call clearing
*Aug 19 14:00:30.598 UTC: ISDN BR0/0/0 Q931: RX <- RELEASE pd = 8  callref = 0xB5
*Aug 19 14:00:30.602 UTC: ISDN BR0/0/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x35
*Aug 19 14:00:45.790 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 68 changed to down
*Aug 19 14:00:45.806 UTC: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

Normally I should have the CPE_BE calling the DC_UK, UK_DC disconnect the session (but L2 still up) and DC call back the CPE_BE:

*Aug 19 14:08:28.056 UTC: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00XXXXXXXXX
*Aug 19 14:08:28.072 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 96 changed to up
CPE#
*Aug 19 14:08:28.092 UTC: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x1B
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
                Preferred, B1
        Called Party Number i = 0x80, '00XXXXXXXXX'
                Plan:Unknown, Type:Unknown
*Aug 19 14:08:28.304 UTC: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0x9B
        Channel ID i = 0x89
                Exclusive, B1
*Aug 19 14:08:33.340 UTC: ISDN BR0/0/0 Q931: RX <- CALL_PROC pd = 8  callref = 0x9B
*Aug 19 14:08:37.000 UTC: ISDN BR0/0/0 Q931: RX <- DISCONNECT pd = 8  callref = 0x9B
        Cause i = 0x8095 - Call rejected
*Aug 19 14:08:37.004 UTC: ISDN BR0/0/0 Q931: TX -> RELEASE pd = 8  callref = 0x1B
        Cause i = 0x8095 - Call rejected
*Aug 19 14:08:37.068 UTC: ISDN BR0/0/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x9B
        Cause i = 0x8095 - Call rejected
*Aug 19 14:08:38.580 UTC: ISDN BR0/0/0 Q931: RX <- SETUP pd = 8  callref = 0x78
        Sending Complete
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x8A
                Exclusive, B2
        Calling Party Number i = 0x0183, '00XXXXXXXXX'
                Plan:ISDN, Type:Unknown
        Called Party Number i = 0xA1, '00YYYYYYY'
                Plan:ISDN, Type:National
*Aug 19 14:08:38.584 UTC: %DIALER-6-BIND: Interface BR0/0/0:2 bound to profile Di100
*Aug 19 14:08:38.588 UTC: %LINK-3-UPDOWN: Interface BRI0/0/0:2, changed state to up
*Aug 19 14:08:38.588 UTC: %ISDN-6-CONNECT: Interface BRI0/0/0:2 is now connected to 00XXXXXXXXX N/A
*Aug 19 14:08:38.588 UTC: ISDN BR0/0/0 Q931: TX -> CALL_PROC pd = 8  callref = 0xF8
        Channel ID i = 0x8A
                Exclusive, B2
*Aug 19 14:08:38.620 UTC: ISDN BR0/0/0 Q931: TX -> CONNECT pd = 8  callref = 0xF8
*Aug 19 14:08:38.684 UTC: ISDN BR0/0/0 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x78
*Aug 19 14:08:40.336 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0/0:2, changed state to up
*Aug 19 14:08:44.588 UTC: %ISDN-6-CONNECT: Interface BRI0/0/0:2 is now connected to 00XXXXXXXXX DC_Uk
CPE#

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

You should have mentioned that you have been tinkering with timers.

Please remove the incorrect dialer command and take the trace again, plus "debug ppp negotiation" and "debug ppp authentication.

Do not take traces for incoming calls to BE router.

New Member

Re: ISDN outband call not working or not permitted?

L3 hasn't the time to perform as L2 disconnect after few seconds . Below is the log after a debug isdn q931 + debug ppp neg + debug ppp aut:

CPE_BE#isdn test call int bri 0/0/0 00nnnnnnnnnn
CPE_BE#
*Aug 19 14:37:01.950 UTC: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 00nnnnnnnnnn
*Aug 19 14:37:02.030 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 68 changed to up
*Aug 19 14:37:02.054 UTC: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x37
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
                Preferred, B1
        Called Party Number i = 0x80, '00nnnnnnnnnn'
                Plan:Unknown, Type:Unknown
*Aug 19 14:37:02.626 UTC: ISDN BR0/0/0 Q931: RX <- SETUP_ACK pd = 8  callref = 0xB7
        Channel ID i = 0x89
                Exclusive, B1
*Aug 19 14:37:05.946 UTC: ISDN BR0/0/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x37
        Cause i = 0x8090 - Normal call clearing
*Aug 19 14:37:06.470 UTC: ISDN BR0/0/0 Q931: RX <- RELEASE pd = 8  callref = 0xB7
*Aug 19 14:37:06.474 UTC: ISDN BR0/0/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x37
*Aug 19 14:37:21.630 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 68 changed to down
*Aug 19 14:37:21.650 UTC: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

New Member

Re: ISDN outband call not working or not permitted?

What i can see is when I dial out I have :

Plan:Unknown, Type:Unknown

instead of    Plan:ISDN, Type:National

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

L3 hasn't the time to perform as L2 disconnect after few seconds .

Incorrect, there is no L2 disconnection happening here

*Aug 19 14:37:02.054 UTC: ISDN BR0/0/0 Q931: TX -> SETUP pd = 8  callref = 0x37
*Aug 19 14:37:05.946 UTC: ISDN BR0/0/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x37

4 seconds approx. have elapsed between events, do you still have the inappropriate "isdn wait-for-carrier-time 4" command in place ?

New Member

Re: ISDN outband call not working or not permitted?

*Aug 19 14:37:21.630 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 68 changed to down

The aboce line is showing L2 down ?

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

That is normal, on BRIs L1 and L2 are disactivated by CO after a timeout. And, the L2 is brought down AFTER the call has failed already.

You can use "isdn tei-negotiation preserver" to avood getting a new TEI every time.

Now for the weird issue, reload the router.

New Member

Re: ISDN outband call not working or not permitted?

yeah already tried but still same issue after that

Anyway thanks for your help   much appreciated

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

Please include full configuration (do not use attachments), and repeat the trace with "debug dialer"

.

New Member

Re: ISDN outband call not working or not permitted?

nop it's not here anymore

Hall of Fame Super Gold

Re: ISDN outband call not working or not permitted?

Please set "dialer wait-for-carrier-time" to something like 30, explicitely.

New Member

Re: ISDN outband call not working or not permitted?

Even with the command setup at 30 instead of 4 I still have the 4 seconds disconnection

I know it's crazy, I start to become nuts :'(

1001
Views
0
Helpful
17
Replies
CreatePlease to create content