Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN problems

Hi, I have a serious problem with ISDN backup.

The call is up for only few seconds.

But the main problem is another, if i do a sh logging i have:

Dec 20 00:02:08.793: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 91 changed to down

Dec 20 01:46:30.580: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 92 changed to up

Dec 20 01:46:43.816: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 92 changed to down

Dec 20 02:02:29.496: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 93 changed to up

Dec 20 02:02:43.800: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 93 changed to down

Dec 20 06:02:29.535: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 94 changed to up

Dec 20 06:02:43.735: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 94 changed to down

Dec 20 06:18:29.543: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 95 changed to up

Dec 20 06:18:43.731: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 95 changed to down

Dec 20 09:45:03.354: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 96 changed to up

Dec 20 09:45:13.678: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 96 changed to down

Dec 20 10:22:36.962: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 97 changed to up

Dec 20 10:22:48.666: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 97 changed to down

Dec 20 10:38:29.558: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 98 changed to up

Dec 20 10:38:43.670: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 98 changed to down

Dec 20 11:42:53.062: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 99 changed to up

Dec 20 11:43:03.646: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 99 changed to down

Dec 20 12:17:23.118: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 100 changed to up

Dec 20 12:17:33.634: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 100 changed to down

Dec 20 12:55:33.082: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 101 changed to up

Dec 20 12:55:43.622: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 101 changed to down

Dec 20 13:31:47.477: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 102 changed to up

Dec 20 13:31:58.621: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 102 changed to down

Dec 20 13:33:30.629: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 103 changed to up

Dec 20 13:33:43.613: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 103 changed to down

Dec 20 13:34:54.997: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 104 changed to up

Dec 20 13:35:08.617: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 104 changed to down

Dec 20 13:49:00.513: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 107 changed to up

Dec 20 13:49:13.429: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 107 changed to down

Dec 20 13:58:47.673: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 108 changed to up

Dec 20 13:58:58.429: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 108 changed to down

Dec 20 14:44:29.361: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 109 changed to up

Dec 20 14:44:43.433: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 109 changed to down

Dec 20 15:00:29.365: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 111 changed to up

Dec 20 15:00:43.409: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 111 changed to down

Dec 20 15:53:04.021: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 64 changed to up

Dec 20 15:53:18.437: %ISDN-3-LAYER2_DOWN: Layer 2 for Interface BR0, TEI 64 changed to down

What means???? are there problems with ISDN LINE ????

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: ISDN problems

Hello,

if the real name of the calling router is not configured on the called router, you need to define the username you have defined, 'send' in your case, in the CHAP configuration. Therefore, you need to configure:

ppp chap hostname send

ppp chap password send

on the calling router.

Regards,

GP

19 REPLIES
VIP Purple

Re: ISDN problems

Hello,

this could be an authentication problem. Can you post the configurations of both your routers ?

Regards,

GP

New Member

Re: ISDN problems

Router 1721 (router that sending call)

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Sendigcall

boot-start-marker

boot system flash 1721.bin

boot-end-marker

!

logging buffered 10000 debugging

enable secret 5

enable password 7

!

username send password 7

username receive password 7

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

!

ip cef

ip audit po max-events 100

no ftp-server write-enable

!

isdn switch-type basic-net3

isdn logging

!

!

!

!

!

!

interface Loopback0

ip address aaa.aaa.aaa.aaa 255.255.255.255

ip nat outside

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn send-alerting

isdn sending-complete

no fair-queue

no cdp enable

ppp authentication chap callin

!

interface FastEthernet0

ip address 192.168.1.254 255.255.255.0

ip nat inside

speed auto

!

interface Serial0

no ip address

encapsulation frame-relay IETF

no fair-queue

!

interface Serial0.1 point-to-point

ip address bbb.bbb.bbb.bbb 255.255.255.252

ip nat outside

frame-relay interface-dlci number

!

interface Dialer1

ip address ccc.ccc.ccc.ccc 255.255.255.252

ip nat outside

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name receive

dialer idle-timeout 3

dialer string 06.......

dialer watch-group 1

no cdp enable

ppp authentication chap callin

!

router eigrp 1

redistribute connected

network bbb.bbb.bbb.bbb 0.0.0.3

network ccc.ccc.ccc.ccc 0.0.0.3

auto-summary

!

ip nat inside source list 101 interface Loopback0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 bbb.bbb.bbb.bbb

ip route 0.0.0.0 0.0.0.0 Dialer1 250

no ip http server

no ip http secure-server

!

!

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

dialer watch-list 1 ip 192.168.199.0 255.255.255.0

dialer watch-list 1 delay route-check initial 10

dialer watch-list 1 delay disconnect 10

!

New Member

Re: ISDN problems

This is the debug q931 ans q921 and isdn error on the router that making call

Dec 20 17:51:27.008: ISDN BR0 Q921: User TX -> RR sapi=0 tei=66 nr=1

Dec 20 17:51:27.320: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=1 nr=1

Dec 20 17:51:27.320: ISDN BR0 Q931: CONNECT pd = 8 callref = 0x90

Dec 20 17:51:27.320: ISDN BR0 Q921: User TX -> RR sapi=0 tei=66 nr=2

Dec 20 17:51:27.324: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

Dec 20 17:51:27.328: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1

Dec 20 17:51:27.328: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 06........ N/A

Dec 20 17:51:27.332: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=66, ns=1 nr=2

Dec 20 17:51:27.332: ISDN BR0 Q931: CONNECT_ACK pd = 8 callref = 0x10

Dec 20 17:51:27.384: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=2

Dec 20 17:51:29.388: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 06........ , call lasted 2 seconds

Dec 20 17:51:29.392: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=66, ns=2 nr=2

Dec 20 17:51:29.392: ISDN BR0 Q931: DISCONNECT pd = 8 callref = 0x10

Cause i = 0x8090 - Normal call clearing

Dec 20 17:51:29.492: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=2 nr=3

Dec 20 17:51:29.492: ISDN BR0 Q931: RELEASE pd = 8 callref = 0x90

Dec 20 17:51:29.496: ISDN BR0 Q921: User TX -> RR sapi=0 tei=66 nr=3

Dec 20 17:51:29.500: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

Dec 20 17:51:29.500: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di1

Dec 20 17:51:29.504: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=66, ns=3 nr=3

Dec 20 17:51:29.504: ISDN BR0 Q931: RELEASE_COMP pd = 8 callref = 0x10

Dec 20 17:51:29.592: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=4

Dec 20 17:51:29.592: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=66, ns=4 nr=3

Dec 20 17:51:29.596: ISDN BR0 Q931: SETUP pd = 8 callref = 0x11

Bearer Capability i = 0x8890

Standard = CCITT

Transfer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Called Party Number i = 0x80, 06........

Plan:Unknown, Type:Unknown

Sending Complete

Dec 20 17:51:29.680: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=3 nr=5

Dec 20 17:51:29.680: ISDN BR0 Q931: CALL_PROC pd = 8 callref = 0x91

Channel ID i = 0x8A

Dec 20 17:51:29.684: ISDN BR0 Q921: User TX -> RR sapi=0 tei=66 nr=4

Dec 20 17:51:30.008: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=66, ns=4 nr=5

Dec 20 17:51:30.008: ISDN BR0 Q931: CONNECT pd = 8 callref = 0x91

Dec 20 17:51:30.012: ISDN BR0 Q921: User TX -> RR sapi=0 tei=66 nr=5

Dec 20 17:51:30.012: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

Dec 20 17:51:30.016: %DIALER-6-BIND: Interface BR0:2 bound to profile Di1

Dec 20 17:51:30.016: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 06........ N/A

Dec 20 17:51:30.020: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=66, ns=5 nr=5

Dec 20 17:51:30.020: ISDN BR0 Q931: CONNECT_ACK pd = 8 callref = 0x11

Dec 20 17:51:30.076: ISDN BR0 Q921: User RX <- RR sapi=0 tei=66 nr=6

Dec 20 17:51:32.076: %ISDN-6-DISCONNECT: Interface BRI0:2 disconnected from 06........ , call lasted 2 seconds

Dec 20 17:51:32.080: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=66, ns=6 nr=5

Dec 20 17:51:32.080: ISDN BR0 Q931: DISCONNECT pd = 8 callref = 0x11

Cause i = 0x8090 - Normal call clearing

Hall of Fame Super Silver

Re: ISDN problems

Thanks for posting the config and the additional debug output. I think that Georg may be on the right path in suggesting that it might be an authentication problem. Could you run debug ppp negotiation and post that output. (I see little value in having the debug q921 output, given what you have posted so far)

HTH

Rick

VIP Purple

Re: ISDN problems

Hello,

can you try and configure the following on your Dialer1 interface:

interface Dialer1

-->dialer-group 1

And in global config mode add:

dialer-list 1 protocol ip permit

Regards,

GP

New Member

Re: ISDN problems

this is the debug PPP of the router that make the isdn call

Dec 21 15:29:53.655: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 84 changed to up

Dec 21 15:29:54.083: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up

Dec 21 15:29:54.087: %DIALER-6-BIND: Interface BR0:2 bound to profile Di1

Dec 21 15:29:54.087: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to 06........ N/A

Dec 21 15:29:54.099: BR0:2 PPP: Using dialer call direction

Dec 21 15:29:54.099: BR0:2 PPP: Treating connection as a callout

Dec 21 15:29:54.099: BR0:2 PPP: Phase is ESTABLISHING, Active Open

Dec 21 15:29:54.099: BR0:2 PPP: No remote authentication for call-out

Dec 21 15:29:54.099: BR0:2 LCP: O CONFREQ [Closed] id 102 len 10

Dec 21 15:29:54.099: BR0:2 LCP: MagicNumber 0xF7B82B87 (0x0506F7B82B87)

Dec 21 15:29:54.115: BR0:2 LCP: I CONFREQ [REQsent] id 116 len 15

Dec 21 15:29:54.115: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

Dec 21 15:29:54.115: BR0:2 LCP: MagicNumber 0x4DD775DB (0x05064DD775DB)

Dec 21 15:29:54.115: BR0:2 LCP: O CONFACK [REQsent] id 116 len 15

Dec 21 15:29:54.115: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

Dec 21 15:29:54.115: BR0:2 LCP: MagicNumber 0x4DD775DB (0x05064DD775DB)

Dec 21 15:29:54.115: BR0:2 LCP: I CONFACK [ACKsent] id 102 len 10

Dec 21 15:29:54.115: BR0:2 LCP: MagicNumber 0xF7B82B87 (0x0506F7B82B87)

Dec 21 15:29:54.115: BR0:2 LCP: State is Open

Dec 21 15:29:54.119: BR0:2 PPP: Phase is AUTHENTICATING, by the peer

Dec 21 15:29:54.131: BR0:2 CHAP: I CHALLENGE id 194 len 27 from "receive"

Dec 21 15:29:54.135: BR0:2 CHAP: Using hostname from unknown source

Dec 21 15:29:54.135: BR0:2 CHAP: Using password from AAA

Dec 21 15:29:54.135: BR0:2 CHAP: O RESPONSE id 194 len 42 from "hostname_router"

Dec 21 15:29:54.151: BR0:2 CHAP: I FAILURE id 194 len 25 msg is "Authentication failed"

Dec 21 15:29:54.155: BR0:2 LCP: I TERMREQ [Open] id 117 len 4

Dec 21 15:29:54.155: BR0:2 LCP: O TERMACK [Open] id 117 len 4

Dec 21 15:29:54.155: BR0:2 PPP: Sending Acct Event[Down] id[6C6C]

Dec 21 15:29:54.155: BR0:2 PPP: Phase is TERMINATING

Dec 21 15:29:56.167: BR0:2 LCP: TIMEout: State TERMsent

Dec 21 15:29:56.167: BR0:2 LCP: State is Closed

Dec 21 15:29:56.167: BR0:2 PPP: Phase is DOWN

Dec 21 15:29:56.167: BR0:2 PPP: Phase is ESTABLISHING, Passive Open

Dec 21 15:29:56.167: BR0:2 LCP: State is Listen

Dec 21 15:29:56.167: BR0:2 LCP: I CONFREQ [Listen] id 118 len 15

Dec 21 15:29:56.167: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

Dec 21 15:29:56.167: BR0:2 LCP: MagicNumber 0x4DD77DE5 (0x05064DD77DE5)

Dec 21 15:29:56.167: BR0:2 PPP: No remote authentication for call-out

Dec 21 15:29:56.171: BR0:2 LCP: O CONFREQ [Listen] id 103 len 10

Dec 21 15:29:56.171: BR0:2 LCP: MagicNumber 0xF7B8339C (0x0506F7B8339C)

Dec 21 15:29:56.171: BR0:2 LCP: O CONFACK [Listen] id 118 len 15

Dec 21 15:29:56.171: BR0:2 LCP: AuthProto CHAP (0x0305C22305)

Dec 21 15:29:56.171: BR0:2 LCP: MagicNumber 0x4DD77DE5 (0x05064DD77DE5)

Dec 21 15:29:56.175: %ISDN-6-DISCONNECT: Interface BRI0:2 disconnected from 06..... , call lasted 2 seconds

Dec 21 15:29:56.263: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down

Dec 21 15:29:56.263: %DIALER-6-UNBIND: Interface BR0:2 unbound from profile Di1

Dec 21 15:29:56.279: BR0:2 PPP: Sending Acct Event[Down] id[6C6D]

Dec 21 15:29:56.279: BR0:2 LCP: State is Closed

Dec 21 15:29:56.279: BR0:2 PPP: Phase is DOWN

Dec 21 15:29:56.731: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

Dec 21 15:29:56.735: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1

Dec 21 15:29:56.739: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 0......... N/A

Dec 21 15:29:56.751: BR0:1 PPP: Using dialer call direction

Dec 21 15:29:56.751: BR0:1 PPP: Treating connection as a callout

Dec 21 15:29:56.751: BR0:1 PPP: Phase is ESTABLISHING, Active Open

Dec 21 15:29:56.751: BR0:1 PPP: No remote authentication for call-out

Dec 21 15:29:56.751: BR0:1 LCP: O CONFREQ [Closed]

VIP Purple

Re: ISDN problems

Hello,

check the configuration on the other side of the connection, there must be a username matching the name of the calling router (Sendigcall) and a matching password. So basically there must be a line that looks like this:

username Sendigcall password ....

Regards,

GP

New Member

Re: ISDN problems

In the other side there is a username that don't macht the calling router's hostname but is a username created by me.

On the both side there are configurated two idem username with the same password

Example

on the router A (receive call) there are

username send password send

username receive password receive

on the router B (sending call) there are

username send password send

username receive password receive

this is the username configurated in Dialer interface

(if you see the sh run above you can see it there)

VIP Purple

Re: ISDN problems

Hello,

if the real name of the calling router is not configured on the called router, you need to define the username you have defined, 'send' in your case, in the CHAP configuration. Therefore, you need to configure:

ppp chap hostname send

ppp chap password send

on the calling router.

Regards,

GP

New Member

Re: ISDN problems

YESSSSSSSSSSSSSSSSS it's as you say!!!!!!!!!!!!!!!!

THANK YOU A LOT!!!!!!!!!!

Your information are been very helpful!!!!!!!

Thank you thank you thank you!!!!!

New Member

Re: ISDN problems

Hello,

How if there is no authentication in my configurations? I got exactly the same messages.

Thanks,

Nelson

Hall of Fame Super Silver

Re: ISDN problems

Nelson

We would be able to help you better if you would post the router configs and perhaps some of the messages that you are getting.

HTH

Rick

New Member

Re: ISDN problems

Hello,

Here is the configration and the error messages, is this enough for your reference?

version 12.3

service timestamps debug datetime msec

service timestamps log datetime localtime

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 8192 debugging

logging monitor informational

enable secret 5

!

clock timezone GMT+8 8

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

no ip domain lookup

no ftp-server write-enable

isdn switch-type basic-net3

!

!

!

!

interface FastEthernet0/0

description "ISDN Router intranet"

ip address

ip access-group 113 in

no ip redirects

no ip unreachables

no ip mroute-cache

duplex auto

speed auto

standby 1 ip

standby 1 priority 90

standby 1 authentication

!

interface FastEthernet0/1

ip address

ip access-group 111 in

no ip redirects

no ip unreachables

no ip mroute-cache

duplex auto

speed auto

standby 2

standby 2 priority 90

standby 2 authentication

!

interface BRI1/0

ip address

encapsulation ppp

dialer idle-timeout 30 either

dialer map

dialer-group 1

isdn switch-type basic-net3

!

interface BRI1/1

ip address

encapsulation ppp

shutdown

dialer idle-timeout 30 either

dialer map ip x.x.x.x yyyyy

dialer-group 1

isdn switch-type basic-net3

!

interface BRI1/2

ip address

encapsulation ppp

dialer idle-timeout 30 either

dialer map ip

dialer-group 1

isdn switch-type basic-net3

!

interface BRI1/3

no ip address

isdn switch-type basic-net3

!

interface BRI1/4

no ip address

isdn switch-type basic-net3

!

interface BRI1/5

no ip address

isdn switch-type basic-net3

!

interface BRI1/6

description *** to YD ***

ip address

ip accounting output-packets

encapsulation ppp

dialer idle-timeout 30 either

dialer map ip

dialer-group 1

isdn switch-type basic-net3

!

interface BRI1/7

no ip address

isdn switch-type basic-net3

!

router eigrp 100

redistribute connected

redistribute static

passive-interface FastEthernet0/1

passive-interface BRI1/0

passive-interface BRI1/1

passive-interface BRI1/2

passive-interface BRI1/3

passive-interface BRI1/4

passive-interface BRI1/5

passive-interface BRI1/6

passive-interface BRI1/7

no auto-summary

!

ip classless

ip route

no ip http server

ip http authentication local

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

logging trap debugging

access-list 1 permit

access-list 1 permit

access-list 2 permit

access-list 110 deny

access-list 110 deny

access-list 110 permit

access-list 110 permit

access-list 111 deny

access-list 111 permit

access-list 112 permit

access-list 113 permit ip any any

dialer-list 1 protocol ip list 111

dialer-list 2 protocol ip permit

snmp-server community RO

snmp-server enable traps tty

!

control-plane

!

!

line con 0

login local

line aux 0

line vty 0 4

!

scheduler allocate 20000 1000

!

end

3085: *Mar 10 08:24:16: Layer 2 for Interface BR1/2, TEI 86 changed to down

3084: *Mar 10 08:23:35: Layer 2 for Interface BR1/2, TEI 86 changed to up

Hall of Fame Super Silver

Re: ISDN problems

Nelson

This is a good starting point. The config that you posted does not have any authentication. Can you also post the config from the device that you are attempting to communicate with?

Authentication is not the only thing that can produce these symptoms. So it might be helpful to run debug isdn q921 and debug isdn q931 and post the output of the debugs.

HTH

Rick

New Member

Re: ISDN problems

Hi Rick,

Here is the output of those two commands,

03:30 PM 3175: *Mar 22 07:29:28.846: ISDN BR1/2 Q931: L3_ShutDown: Shutting down ISDN Layer 3

03:30 PM 3174: *Mar 22 07:29:28.190: ISDN BR1/2 Q921: User TX -> IDREQ ri=17890 ai=127

03:30 PM 3173: *Mar 22 07:29:18.882: ISDN BR1/6 Q931: L3_ShutDown: Shutting down ISDN Layer 3

03:30 PM 3172: *Mar 22 07:29:18.234: ISDN BR1/6 Q921: User TX -> IDREQ ri=47313 ai=127

03:30 PM 3171: *Mar 22 07:29:08.918: ISDN BR1/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

03:30 PM 3170: *Mar 22 07:29:08.306: ISDN BR1/0 Q921: User RX <- IDDENY ri=64464 ai=127

03:30 PM 3169: *Mar 22 07:29:08.262: ISDN BR1/0 Q921: User TX -> IDREQ ri=64464 ai=127

02:28 PM 3168: *Mar 22 06:26:58.502: ISDN BR1/2 Q931: L3_ShutDown: Shutting down ISDN Layer 3

02:28 PM 3167: *Mar 22 06:26:57.854: ISDN BR1/2 Q921: User TX -> IDREQ ri=7647 ai=127

02:27 PM 3166: *Mar 22 06:26:48.438: ISDN BR1/6 Q931: L3_ShutDown: Shutting down ISDN Layer 3

02:27 PM 3165: *Mar 22 06:26:47.786: ISDN BR1/6 Q921: User TX -> IDREQ ri=15870 ai=127

02:27 PM 3164: *Mar 22 06:26:38.442: ISDN BR1/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

02:27 PM 3163: *Mar 22 06:26:37.794: ISDN BR1/0 Q921: User TX -> IDREQ ri=35629 ai=127

01:25 PM 3162: *Mar 22 05:24:28.082: ISDN BR1/2 Q931: L3_ShutDown: Shutting down ISDN Layer 3

01:25 PM 3161: *Mar 22 05:24:27.430: ISDN BR1/2 Q921: User TX -> IDREQ ri=17516 ai=127

01:25 PM 3160: *Mar 22 05:24:18.102: ISDN BR1/6 Q931: L3_ShutDown: Shutting down ISDN Layer 3

01:25 PM 3159: *Mar 22 05:24:17.454: ISDN BR1/6 Q921: User TX -> IDREQ ri=47291 ai=127

01:25 PM 3158: *Mar 22 05:24:08.054: ISDN BR1/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

01:25 PM 3157: *Mar 22 05:24:07.406: ISDN BR1/0 Q921: User TX -> IDREQ ri=18202 ai=127

12:23 PM 3155: *Mar 22 04:21:57.007: ISDN BR1/2 Q921: User TX -> IDREQ ri=24201 ai=127

12:23 PM 3156: *Mar 22 04:21:57.655: ISDN BR1/2 Q931: L3_ShutDown: Shutting down ISDN Layer 3

12:22 PM 3153: *Mar 22 04:21:47.031: ISDN BR1/6 Q921: User TX -> IDREQ ri=32264 ai=127

12:22 PM 3154: *Mar 22 04:21:47.679: ISDN BR1/6 Q931: L3_ShutDown: Shutting down ISDN Layer 3

12:22 PM 3152: *Mar 22 04:21:37.667: ISDN BR1/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

12:22 PM 3151: *Mar 22 04:21:37.019: ISDN BR1/0 Q921: User TX -> IDREQ ri=13463 ai=127

Many thanks for your support!

Nelson

Hall of Fame Super Silver

Re: ISDN problems

Nelson

It looks to me from this debug that there is a problem in your router trying to talk to the ISDN switch. It might be helpful if you would post the output of show isdn status. I think that you might also ask your provider what, if anything, they are seeing from you and to review the configuration parameters in your router to their version of what the parameters should be.

HTH

Rick

New Member

Re: ISDN problems

Rick,

This is the output of show isdn status.

ISDN BRI1/0 interface

dsl 8, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 8 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI1/1 interface

dsl 9, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 9 CCBs = 0

The Free Channel Mask: 0x00000000

ISDN BRI1/2 interface

dsl 10, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 10 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI1/3 interface

dsl 11, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 11 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI1/4 interface

dsl 12, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 12 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI1/5 interface

dsl 13, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 13 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI1/6 interface

dsl 14, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 14 CCBs = 0

The Free Channel Mask: 0x80000003

ISDN BRI1/7 interface

dsl 15, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 15 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

Thanks for your help!

Nelson

Hall of Fame Super Silver

Re: ISDN problems

Nelson

These lines:

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

which appear on each of your BRI interfaces indicate that there is no connectivity between your router and the ISDN switch. You need to get that resolved. I can not tell whether it is a physical connectivity problem or a configuration mismatch between your router and the switch. But your router and the ISDN switch are not talking and that is your immediate problem.

HTH

Rick

New Member

Re: ISDN problems

Hi

Pls grab some of the sample configs at http://ciscorouterconfig.blogspot.com/

583
Views
0
Helpful
19
Replies
CreatePlease login to create content