Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN Redundant Connectivity

Hardware: Two Cisco 2821 Routers with Bri interface

Connectivity: ISDN dedicated/DOD link for Both routers

Q: How we can provide link redundancy by using ISDN connection. Also I need router redundancy too.

I need to use static routing only

Only one ISDN link per router no other links

Please suggest me a solution for this with needed configurations

Thanks & Regards

Satheerthan S

4 REPLIES
New Member

Re: ISDN Redundant Connectivity

Satheerthan

If i were you, i would use ISDN dialer watch and dynamic routing.

However, if you insist to only use static routes. You may able to get away with HSRP and HSRP interface tracking on your WAN interface.

- In event of R1 WAN link was down, R2 become active and route your traffic via ISDN connections.

- In event of R1 WAN link was down and R2 also was down, R1 remain active and route your traffic via local ISDN connections.

there are many other solutions for your requirement. however, i think dialer watch is the best for your senario.

regards,

Eng Siong

New Member

Re: ISDN Redundant Connectivity

Dear Eng Siong,

Thanks for your solution,

I have some doubts in this.

How we can configure HSRP in WAN interface?.

Can we use HSRP with dialer watch?

What are the other solutions for this specific requirement.(Router redundancy and link redundancy, Only 2 BRI ISDN connections)

Can you please suggest with sample configuration.

Regards

Satheerthan

New Member

Re: ISDN Redundant Connectivity

Yon only need to configure HSRP for your LAN interface. You can setup your R1 WAN router as primary hsrp router. As well as that, configure the R1 HSRP to track your WAN interface.

If R1 WAN interface was down, it would reduce the HSRP priority, so the R2 backup isdn router can take over as default gateway and route traffic via ISDN connection.

If R1 WAN interface and R2 router were down at the sametime. R1 remain as default gateway router and route traffic via ISDN connection using floting static route.

hope this helps....

sample config.

ISDN-R1

********

!

interface FastEthernet0/0

description - PRIMARY LAN INTERFACE -

ip address 10.10.10.2 255.255.255.0

speed 100

full-duplex

standby 10 ip 10.10.10.1

standby 10 priority 150

standby 10 preempt

standby 10 track Serial1/0.103 80

!

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

no frame-relay inverse-arp

!

interface Serial1/0.103 point-to-point

description - FR WAN Connection -

ip address 20.x.x.1 255.255.255.0

frame-relay interface-dlci 103

!

interface bri 0

encapsulation PPP

dialer pool-member 1

!

interface dialer0

ip 30.x.x.1 255.255.255.0

encapsulation ppp

dialer remote-name Remote-Router

dialer pool 1

dialer string 5551212

dialer-group 1

!

ip route 0.0.0.0 0.0.0.0 Serial1/0.103

ip route 0.0.0.0 0.0.0.0 dialer0 100

!

ISDN-R2

********

!

interface FastEthernet0/0

description - SECONDARY LAN INTERFACE -

ip address 10.10.10.3 255.255.255.0

speed 100

full-duplex

standby 10 ip 10.10.10.1

standby 10 preempt

!

!

interface bri 0

encapsulation PPP

dialer pool-member 1

!

interface dialer0

ip 40.x.x.1 255.255.255.0

encapsulation ppp

dialer remote-name Remote-Router

dialer pool 1

dialer string 5551212

dialer-group 1

!

!

ip route 0.0.0.0 0.0.0.0 dialer0

!

regards,

eng siong

New Member

Re: ISDN Redundant Connectivity

Eng Siong,

Thanks for your help.

I will try to implement this and getback to you..

Thanks & Regards

Satheerthan

129
Views
4
Helpful
4
Replies