Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Isis areas -vlan plan

Hi Guys,

I know that level 2 routers learn about paths both within areas and between areas.

If that is so , can we repeat the vlans that are in area 1 to the area2 ,i.e excluding the vlans that are directly connected.

2 REPLIES
Cisco Employee

Re: Isis areas -vlan plan

Hello,

I believe you are confusing two things together. To a routing protocol, a VLAN is a Layer2 technology just like any other interface, be it Token Ring, PPP, ATM, Frame Relay, etc. Just like a router's interface terminates a particular Layer2 technology on the router and does not allow it to transparently pass further, a router also terminates a VLAN without allowing it to pass further. So regardless of IS-IS, its levels and areas, VLAN numbers on different interfaces of routers can be reused, even on a single router. So for example, this configuration is perfectly valid:

interface FastEthernet0/0

no shutdown

!

interface FastEthernet0/0.10

encapsulation dot1q 10

ip address 10.0.10.1 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1q 20

ip address 10.0.20.1 255.255.255.0

!

interface FasthEthernet0/1

no shutdown

!

interface FastEthernet0/1.10

encapsulation dot1q 10

ip address 10.1.10.1 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1q 20

ip address 10.1.20.1 255.255.255.0

What can not be reused are the IP address spaces - they have to be unique across the entire routed internetwork, regardless on their placement in areas or Layer2 technologies.

Please feel welcome to ask further!

Best regards,

Peter

New Member

Isis areas -vlan plan

Hi All,

Thanks Peter for the clarification.

The topology is like the attach, we have to terminate mpls pseudowire

from DX to the 2 AX,i.e AX1 & AX2 over this ISIS network;

could it be possible like as mentioned in diagram.

Regards

Kumar

205
Views
3
Helpful
2
Replies
CreatePlease to create content