Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Issue while redistributing static routes into eigrp

Hi Expert,

We are facing one issue while redistributing static routes in Eigrp.Below find brief discription.

We are running eigrp between provider CE (R1) router and our router (R2). We are redistributing static
routes into eigrp , some routes are getting redistributed but facing issue for (172.19.148.0/24)

Router R2:

router eigrp 100
redistribute static
network 10.119.130.32 0.0.0.31
distribute-list 10 out
no auto-summary

access-list 10 permit 10.119.148.0 0.0.0.255
access-list 10 permit 172.19.148.0 0.0.0.255---facing issue for this subnet


ip route 10.119.148.0 255.255.255.0 10.119.130.37
ip route 172.19.148.0 255.255.255.0 10.119.130.37

R2#sh ip route
S       172.19.148.0/24 [1/0] via 10.119.130.37
S       172.29.0.0/16 [1/0] via 10.119.130.37
S       10.119.148.0/24 [1/0] via 10.119.130.37
D EX    10.100.1.40/32
           [170/256512] via 10.119.130.36, 1w0d, GigabitEthernet0/0
D EX    10.100.1.50/32
           [170/256512] via 10.119.130.36, 1w0d, GigabitEthernet0/0
D EX    10.100.1.30/32
           [170/256512] via 10.119.130.36, 1w0d, GigabitEthernet0/0
R2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(10.119.130.33)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status


P 10.100.1.40/32, 1 successors, FD is 256512, tag is 12641
        via 10.119.130.36 (256512/256256), GigabitEthernet0/0
P 10.100.1.50/32, 1 successors, FD is 256512, tag is 12641
        via 10.119.130.36 (256512/256256), GigabitEthernet0/0
P 10.100.1.30/32, 1 successors, FD is 256512, tag is 12641
       via 10.119.130.36 (256512/256256), GigabitEthernet0/0
P 10.119.130.32/27, 1 successors, FD is 2816
        via Connected, GigabitEthernet0/0
P 10.119.148.0/24, 1 successors, FD is 2816
        via Rstatic (2816/0)


R21#sh ip route 10.119.148.0
Routing entry for 10.119.148.0/24
  Known via "static", distance 1, metric 0
  Redistributing via eigrp 100
  Advertised by eigrp 100
  Routing Descriptor Blocks:
  * 10.119.130.37
      Route metric is 0, traffic share count is 1


R2#sh ip route 172.19.148.0
Routing entry for 172.19.148.0/24
  Known via "static", distance 1, metric 0
  Redistributing via eigrp 100
  Routing Descriptor Blocks:
  * 10.119.130.37
      Route metric is 0, traffic share count is 1

Please help me to get this issue solve.

Please see below diag.

6 REPLIES
Purple

Issue while redistributing static routes into eigrp

Hi,

both prefixes should not be advertised as they match a permit statement in the distribute-list ACL.

So both shouldn't be advertised but they should be in the topology table and you only get the first one.

Can you clear the routing table and see if it gets in the topology table.

When you get both in the topology table you should do this to redistribute them or use a deny in the prefix-list then a permit 0.0.0.0/0 le 32 if you want to filter these and advertise the other static prefixes.

ip prefix-list STATIC permit 10.119.148.0/24

ip prefix-list STATIC permit 172.19.148.0/24

route-map REDISTRIBUTE

match ip address prefix-list STATIC

router eigrp 100

redistribute static route-map REDISTRIBUTE

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Issue while redistributing static routes into eigrp

Hi Alain,

Thanks for prompt reply.

first I can't clear the routing table as production is going on.

These routes are in routing table.

R2#sh ip route

S 172.19.148.0/24 [1/0] via 10.119.130.37

S 172.29.0.0/16 [1/0] via 10.119.130.37

S 10.119.148.0/24 [1/0] via 10.119.130.37

D EX 10.100.1.40/32

[170/256512] via 10.119.130.36, 1w0d, GigabitEthernet0/0

D EX 10.100.1.50/32

[170/256512] via 10.119.130.36, 1w0d, GigabitEthernet0/0

D EX 10.100.1.30/32

[170/256512] via 10.119.130.36, 1w0d, GigabitEthernet0/0

So they should be in eigrp topology table and get advertised by eigrp (As distribution-list is permitting both network and it's out direction), Which is happening for only one subnet (10.119.148.0/24) but not for  172.19.148.0/24.

R21#sh ip route 10.119.148.0

Routing entry for 10.119.148.0/24

Known via "static", distance 1, metric 0

Redistributing via eigrp 100

Advertised by eigrp 100 -----------------------------------This is missing for 172.19.148.0

Routing Descriptor Blocks:

* 10.119.130.37

Route metric is 0, traffic share count is 1


R2#sh ip route 172.19.148.0
Routing entry for 172.19.148.0/24
Known via "static", distance 1, metric 0
Redistributing via eigrp 100
Routing Descriptor Blocks:
* 10.119.130.37
Route metric is 0, traffic share count is 1

Please correct me if I am wrong anywhere.

Purple

Issue while redistributing static routes into eigrp

Hi,

yes you are correct ,my brain was on vacancy this morning when I replied and it suddenly came back home after 

They should indeed be advertised by EIGRP as long as they are in the topology table but the second one is not in the topology table so it can't be advertised.Now the question is why isn't in the topology table and as of now I don't see why.Let's wait for others to chime in with some solution.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Bronze

Re: Issue while redistributing static routes into eigrp

First step is to supply a metric when redistributing static routes. It's terribly buggy if you don't.

Sent from Cisco Technical Support iPad App

New Member

Re: Issue while redistributing static routes into eigrp

Hi slice,

To give metric was in my mind but without metric eigrp redistribut directly and static route with interface metric on which it

Shows in routing table.

Do not understand if it is bug then why it redistributing one static route and not other while both are in routing table and allowed by

Distribution list, also why only one route is place in topology table why other miss.

Bronze

Re: Issue while redistributing static routes into eigrp

It's up to you whether you supply a metric or not for static redistribution.  I'm just telling you that the process works far more consistently when a metric is supplied than when it isn't supplied.  EIGRP is reliant on information supplied by the interface that can be susceptible to timing problems (particularly at bootup time.)  Since there isn't a valid reason that I can think of to leave the redistribution metric off, I always recommend supplying it.

560
Views
0
Helpful
6
Replies
CreatePlease to create content