Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with GLBP

Hi Guys,

I'm currently in the middle of setting up a leased line connection from Site A to Site B using 2 pairs of leased line circuit with GLBP for balancing purposes. At site B, i already have 2 servers with IP 172.20.60.11 and 172.20.60.12. The issue that i'm having rigth now is that from both routers in Site A, i could not ping to this 2 servers but i'm able to ping the VIP of the LAN at site B. From the routers in site B, I have no issue to ping to the said servers. Attached is a diagram to help explaiin further regarding my Architecture. Below is the GLBP command at site B routers.

Site B Router 1 Config

--------------------------------

track 1 interface Serial0/0/0 line-protocol

interface GigabitEthernet0/0.1

description ** Site B Svr Frm  **

encapsulation dot1Q 60

ip address 172.20.60.2 255.255.255.0

ip load-sharing per-packet

glbp 10 ip 172.20.60.1

glbp 10 priority 110

glbp 10 preempt delay minimum 60

glbp 10 weighting 110 lower 95 upper 100

glbp 10 authentication text yyy

glbp 10 weighting track 1 decrement 50

ip route 172.25.63.75 255.255.255.255 10.35.0.2

R1#sh glbp

GigabitEthernet0/0.1 - Group 10

  State is Active

    85 state changes, last state change 00:43:59

  Virtual IP address is 172.20.60.1

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.888 secs

  Redirect time 600 sec, forwarder timeout 14400 sec

  Authentication text, string "bursa@csc"

  Preemption enabled, min delay 60 sec

  Active is local

  Standby is 172.20.60.3, priority 100 (expires in 8.160 sec)

  Priority 110 (configured)

  Weighting 110 (configured 110), thresholds: lower 95, upper 100

    Track object 1 state Up decrement 50

  Load balancing: round-robin

  Group members:

    2894.0f5a.9e00 (172.20.60.3)

    649e.f3f4.aa80 (172.20.60.2) local

  There are 2 forwarders (1 active)

  Forwarder 1

    State is Active

      37 state changes, last state change 00:44:29

    MAC address is 0007.b400.0a01 (default)

    Owner ID is 649e.f3f4.aa80

  Redirection enabled

    Preemption enabled, min delay 30 sec

    Active is local, weighting 110

    Client selection count: 1411

  Forwarder 2

    State is Listen

      52 state changes, last state change 00:17:00

    MAC address is 0007.b400.0a02 (learnt)

    Owner ID is 2894.0f5a.9e00

    Redirection enabled, 598.176 sec remaining (maximum 600 sec)

    Time to live: 14398.176 sec (maximum 14400 sec)

    Preemption enabled, min delay 30 sec

    Active is 172.20.60.3 (primary), weighting 110 (expires in 10.048 sec)

    Client selection count: 5

Site B Router 2 Config

--------------------------------

track 1 interface Serial0/0/0 line-protocol

interface GigabitEthernet0/0.1

description ** Svr Frm **

encapsulation dot1Q 60

ip address 172.20.60.3 255.255.255.0

ip load-sharing per-packet

glbp 10 ip 172.20.60.1

glbp 10 preempt delay minimum 60

glbp 10 weighting 110 lower 95 upper 100

glbp 10 authentication text yyy

glbp 10 weighting track 1 decrement 50

ip route 172.25.63.75 255.255.255.255 10.45.0.2

R2#sh glbp

GigabitEthernet0/0.1 - Group 10

  State is Standby

    34 state changes, last state change 00:19:34

  Virtual IP address is 172.20.60.1

  Hello time 3 sec, hold time 10 sec

    Next hello sent in 1.376 secs

  Redirect time 600 sec, forwarder timeout 14400 sec

  Authentication text, string "bursa@csc"

  Preemption enabled, min delay 60 sec

  Active is 172.20.60.2, priority 110 (expires in 9.184 sec)

  Standby is local

  Priority 100 (default)

  Weighting 110 (configured 110), thresholds: lower 95, upper 100

    Track object 1 state Up decrement 50

  Load balancing: round-robin

  Group members:

    2894.0f5a.9e00 (172.20.60.3) local

    649e.f3f4.aa80 (172.20.60.2)

  There are 2 forwarders (1 active)

  Forwarder 1

    State is Listen

      54 state changes, last state change 00:45:30

    MAC address is 0007.b400.0a01 (learnt)

    Owner ID is 649e.f3f4.aa80

Time to live: 14398.560 sec (maximum 14400 sec)

    Preemption enabled, min delay 30 sec

    Active is 172.20.60.2 (primary), weighting 110 (expires in 10.208 sec)

    Client selection count: 1467

  Forwarder 2

    State is Active

      33 state changes, last state change 00:18:01

    MAC address is 0007.b400.0a02 (default)

    Owner ID is 2894.0f5a.9e00

    Preemption enabled, min delay 30 sec

    Active is local, weighting 110

    Client selection count: 1466

1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Issue with GLBP

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Try an extended ping from one of the site B routers to a site B server sourcing from a WAN link interface.  If that also doesn't work, try check the site B server has the correct site B virtual gateway IP.

3 REPLIES
Super Bronze

Issue with GLBP

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Try an extended ping from one of the site B routers to a site B server sourcing from a WAN link interface.  If that also doesn't work, try check the site B server has the correct site B virtual gateway IP.

Issue with GLBP

Hi Joseph

how are you routes set ?

Please give us a traceroute for the failing.

Cheers

Patrick

Issue with GLBP

Hi Guys,

Thanks for the feedback. After talking to my support team in charge of that particular server, i was inform that the server has 2 NIC with 2 Default gateway. after asking the server team to add in a static route at the server itself, the problem has been solved. The clue was when i did an extended ping from Router B's Wan interface, i did not receive any reply. Thanks again Joseph and Patrick.

272
Views
0
Helpful
3
Replies
CreatePlease to create content