Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Issue with routing?!? I know I'm missing something.

Hi everyone.

I've set up home lab. I have two routers 1721, 1 switch 2950, PC and 2 laptops.

=================================================================================================

My two routers are connected via serial interface. R2 is directly connected to the PC on FastE 0 192.168.1.2.   PC addres 192.168.1.1

Serial int addres 192.168.1.65.

R1 [serial int 192.168.1.66 connected to R2] with FastE 192.168.1.129 is connected to the switch [vlan int 192.168.1.130].

Two laptops are connected to the switch on ports 1 and 2. [192.168.1.131  -  192.168.1.133]

=================================================================================================

The problem I'm having is that I can't ping devices on the other subnets. I have static routing set up on both routers:

R1-

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks

C       192.168.1.65/32 is directly connected, Serial0

C       192.168.1.64/26 is directly connected, Serial0

S       192.168.1.0/26 [1/0] via 192.168.1.65

C       192.168.1.128/26 is directly connected, FastEthernet0

R2-

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks

C       192.168.1.64/26 is directly connected, Serial0

C       192.168.1.66/32 is directly connected, Serial0

C       192.168.1.0/26 is directly connected, FastEthernet0

S       192.168.1.128/26 [1/0] via 192.168.1.66

The thing when I'm on R2 I'm able to ping R1, switch and laptops - also my PC.

When I'm on R1 it is the same.

BUT. Whan I'm trying to ping something behind the router while on PC or laptops I'm getting this message:

----Reply from x.x.x.x: Destination host unreachable.  -  Packets sent=4 , received 4, lost 0---

Also replying address is different from the one I'm pinging.

I have no idea what is going on.

While setting it I was using Packet Tracer as a guide and created exact clone of this network - and a PT net works fine.

I did  disable firewalls.

I'm attaching PT file.

Please help !!!

----------------------------------------------------------------------------------

R1 config file:

Current configuration : 890 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router-1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$q0Qj$8hrfpMXpSj4Xr96xFAhyM0

!

no aaa new-model

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

interface FastEthernet0

ip address 192.168.1.129 255.255.255.192

speed auto

!

interface Serial0

ip address 192.168.1.66 255.255.255.192

encapsulation ppp

no fair-queue

!

ip forward-protocol nd

ip route 192.168.1.0 255.255.255.192 192.168.1.65

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

banner motd ^C

==================

Router-1!!!!!!!!!!

==================

^C

!

line con 0

password 7 0202114B0A

logging synchronous

login

line aux 0

line vty 0 4

password 7 1413071B0D

logging synchronous

login

!

end

++++++++++++++++++++++++++++++++++++++++++++++++++++++++

R2 config file.

Current configuration : 968 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router-2

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$H2IG$EsBXfuVE3BbB96tJWpoBF1

!

no aaa new-model

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0

ip address 192.168.1.2 255.255.255.192

speed auto

!

interface Serial0

ip address 192.168.1.65 255.255.255.192

encapsulation ppp

no fair-queue

clock rate 2000000

!

ip forward-protocol nd

ip route 192.168.1.128 255.255.255.192 192.168.1.66

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

banner motd ^C

==============

Router-2!!!!!!

==============

^C

!

line con 0

password 7 045F1E160E

logging synchronous

login

line aux 0

line vty 0 4

password 7 130102020A

login

!

end

Everyone's tags (2)
4 ACCEPTED SOLUTIONS

Accepted Solutions
Purple

Issue with routing?!? I know I'm missing something.

Hi,

just send the debugs to the buffer:

logging buffered debug

logging buffered 10000

no service timestamp debug

do sh log

and you'll see the logs from the debug there.

Regards.

Alain

Don't forget to rate helpful posts.
Community Member

Issue with routing?!? I know I'm missing something.

Routing is good, you have a PC issue or some crazy filtering going on that I am not seeing.

Re: Issue with routing?!? I know I'm missing something.

Hello

Just run it on R1. Traffic gernerated on hosts behind R1.

Toshi

Sent from Cisco Technical Support iPhone App

Bronze

Issue with routing?!? I know I'm missing something.

Strange. It looks ok on PT.

Can you post the output of "sh controllers serial 0" and "sh int s0" of both routers?

38 REPLIES

Issue with routing?!? I know I'm missing something.

Hi,

   It should not be a problem.

   - Make sure that hosts behind R1 configured a gateway-192.168.1.129

   - Make sure that hosts behind R2 configured a gateway-192.168.1.2

   - Turn off personal firewall on hosts for testing.

    "Destination host unreachable" tells you that the routing problem should be considered.  

HTH,

Toshi

Community Member

Issue with routing?!? I know I'm missing something.

Hi

Thank for quick replay.

Default gateways are already set up.

And firewall is disabled on both laptops and PC.

Everything looks OK but - there is something.

Issue with routing?!? I know I'm missing something.

Hi

   Try to test from hosts behind R1 to connect hosts behind R2.

   Please post the output of "debug ip routing" on R1 and R2.

Toshi

Community Member

Issue with routing?!? I know I'm missing something.

How do I do it exactly?

After typing -

debug ip routing

all I'm getting on the router is : IP routing debugging is on

Thanks.

Issue with routing?!? I know I'm missing something.

Hi,

   How do you manage the devices? Console or Telnet?

R1#conf t

R1(conf t)#logg cons 7

R1#debug ip routing

R2#conf t

R2(conf t)#logg cons 7

R2#debug ip routing

   Then generate traffic from hosts between R1 and R2.

Toshi

Community Member

Issue with routing?!? I know I'm missing something.

I'm using telnet.

Purple

Issue with routing?!? I know I'm missing something.

Hi,

the output of show ip route doesn't correspond to the configs because in the routing table the static routes have the connected interface IP as next-hop but they should have the next-hop IP like it is done in the config

Regards.

Alain

Don't forget to rate helpful posts.
Community Member

Issue with routing?!? I know I'm missing something.

Hi

What do you mean exactly by 'not coresspond'''?

How I supose to change it?

Thats the command I ve used on Router 1

---ip route 192.168.1.0  255.255.255  192.168.1.65---

and thats the one I've used on router 2

---ip route 192.168.1.128  255.255.255.192  192.168.1.66

I thought after doing this routers should route between subnets.

What should i change?

Thanks.

Issue with routing?!? I know I'm missing something.

Hi,

   I thought that peer neighbor route of PPP should not kill your routing. All right lets see the output of debug.

Toshi

Community Member

Issue with routing?!? I know I'm missing something.

Are these commands going to be different if I'm using telnet?

and also where do i find the output of this debug?

Thanks a lot.

Purple

Issue with routing?!? I know I'm missing something.

Hi,

just send the debugs to the buffer:

logging buffered debug

logging buffered 10000

no service timestamp debug

do sh log

and you'll see the logs from the debug there.

Regards.

Alain

Don't forget to rate helpful posts.
Community Member

Issue with routing?!? I know I'm missing something.

To enabled logging to your telnet session:

conf t

logging mon

exit

term mon

Your config looks fine, something else is wrong.  Maybe missing a crossover on the handoff to the PC or something.  Do the following:

From R1

ping 192.168.1.66

if it fails, check your T1 crossover cable

From R1:

ping 192.168.1.129

if it fails, it is the route ON this router that is wrong

From R1

ping 192.168.1.129 source Fast0

if the previous works but this fails it is the route on R2 that is wrong

If all successfull, you have a PC issue.  VLAN the switch out and connect to the switch, then the router as opposed to cross connecting directly. I don't know that 1721's support auto-mdix.

Bronze

Re: Issue with routing?!? I know I'm missing something.

Hi,

Try "clear ip route *" and shut and open the serial interface.

Also try changing the ip route statements to use the exit interface

ip route x.x.x.x x.x.x.x serial 0

Hope this helps

Eugen

Community Member

Re: Issue with routing?!? I know I'm missing something.

Thanks a lot guys

I don't know where to start from now ;]

OK. I changed routing on both R1 and R2 so now they using Serial 0 to forward traffic.

And now from laptop .133 i can ping everything on this side plus 192.168.1.66.

Whan i try to ping .65 BANG! host unreachable.

From PC .1 I'm able to ping .2 interface of R2 but not the .65.

I'm a really fresh to CISCO but i'm almost certain that there is a problem with Serial 0 int on R2.

I will try to setup these logs now- i never done it before so it may take me a while.

update-

I just tried to ping .2 and .65 from R1. It works fine.

?????????????????????????????????????????

Thanks again.

2687
Views
0
Helpful
38
Replies
CreatePlease to create content