Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

L2TPv3 need help

I am trying to create a bridge between two 3845 routers so that the same subnet can appear on both routers which are connected by a third party's network using l2tpv3.

Router 1 has a physical interface (GigabitEthernet0/0.1999) which is connected to the third party's network Router 2 has a physical interface (GigabitEthernet0/0.2000) which is connected to the third party's network

A route exists in the third parties network to allow routing between router 1's and router 2's loopback interfaces.

A bridge group is configured on each router (BVI12). Both bridge-groups are in the same subnet.

A tunnel from an interface in each bridge group is xconnected to the loopback interface of the other router.

The tunnel is established and stays up.

I cannot ping between the ip addresses of the bridge groups.

Config fragments of each router:

Router 1:

l2tp-class class.to.router2

authentication

digest secret 0 CiSc0 hash SHA1

!

pseudowire-class pw.to.router2

encapsulation l2tpv3

protocol l2tpv3 class.to.router1

ip local interface Loopback0

ip pmtu

!

interface Loopback0

ip address 192.168.153.2 255.255.255.255 !

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

media-type sfp

!

interface GigabitEthernet0/0.1999

encapsulation dot1Q 1999

ip address 10.153.0.3 255.255.255.0

!

interface GigabitEthernet0/0.2501

encapsulation dot1Q 2501

no ip redirects

no cdp enable

xconnect 192.168.153.4 2000 pw-class pw.to.router2 bridge-group 12 !

interface GigabitEthernet0/1/0

no ip address

negotiation auto

!

interface GigabitEthernet0/1/0.2501

encapsulation dot1Q 2501

no ip redirects

no cdp enable

bridge-group 12

!

interface BVI12

ip address 192.168.192.2 255.255.255.0

no ip redirects

!

ip route 192.168.153.4 255.255.255.255 10.153.0.2 !

bridge 12 protocol ieee

bridge 12 route ip

!

Router 2:

l2tp-class class.to.router1

authentication

digest secret 0 CiSc0 hash SHA1

!

pseudowire-class pw.to.router1

encapsulation l2tpv3

protocol l2tpv3 class.to.router1

ip local interface Loopback0

ip pmtu

!

interface Loopback0

ip address 192.168.153.4 255.255.255.255 !

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

media-type sfp

!

interface GigabitEthernet0/0.1999

encapsulation dot1Q 1999

ip address 10.153.1.3 255.255.255.0

!

interface GigabitEthernet0/0.2501

encapsulation dot1Q 2501

no ip redirects

no cdp enable

xconnect 192.168.153.2 2000 pw-class pw.to.router1 bridge-group 12 !

interface GigabitEthernet0/1/0

no ip address

negotiation auto

!

interface GigabitEthernet0/1/0.2501

encapsulation dot1Q 2501

no ip redirects

no cdp enable

bridge-group 12

!

interface BVI12

ip address 192.168.192.4 255.255.255.0

no ip redirects

!

ip route 192.168.153.2 255.255.255.255 10.153.1.2 !

bridge 12 protocol ieee

bridge 12 route ip

!

1 REPLY
New Member

Re: L2TPv3 need help

Hi,

I have a similar setup except I've not tried to use a BVI and bridge-groups together with l2tp.

My bridged subinterface, interface GigabitEthernet0/0.2501 in your case, is trunked through to a 3750 with an SVI in a vrf providing Layer3. i.e. xconnect 192.168.153.2 2000 pw-class pw.to.router1

That works well.

HTH,

Andres

377
Views
0
Helpful
1
Replies
CreatePlease to create content