Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

L3 Routing Problem

hi experts,

i have a 6509 and a 3750 connected via FSO (free space optics). i will be adding a fiber connection on both swithces. both FSO and fiber have L3 IP address configured. how can i route properly, avoiding loops, between these devices? i'm considering a floating static route for this one. below is the config for the FSO connection, VLAN 250

6509E-MAIN

vlan 250

name 172.25.250.2/31

interface Vlan250

ip address 172.25.250.2 255.255.255.254

no ip proxy-arp

ip flow ingress

ip pim dense-mode

interface GigabitEthernet7/3

description to 3750G-TEMP g1/0/28

ip address 172.25.250.38 255.255.255.254

no ip proxy-arp

ip flow ingress

ip pim dense-mode

speed nonegotiate

mls qos trust dscp

router ospf 10

no passive-interface GigabitEthernet7/3

network 172.25.250.2 0.0.0.0 area 4949

network 172.25.250.38 0.0.0.0 area 4949

______________________

3750G-TEMP

interface GigabitEthernet1/0/28

description to 6509E-MAIN G7/3

no switchport

ip address 172.25.250.39 255.255.255.254

no ip proxy-arp

ip pim dense-mode

speed nonegotiate

mls qos trust dscp

router ospf 10

no passive-interface GigabitEthernet1/0/28

network 172.25.250.39 0.0.0.0 area 4949

6 REPLIES
Hall of Fame Super Gold

Re: L3 Routing Problem

You don't need any floating static.

Regular OSPF is enough for load balancing (optional) and loop avoidance.

Re: L3 Routing Problem

thanks for giving me a hint paolo! i'll now use the ip ospf cost between the two and make the fiber's costs lower to make it the preferred route. can someone verify my config below:

interface GigabitEthernet7/3

description This is the FSO link

ip address 172.25.250.38 255.255.255.254

ip ospf cost 2

no ip proxy-arp

ip flow ingress

ip pim dense-mode

speed nonegotiate

mls qos trust dscp

interface GigabitEthernet7/4

description This is the FIBER link

ip address 172.25.250.x 255.255.255.254

ip ospf cost 1

no ip proxy-arp

ip flow ingress

ip pim dense-mode

speed nonegotiate

mls qos trust dscp

router ospf 10

network 172.25.250.x 0.0.0.0 area 4949

New Member

Re: L3 Routing Problem

When defineing OSPF, you could add "passive-interface default", unless this is a standard setting on your IOS build.

Hall of Fame Super Gold

Re: L3 Routing Problem

OP doesn't need passive interface, instead he just need a way to prefer paths. This is done by setting the ospf cost as indicated above.

Re: L3 Routing Problem

do i need to issue the 'clear ip ospf process' command after configuring the interfaces with 'ip ospf cost' command?

Hall of Fame Super Gold

Re: L3 Routing Problem

No, but please remember to rate useful posts with the scrollbox below.

191
Views
0
Helpful
6
Replies
CreatePlease to create content