Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Silver

Lab help - OSPF multi area to EIGRP Redistribution

All I am in the process of setting up a lab for testing a new network deployment.  I am performing Proof of Concet before moving on.  In this lab I have multiple areas in OSPF 0, 1, and 2  I am also running EIGRP in another network and connecting them all together.

See diagram for topology.

Below is the config for the 2 routers in running ospf and eigrp along with routing tables:

Router C

router ospf 1
log-adjacency-changes
area 1 virtual-link 172.16.1.1
network 157.130.0.4 0.0.0.3 area 1
network 10.4.0.0 0.0.0.255 area 1
network 157.130.0.12 0.0.0.3 area 1
network 10.4.1.0 0.0.0.255 area 2
network 157.130.0.8 0.0.0.3 area 2


RouterC#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 6 subnets
O       10.1.0.0 [110/3] via 157.130.0.5, 00:18:32, FastEthernet1/1
O       10.2.0.0 [110/2] via 157.130.0.10, 00:18:57, FastEthernet1/0
O       10.3.1.0 [110/2] via 157.130.0.5, 00:18:52, FastEthernet1/1
C       10.4.1.0 is directly connected, FastEthernet0/1
O       10.100.0.0 [110/3] via 157.130.0.5, 00:18:32, FastEthernet1/1
O       10.200.0.0 [110/2] via 157.130.0.10, 00:18:57, FastEthernet1/0
     157.130.0.0/30 is subnetted, 4 subnets
O       157.130.0.0 [110/2] via 157.130.0.5, 00:18:32, FastEthernet1/1
C       157.130.0.4 is directly connected, FastEthernet1/1
C       157.130.0.8 is directly connected, FastEthernet1/0
C       157.130.0.12 is directly connected, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O       172.16.0.1/32 [110/3] via 157.130.0.5, 00:18:32, FastEthernet1/1
O       172.16.1.1/32 [110/2] via 157.130.0.5, 00:18:32, FastEthernet1/1
C       172.16.2.0/24 is directly connected, Loopback0
O    192.168.0.0/24 [110/2] via 157.130.0.13, 00:18:52, FastEthernet0/0

Router A EIGRP 100

router eigrp 100
redistribute ospf 1
network 192.168.0.0
network 157.130.0.16 0.0.0.3
network 157.130.0.20 0.0.0.3
auto-summary
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 1
network 157.130.0.12 0.0.0.3 area 1

RouterA-EIGRP100#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 6 subnets
O IA    10.1.0.0 [110/4] via 157.130.0.14, 00:19:33, FastEthernet0/0
O IA    10.2.0.0 [110/3] via 157.130.0.14, 00:19:33, FastEthernet0/0
O       10.3.1.0 [110/3] via 157.130.0.14, 00:19:33, FastEthernet0/0
O IA    10.4.1.0 [110/2] via 157.130.0.14, 00:19:33, FastEthernet0/0
O IA    10.100.0.0 [110/4] via 157.130.0.14, 00:19:33, FastEthernet0/0
O IA    10.200.0.0 [110/3] via 157.130.0.14, 00:19:33, FastEthernet0/0
     157.130.0.0/16 is variably subnetted, 7 subnets, 2 masks
D       157.130.0.0/16 is a summary, 00:20:33, Null0
O IA    157.130.0.0/30 [110/3] via 157.130.0.14, 00:19:33, FastEthernet0/0
O       157.130.0.4/30 [110/2] via 157.130.0.14, 00:19:33, FastEthernet0/0
O IA    157.130.0.8/30 [110/2] via 157.130.0.14, 00:19:33, FastEthernet0/0
C       157.130.0.12/30 is directly connected, FastEthernet0/0
C       157.130.0.16/30 is directly connected, FastEthernet1/0
C       157.130.0.20/30 is directly connected, FastEthernet1/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O IA    172.16.0.1/32 [110/4] via 157.130.0.14, 00:19:33, FastEthernet0/0
O IA    172.16.1.1/32 [110/3] via 157.130.0.14, 00:19:33, FastEthernet0/0
C       172.16.4.0/24 is directly connected, Loopback0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D    192.168.1.0/24 [90/30720] via 157.130.0.18, 00:20:32, FastEthernet1/0
D    192.168.2.0/24 [90/30720] via 157.130.0.22, 00:20:32, FastEthernet1/1
RouterA-EIGRP100#

I can ping from Router A EIGRP 100 all the way to a loopback interface in area 0

What I cannot do is ping from Router C EIGRP 100 to anything in the OSPF network.

Here is Router C EIGRP 100 config and routing table:

router eigrp 100
network 192.168.2.0
network 157.130.0.20 0.0.0.3
auto-summary
!

RouterC-EIGRP100#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     157.130.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       157.130.0.0/16 is a summary, 00:22:24, Null0
D       157.130.0.16/30 [90/30720] via 157.130.0.21, 00:22:23, FastEthernet0/0
C       157.130.0.20/30 is directly connected, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.6.0 is directly connected, Loopback0
D    192.168.0.0/24 [90/30720] via 157.130.0.21, 00:22:23, FastEthernet0/0
D    192.168.1.0/24 [90/33280] via 157.130.0.21, 00:22:23, FastEthernet0/0
C    192.168.2.0/24 is directly connected, FastEthernet0/1
RouterC-EIGRP100#

My overall question is how does Router C get the routes into its routing table for the OSPF network?  I need a host from EIGRP Router C to be able to get to a host on OSPF area 0

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

If you add a default metric under EIGRP on router A then your redistribution should work. You can add the default metric either as a separate command under router EIGRP or you can add the default metric as parameters on the redistribute command.

Without a default metric EIGRP can not understand the metric supplied by OSPF and without an understandable metric EIGRP can not redistribute routes.

HTH

Rick

11 REPLIES
Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

If you add a default metric under EIGRP on router A then your redistribution should work. You can add the default metric either as a separate command under router EIGRP or you can add the default metric as parameters on the redistribute command.

Without a default metric EIGRP can not understand the metric supplied by OSPF and without an understandable metric EIGRP can not redistribute routes.

HTH

Rick

Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Thanks Rick this does help and now makes sense.  I  have been looking and reading and it was not very clear about the metrics.  One last question, at least I hope.

I now see the routes but cannot ping from end to end.  Do I also need to redistribute eigrp into OSPF for replies to come back?

Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Yes. Right now the EIGRP only router does learn the OSPF routes. But the OSPF router does not know the routes from the EIGRP only router. So redistributing EIGRP into OSPF will fix that.

HTH

Rick

Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

does that require metrics like the redistribute ospf 1 metric 10000 1 255 1 1500

so on the ospf router does it need

redistribute eigrp 100 metric 10000 1 255 1 1500

Sorry this seems basic but this is new for me.

Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Hello,

>>

so on the ospf router does it need

redistribute eigrp 100 metric 10000 1 255 1 1500

No,   because OSPF metric is a simple scalar made of cumulative cost the 5  parameters of seed metric are EIGRP specific all other protocols define the seed metric as a simple number.

In addition to this OSPF is also a special case because it has a default metric for redistribution, but it requires a special option called subnets or it will advertise only major networks class A,B, C (without subnets OSPF performs classful summarization)

so you need

router ospf 1

redistribute eigrp 1 subnets

Hope to help

Giuseppe

Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

I did this and my eigrp table is not populating the routing table.

Any ideas?

OSPF 1 Router C

router eigrp 100
network 10.4.0.0 0.0.0.255
network 10.4.1.0 0.0.0.255
network 157.130.0.12 0.0.0.3
auto-summary
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 172.16.1.1
redistribute eigrp 100 subnets
network 157.130.0.4 0.0.0.3 area 1
network 10.4.0.0 0.0.0.255 area 1
network 157.130.0.12 0.0.0.3 area 1
network 10.4.1.0 0.0.0.255 area 2
network 157.130.0.8 0.0.0.3 area 2

!

RouterC#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.0.0.0/8 is a summary, 16:35:53, Null0
O       10.1.0.0/24 [110/3] via 157.130.0.5, 01:38:15, FastEthernet1/1
O       10.2.0.0/24 [110/2] via 157.130.0.10, 12:01:04, FastEthernet1/0
O       10.3.1.0/24 [110/2] via 157.130.0.5, 16:36:18, FastEthernet1/1
C       10.4.1.0/24 is directly connected, FastEthernet0/1
O       10.100.0.0/24 [110/3] via 157.130.0.5, 01:38:15, FastEthernet1/1
O       10.200.0.0/24 [110/2] via 157.130.0.10, 12:01:04, FastEthernet1/0
     157.130.0.0/16 is variably subnetted, 5 subnets, 2 masks
D       157.130.0.0/16 is a summary, 16:35:53, Null0
O       157.130.0.0/30 [110/2] via 157.130.0.5, 16:35:53, FastEthernet1/1
C       157.130.0.4/30 is directly connected, FastEthernet1/1
C       157.130.0.8/30 is directly connected, FastEthernet1/0
C       157.130.0.12/30 is directly connected, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O       172.16.0.1/32 [110/3] via 157.130.0.5, 01:38:15, FastEthernet1/1
O       172.16.1.1/32 [110/2] via 157.130.0.5, 16:35:53, FastEthernet1/1
C       172.16.2.0/24 is directly connected, Loopback0
O    192.168.0.0/24 [110/2] via 157.130.0.13, 16:36:18, FastEthernet0/0

EIGRP 100 Router A

router eigrp 100
redistribute ospf 1
network 192.168.0.0
network 157.130.0.16 0.0.0.3
network 157.130.0.20 0.0.0.3
auto-summary
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 1
network 157.130.0.12 0.0.0.3 area 1
!


RouterA-EIGRP100#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O E2    10.0.0.0/8 [110/20] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    10.1.0.0/24 [110/4] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    10.2.0.0/24 [110/3] via 157.130.0.14, 02:31:25, FastEthernet0/0
O       10.3.1.0/24 [110/3] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    10.4.1.0/24 [110/2] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    10.100.0.0/24 [110/4] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    10.200.0.0/24 [110/3] via 157.130.0.14, 02:31:25, FastEthernet0/0
     157.130.0.0/16 is variably subnetted, 7 subnets, 2 masks
D       157.130.0.0/16 is a summary, 16:37:37, Null0
O IA    157.130.0.0/30 [110/3] via 157.130.0.14, 02:31:25, FastEthernet0/0
O       157.130.0.4/30 [110/2] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    157.130.0.8/30 [110/2] via 157.130.0.14, 02:31:25, FastEthernet0/0
C       157.130.0.12/30 is directly connected, FastEthernet0/0
C       157.130.0.16/30 is directly connected, FastEthernet1/0
C       157.130.0.20/30 is directly connected, FastEthernet1/1
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O IA    172.16.0.1/32 [110/4] via 157.130.0.14, 02:31:25, FastEthernet0/0
O IA    172.16.1.1/32 [110/3] via 157.130.0.14, 02:31:25, FastEthernet0/0
C       172.16.4.0/24 is directly connected, Loopback0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D    192.168.1.0/24 [90/30720] via 157.130.0.18, 02:31:39, FastEthernet1/0
D    192.168.2.0/24 [90/30720] via 157.130.0.22, 02:31:39, FastEthernet1/1

I can go from Router A EIGRP 100 to a loopback ip in area 0

I cannot go from Router C OSPF 1 to anything inside the EIGRP network.  I was trying to get to 192.168.2.1 Fa0/1

It does not look like my routes are being redistributed into OSPF from EIGRP

Am I missing something else?

Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Since your network has multiple routers identified as Router A and multiple routers identified as Router C it is a bit difficult to keep them straight and to know which one you are referencing in your questions.

In what you post this time I notice that there are no EIGRP routes in the routing table of Router C, other than the summary routes that EIGRP has generated. If there are no EIGRP routes in the routing table then there can be no routes redistributed from EIGRP to OSPF.

so perhaps the question becomes why are there no EIGRP routes in the routing table of Router C? To figure this out I would suggest that we start with the output on Router C of the commands show ip eigrp neighbor and show ip eigrp interface.

HTH

Rick

Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

well...I found one of the issues.  I had a router flapping which was causing my ospf network to go crazy.  I had to shut the router down to get it to stop going from init to full every second.  Once I did this I added the ospf redis back into the eigrp router edge and my internal eigrp routers now see the ospf routes.  Now to figure out why that router is flapping.  Either way I am one step closer.  Thanks Rick and Guiseppe

Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Hello,

to effectively redistribute OSPF into EIGRP you need to configure an EIGRP seed metric

Router A EIGRP 100

router eigrp 100

redistribute ospf 1

network 192.168.0.0

network 157.130.0.16 0.0.0.3

network 157.130.0.20 0.0.0.3

auto-summary

!

this is important otherwise OSPF subnets cannot be injected in EIGRP domain because EIGRP doesn't know how to initialize all the metric components.

router eigrp 100

default-metric 10000 100 255 1 1500

these are bandwidth, delay, realibilty, load and MTU

exact values are not important unless there are multiple points of redistribution

see

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094613.shtml#rdc

Hope to help

Giuseppe

Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Giuseppe - thanks.  Rick beat ya!!!!

Actually this all helps.  I am also in the process of studying for the BSCI - hoping to complete all 3 tests by June and in the book it does not really explain this very well in the redistribution section.

Hall of Fame Super Silver

Re: Lab help - OSPF multi area to EIGRP Redistribution

Hello,

>> Giuseppe - thanks.  Rick beat ya!!!!

I'm happy to have been beaten by Rick, actually I hadn't seen he was answering too ( I couldn't know actually)

Best Regards

Giuseppe

3747
Views
5
Helpful
11
Replies
CreatePlease to create content