Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LACP on 3750G uplink ports

Hi,

I'm hoping for some decent guide for my problem.

Here is the situation:

I have a cisco 3750G-48TS-S in my network connected via ethernet to my software router through uplink port 50.

All 48 ports are set as access-ports with separate vlans assigned to them, while port 50 is set as "no switchport".

Now, I need to run link aggregation on this switch to put more bandwidth on it.

I have hooked up port 51 to my software router and can setup link bonding on software router with no problems, but I need to know if I can still have the vlans set on software router and assigned on the switch and have the uplink ports set as a trunk port.

If yes, what would the ultimate config for these 2 ports look like?

Thanks in advance.

4 REPLIES
New Member

LACP on 3750G uplink ports

Anyone???

Cisco Employee

Re: LACP on 3750G uplink ports

Hi Mohammad,

It is absolutely possible to bind your ports 50 and 51 into a single EtherChannel using LACP. You have two options of configuring the resulting Port-channel: either it will keep the no switchport configuration and it will continue to work as a routed port (similar to what you appear to have right now), or you can configure it to become an 802.1Q VLAN trunk.

If you want the EtherChannel to be a Layer2 trunk then the configuration would be similar to this:

interface range gi1/0/50 - 51

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

You will have to use appropriate tools on your software router to create a bonded channel and create VLAN subinterfaces over it. What kind of software router is that - is it running Linux?

Best regards,

Peter

New Member

LACP on 3750G uplink ports

Hi Peter,

Thank you very much for the complete response.

I'm hoping to have "no-switchport" setting on etherchannel. If yes, it will be done with least pain.

BTW, software router is Vyatta.

I've done etherchannel on cisco/cisco environment but with vtp. I'm not sure how vyatta will handle this.

I appreciate your inputs on this matter.

Cisco Employee

Re: LACP on 3750G uplink ports

Hello Mohammad,

I see. In that case, you have decided to use a different configuration than the one you originally requested. In your first post, you wrote that you want the uplinks to be trunks. Trunks are by definition Layer2 switched ports, so that is my configuration I have suggested. If you want the uplinks to be no switchport-alike ports, then that is a Layer3 routed EtherChannel with its own IP address and no VLANs being carried over it. The configuration would look as follows:

interface range gi1/0/50 - 51
 no switchport
 channel-group 1 mode active

interface Port-channel 1
ip address 192.0.2.1 255.255.255.0

On the Vyatta router, I do not expect any issues with any of these configurations. As the Vyatta is based on Linux, it nicely supports LACP for link bundling, and it is capable of using the bundle both as a Layer2 switched port with VLAN subinterfaces, and as a Layer3 routed port.

Best regards,

Peter

698
Views
0
Helpful
4
Replies
CreatePlease to create content