Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LAN to LAN tunnel

Hello,

If you could help me, it would be great.

I am trying to route the following segments(each distant location) and do not know how to route A from/to C.

Between A and B is kind of secure line provided by my ISP. ISP controls source/destination segment and A can be accessed only from B and B can be accessed only from A. B had other gateway via L3SW.

B and C has already established routing and can connect to each other via the L3SW.

<Segment A>

10.10.1.80/28

Router: cisco 1812J

Dialer1: PPPoE/ip unnumbered fas0

fas0 ip: 10.10.1.81

<Segment B>

10.10.1.64/28

Router: cisco 1812J

Dialer1: PPPoE/ip unnumbered fas0

fas0 ip: 10.10.1.65

L3SW: 10.10.1.78

*B & C can connect between this L3SW

<Segment C>

10.10.2.0/24

I think I need to configure tunneling to router A and B to make routing from A to C.

<Configuration router A>

interface Tunnel0
ip address 192.168.100.1 255.255.255.0
tunnel source FastEthernet0
tunnel destination 10.10.1.65
tunnel mode ipip
ip mtu 1434

interface FastEthernet0
description Connected to Ethernet LAN
ip address 10.10.1.81 255.255.255.240
ip tcp adjust-mss 1390

interface Dialer2
description PPPoE Dialer Interface
ip unnumbered FastEthernet0

<Configuration router B>

interface Tunnel0
ip address 192.168.100.2 255.255.255.0
tunnel source FastEthernet0
tunnel destination 10.10.1.81
tunnel mode ipip
ip mtu 1434

interface FastEthernet0
  description Connected to Ethernet LAN
  ip address 10.10.1.65 255.255.255.240
  ip tcp adjust-mss 1390

interface Dialer2
  description PPPoE Dialer Interface
  ip unnumbered FastEthernet0

I am not quite sure how to write the configuration to router B to make routing A to C. As I wrote above, B and C is conncted and A can only connect to B. I am not sure of mss and mtu. If I do not use tunneling, mtu is 1454 and mss is 1414.Any suggestion would be appreciated.

Regards,

Everyone's tags (1)
1 REPLY
Silver

Re: LAN to LAN tunnel

yes, the idea to make a tunnel is good

then you need to add the following commands:

in A:

ip route 10.10.2.0 255.255.255.0 tunnel0

in C:

ip route 10.10.10.80 255......... L3 switch

in L3 switch:

ip route 10.10.10.80 255......... router B

1832
Views
0
Helpful
1
Replies
CreatePlease login to create content