Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

leased line backup problem

Plz help me out leased line backup problem-

i configuerd ISDN for Leased line backup but after Leased line goes down Traffic is not routed thro ISDN line .when i put this -

ip nat inside source list 101 interface bri0 overload

Then traffic is routed through ISDN but after this leased line is not working so plzz tell my right configrutation for this iam sending the configrutation with the attachment

16 REPLIES

Re: leased line backup problem

I feel you can test after doing these changes. It'll cause some downtime, so you can schedule changes in off business hours or whenever you feel is the right time.

interface Loopback0

ip nat outside

interface BRI0

no ip nat outside

interface Serial0

no ip nat outside

see if it works .... rate if it does ...

New Member

Re: leased line backup problem

hi senthil as you have described that after hardening command

ip nat inside source list 101 inteface bri0 overload it works .but when lease line come up it doesnt

it happens because u cant nat 1 access list to multiple interface .

so u can do 1 thing prepare 1 more access list .config will be like this

access-list 101 permit ip 192.168.5.0 0.0.0.255 any

access-list 102 permit ip 192.168.5.0 0.0.0.255 any

ip nat inside source list 101 interface Loopback0 overload (either loopback0 or serial0)

ip nat inside source list 102 interface bti0 overload

just try this and this will work

New Member

Re: leased line backup problem

Hi

try putting a metric instead of backup interface also. I have found that this works in some of the cases.

regards

Ashish Gupta

New Member

Re: leased line backup problem

I agree Jithesh and rated too ;)

New Member

Re: leased line backup problem

thanx jitesh today i fixed a downtime with my client i will check this configruation

but my dought is if i do this then nating will happen throug loopback or bri0 ?

New Member

Re: leased line backup problem

can u discribe me? how it will work plzzz

New Member

Re: leased line backup problem

plzz find out the configruation with attachment

my problem is after leased line gose down ISDN is comming up and traffic is going from router to outside via bri but from pc traffic is not going outside

from i am able to ping bri but iam not able to ping isp gateway may be there is some issue of nating plzz any body can help for the same

Re: leased line backup problem

Hi Senthil

I did face similar kinda probs in the past in giving BRI as a backup for the customer who has availed Internet services..

I would rather suggest to check out with the SP if they can provide/map the same WAN ip to your backup/isdn.

This can be achieved by configuring the radius attributes accordingly for the isdn bri backup id.

Also you can avail a /30 ip from your SP and have it configured as a loopback and do the overload over the loopback interface.

As per your requirement this will provide 2 gateways to you with redundancy built in.

Did you configure the loopback with a public ip and checked out the same with the necessary config ?

did you check for the nat translation while your main link is down ?

regds

Note: Attachment missing in your earlier post.

Re: leased line backup problem

Hi,

From your post, its clear that with BRI0 overload it works , But with lo0 overload it doesnt work during backup.

Can u pls check with your ISP wheter a higher metric route for the loopback is pointed via the BRI interface so that loopback reachability is fine during LL failure.

Hope this helps

regards

vanesh k

New Member

Re: leased line backup problem

ya i configured the loobback with public ip

plzz check the configuration iam sending you with the attachment

in the configuration

check this statment

ip nat inside source lits 101 interface loopback overload

after leased line goes down if i ping from router to any public ip iam getting reply

but if i ping frm my pc iam not getting reply

but if put statment like this

ip nat inside source lits 101 interface bri0 overload

after this iam able to ping public ip from my pc also

Re: leased line backup problem

Hi,

ping works fine after ur LL failure bcos it takes the BRI ip as source and works fine .But ur Lan ips gets natted to loopback , so pls check whether reverse route for Loopback via your backup interface is present or not at ISP end.

regards

vanesh k

New Member

Re: leased line backup problem

i have two wan link one is leased line second is ISDN line both are for airtel

you mean to say i need to check with our ISDN side ?

Re: leased line backup problem

Hi,

As you said while on ISDN , pat is not working , so suspecting some routing issue in backup from ISP side . So just check how is the routing done at ISP end . Primary route for Loopback via LL and secondry route via ISDN . Pls check once to isolate the routing problem at ISP end.

regards

vanesh k

Re: leased line backup problem

Hi

1.Are you manualling shutting down the serial interface using shut command to check the backup ?

2.Do switch off the modem to make the link down and check the backup connectivity.

3.Did you check up whether your isdn comes up when your primary link goes down ?

4.you can verify the same using Show isdn active/show isdn status once your primary link is down.

5.Also you need to go through the steps already mentioned by Vanesh in his earlier post.

regds

New Member

Re: leased line backup problem

hi

spremkumar

ya i already did the same but i need to check with isp

New Member

Re: leased line backup problem

Dear senthil

As i have suggested u earlier

taking primary route for lease line

use command

ip nat inside source list 101 interface serial0 overload

delete loopback interface

secondly in bri0 config ip address is negotiated so check what ip address u r getting . try to ping an internet ip drom ur router when isdn is active

if it works then

just prepare access list 102 permitting same internal network and overload it with bri0

problem u r facing can happen if isp failed to put seconary route pointing bri0 .u can check this through as u have put this command

ip nat inside source static 192.168.5.20 59.145.X.X extendable.

just ask any 1 of them to ping this ip 59.145.X.X from outside . when lease line is down . if it's doesnt ping that means isp had not inject secondary route for same network 59.145.a.b/29 will be i guess. ok try this and let me know

190
Views
11
Helpful
16
Replies