Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

leased line loadblancing + failover overleased line

hi to all

can any body help me out regarding this problem

i have 1721 router in this router i have two leased line in this.

my requirment

1. some prime users packet should go via Serial0

and rest useres packet should go via serial1

2. if s0 will dwon all prime users all shoul go via s1

can any body tell me configuration for this requirment

30 REPLIES

Re: leased line loadblancing + failover overleased line

Hi

You can use route-map to do the same .

1.Create a access-list for listing the prime users source ips

access-list 1 permit x.x.x.x

access-list 1 permit y.y.y.y

2.Create a route-map to set the next-hop for prime users

route-map prime-users permit 10

match ip address 1

set interface s0

3.All others except the prime users would go through the S1

ip route 0.0.0.0 0.0.0.0 s1

In case your S0 goes down , the route-map will have no interface to put the packet as s0 is down , so it sends the traffic default to s1.

In case of s1 failure , have a higher metric route to s0 so that during failure you have a auto fallback

ip route 0.0.0.0 0.0.0.0 s1 200 ---- higher metric.

Hope this helps

regards

vanesh k

New Member

Re: leased line loadblancing + failover overleased line

thanx for reply

tell me wat is the nating confguration for this

Re: leased line loadblancing + failover overleased line

Hi

I have not tried this , pls configure to check it out

You need to do pat for making ur multiple users to access internet.

1.For specific users to go via S0

a. Access-list for the specific users already created

pat :

ip nat inside source list 1 interface s0 overload

b.Access-list for other users

access-list 2 permit x.x.x.0 0.0.0.255 --- if your internal segment is /24

pat :

ip nat inside source list 2 interface s1 overload

c.During S1 failure for all traffic to go via S0

access-list 3 permit x.x.x.0 0.0.0.255

ip nat inside source list 3 interface s0 overload

int s0

ip nat outside

int s1

ip nat outside

int e0

ip nat inside

ip policy route-map prime-user

Pls try and let us know the results

Hope this helps

regards

vanesh k

New Member

Re: leased line loadblancing + failover overleased line

thanx i ll try this conf

but i already tryied this conf

i tried this confg

it just a example:-

lets prime user ip is 192.168.5.6

so i did configrutatin like that

access-list 1 permit 192.168.5.6 0.0.0.0

rout-map primeusers sequence 100

match ip address 1

set interface s1 s0

rout-map othersusers 2

set interface s0

ip nat inside source route-map primeusers interface s1

ip nat inside source route-map othersusers interface s0

int e0

ip nat inside

ip policy route-map primeuser

but when s1 is getting down packet it not going via s0

my dought is some problem with nating plz find out right configuration

Re: leased line loadblancing + failover overleased line

Hi

Just add another acl

access-list 2 permit 192.168.5.0 0.0.0.255

and change this

ip nat inside source list 2 interface s0 overlaod .

Just try this config first and then try the config given by me

Hope this helps

regareds

vanesh k

New Member

Re: leased line loadblancing + failover overleased line

thanx

i will go there on monday morning i ll try this u r frm which city?

New Member

Re: leased line loadblancing + failover overleased line

i tried this confg

it just a example:-

lets prime user ip is 192.168.5.6

so i did configuration like this:-

access-list 1 permit 192.168.5.6 0.0.0.0

rout-map primeusers sequence 10

match ip address 1

set interface s1 s0

rout-map othersusers 20

match ip address 1

set interface s1 s0

route-map othersusers 30

set s0

ip nat inside source route-map primeusers interface s1

ip nat inside source route-map othersusers interface s0

int e0

ip nat inside

but when s1 is getting down packet it not going via s0

my dought is some problem with nating plz find out right configuration

Silver

Re: leased line loadblancing + failover overleased line

Did you add the static route & policy-map commands that suggest by network.king ?

ip route 0.0.0.0 0.0.0.0 s0 <-- primary path

ip route 0.0.0.0 0.0.0.0 s1 200 <-- backup if s0 down

int e 0

ip policy-map otherusers

If you have the static route configured in the router, you need to set the normal traffic. You only need to specify the traffic which you want to route to s1 and apply it as policy-based routing.

i.e. if match the access-list, forward the packet to s1, otherwise, follow the routing table to forward the packet to s0.

Can you post the full config. then we can check it ?

Hope this helps.

New Member

Re: leased line loadblancing + failover overleased line

i have 1721 router in this router i have two leased line in this.

my requirment

1. some prime users packet should go via Serial0

and rest useres packet should go via serial1

2. if s0 will dwon all prime users all shoul go via s1

can any body tell me configuration for this requirment

i tried this confg

it just a example:-

lets prime user ip is 192.168.5.6

so i did configuration like this:-

access-list 1 permit 192.168.5.6 0.0.0.0

rout-map primeusers sequence 10

match ip address 1

set interface s1 s0

rout-map othersusers 20

match ip address 1

set interface s1 s0

route-map othersusers 30

set s0

ip route 0.0.0.0 0.0.0.0 s1

ip route 0.0.0.0 0.0.0.0 s0

ip nat inside source route-map primeusers interface s1

ip nat inside source route-map othersusers interface s0

int e0

ip nat inside

but when s1 is getting down packet it not going via s0

my dought is some problem with nating plz find out right configuration

Re: leased line loadblancing + failover overleased line

Hi Rohit,

Pls let me know wheter you tried the config given by me in the earlier post

regards

vanesh k

New Member

Re: leased line loadblancing + failover overleased line

ya i aleary tryed that one but its not working

Silver

Re: leased line loadblancing + failover overleased line

Thanks for the config. Please check my comments as below :

access-list 1 permit 192.168.5.6 0.0.0.0

access-list 2 permit any <-- add this for NAT

rout-map primeusers sequence 10

match ip address 1

set interface s0 <-- remove s1 and set s0 as next-hop

no rout-map othersusers 20 <-- no need this route-map

match ip address 1 <-- no need this route-map

set interface s1 s0 <-- no need this route-map

route-map othersusers 30 <-- no need this route-map

set s0 <-- no need this route-map

ip route 0.0.0.0 0.0.0.0 s1

ip route 0.0.0.0 0.0.0.0 s0 200 <-- Add flowing static to this route, s0 as backup path

ip nat inside source list 2 overload <-- change to use access-list 2 (all traffic) and add 'overload' for port address translation

ip nat inside source route-map othersusers interface s0 overload <-- remove this nat rule

int e0

ip nat inside

ip policy route-map primeuser <-- add this to enable policy-based routing

int s0

ip nat outside <-- add this for NAT

int s1

ip nat outside <-- add this for NAT

In above suggestion, the primary path is s1 for all user except prime user. Primeuser will use s0 for outgoing. If s0 down, the primeuser will use s1 for outgoing as same as other users. If s1 down, the floating-static will take effect that s0 will be the outgoing path for all users (including primeuser).

Please check below link for more information of different features :

NAT :

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_white_paper09186a0080091cb9.shtml

PBR :

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a008075fae6.html

Floating-static :

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a0080093d6e.shtml

Please read above links that let you understand the operation and the correct commands format.

Hope this helps.

New Member

Re: leased line loadblancing + failover overleased line

thanx for this but my dought is

plzz can u give me the clear picture of nat cammond

in which interface i have to overload

we have interface so s1 which int i need do ovlerload

Silver

Re: leased line loadblancing + failover overleased line

According to my suggestion. Both s0 & s1 should be enable overload, the reason is both links may be the backup for another, so you have to enable both.

However, the problem of your original config is not only the NAT and also the routing problem. Please try to follow my suggestion or Venash's suggestion to test it again.

Moreover, if you can provide FULL config.(w/o password shown) to us, we can help more.

And, please read the links that I provided, they are useful for you to understand the feature operation.

Hope this helps.

New Member

Re: leased line loadblancing + failover overleased line

this is my current configuration plzz check it out wat i need to do

plzz tell me nating statament as well

--More-- !

!

!

!

interface Loopback0

ip address 59.145.X.X 255.255.255.x

shutdown

!

interface FastEthernet0

ip address 192.168.5.100 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

speed auto

half-duplex

!

interface Serial0

ip address 203.101.x.x 255.255.255.252

ip nat outside

ip virtual-reassembly

ip route-cache flow

!

interface Serial1

ip address 202.x.x.x 255.255.255.252

ip nat outside

ip virtual-reassembly

ip route-cache flow

!

interface Virtual-Template1

ip unnumbered FastEthernet0

peer default ip address pool mypool

ppp encrypt mppe auto

ppp authentication ms-chap-v2 pap chap ms-chap callin

!

ip local pool mypool 192.168.5.201 192.168.5.205

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 serial1

ip flow-export source FastEthernet0

ip flow-export version 5

ip flow-export destination 192.168.5.73 9996

!

no ip http server

no ip http secure-server

ip nat inside source route-map primery interface serial0 overload

ip nat inside source route-map other interface Serial1 overload

logging source-interface Serial0

logging 192.168.5.2

access-list 101 permit ip 192.168.5.6 0.0.0.0 any

Silver

Re: leased line loadblancing + failover overleased line

Thanks for the config. but you missed to post the route-map section. Please consider to try my suggestion in pervious and test again.

Hope this helps.

New Member

Re: leased line loadblancing + failover overleased line

plzz check the attachment n telll me wat is the nating statment i shld put

Silver

Re: leased line loadblancing + failover overleased line

Did you test any suggestions from other Netpro and me ? Referring to the config file, it is the same as the post from you before.

PLEASE check my pervious post, it already indicated the suggestion one-by-one in command format.

What I suggested is to add a new access-list then use it in the nat rule command. Please check below :

access-list 2 permit any

ip nat inside source list 2 overload

Please advise the test result.

Hope this helps.

New Member

Re: leased line loadblancing + failover overleased line

ya i alredsy tryed this but its not working

can u tell me it is possible that we can do failover + loadblancing togather in single router ?

Silver

Re: leased line loadblancing + failover overleased line

Yes, our proposal on the solution should work, but it is fail-over instead of load-balancing. According to your requirement, primeuser go to s1 and other go to s0, it is a fail-over requirement. Moreover, if you already specify two groups of users to forward to two different path, how to achieve the load-balancing ? Please advise your latest requirement and we try to help.

Please post the modified config with our suggestion and advise the test result on which area not work. Thx.

New Member

Re: leased line loadblancing + failover overleased line

thanks i ll send it to u by evening right now iam not in client place

i wana give u exact senario :-

client have two leased line in in 1721 router

leasedline1- s0

leasedline2- s1

clint requirment:-

1.He want two use both leased line at same time means....(loadblancing)

2.if s1 is get down all trafic shd go other interface(leasedline)

can u tell me it is possible ?

Silver

Re: leased line loadblancing + failover overleased line

Thx. for clarification. This is possible.

The operation like two links will be load-balanced in normal case, if one of the link down, it will forwardf the traffic and the remaining link will continue to carry all traffic.

Your original config of two static route w/ no metric is already carrying this function. It is the normal behaviour of routing.

If this is the case, try to use the NAT config that proposed earlier and test again.

If you still want to let prime user to use one link only, you can also apply the policy-based config but no need the floating-static. However, it will make the other user's traffic to be load-shared in two links and prime user only use one link.

Hope this helps.

New Member

Re: leased line loadblancing + failover overleased line

thanx jack sorry for this

iam sending u my configuration with attachment can u modified it and send it me back with exact configuration

i wana both links will be load-balanced in normal case, if one of the link down, it will forwardf the traffic and the remaining link will continue to carry all traffic.

Silver

Re: leased line loadblancing + failover overleased line

I am willing to help but my pervious post already indicated that your static route config is fine to provide the required load-sharing and backup function.

Could you confirm do you require to NAT ALL traffic or only host 192.168.5.6 ? If you will NAT all LAN traffic to remote, I have already proposed in my pervious posts too. I retype it as below, please test it. The idea is to let all traffic from e0 to be NAT at s0 & s1 then forward to remote. So, we have a access-list 2 to include all traffic and setup a NAT rule for both s0. Then remove the original NAT rule.

access-list 2 permit ip any

no ip nat inside source route-map primery interface serial0 overload

no ip nat inside source route-map other interface Serial1 overload

ip nat inside source list 2 overload

Please let me know the problem is you cannot type the command or proposed modification not work.

New Member

Re: leased line loadblancing + failover overleased line

thanx jack

interface Loopback0

ip address 59.145.X.X 255.255.255.x

shutdown

interface FastEthernet0

ip address 192.168.5.100 255.255.255.0

ip nat inside

interface Serial0

ip address 203.101.x.x 255.255.255.252

ip nat outside

interface Serial1

ip address 202.x.x.x 255.255.255.252

ip nat outside

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 serial1

( ip nat inside source list 2 overload

or

ip nat inside source list 2 interface s0 overload

ip nat inside source list 2 interface s1 overload )

access-list 101 permit ip 192.168.5.0 0.0.0.255 any

(what exact access-list i need to configure)

any thing els i need to configure ?

and my dought how it will do load blance and failover ???

New Member

Re: leased line loadblancing + failover overleased line

thanx jack

any thing els i need to configure ?

and my dought how it will do load blance and failover ???

interface Loopback0

ip address 59.145.X.X 255.255.255.x

shutdown

interface FastEthernet0

ip address 192.168.5.100 255.255.255.0

ip nat inside

interface Serial0

ip address 203.101.x.x 255.255.255.252

ip nat outside

interface Serial1

ip address 202.x.x.x 255.255.255.252

ip nat outside

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 serial1

( ip nat inside source list 2 overload

or

ip nat inside source list 2 interface s0 overload

ip nat inside source list 2 interface s1 overload )

access-list 101 permit ip 192.168.5.0 0.0.0.255 any

(what exact access-list i need to configure)

Silver

Re: leased line loadblancing + failover overleased line

You are welcome. You have two static route commands that will carry the load-sharing funtion for outgoing traffic. If one of the WAN link down, the route belongs to the down interface will be disappeared and the router will follow the only and remaining route to forward the traffic to remote.

I am sorry for the incorrect syntex of NAT command. Please use your NAT command of "ip nat inside source list 2 interface s0/s1 overload" instead of my pervious suggstion.

And also add an access-list,"access-list 2 permit ip any" to the router. It is for the NAT rule,"list 2".

Wait for your test result.

New Member

Re: leased line loadblancing + failover overleased line

thanx jack

plzz check this is right :-

interface FastEthernet0

ip address 192.168.5.100 255.255.255.0

ip nat inside

interface Serial0

ip address 203.101.x.x 255.255.255.252

ip nat outside

interface Serial1

ip address 202.x.x.x 255.255.255.252

ip nat outside

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 serial1

ip nat inside source list 101 interface s0 overload

ip nat inside source list 102 interface s1 overload

access-list 101 permit ip 192.168.5.0 0.0.0.255 any

access-list 102 permit ip 192.168.5.0 0.0.0.255 any

Silver

Re: leased line loadblancing + failover overleased line

It is fine for this config. Did you test it and meet the customer expectation ?

142
Views
0
Helpful
30
Replies
CreatePlease login to create content