Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

limit band to 16mbps

Hi Experts

Ps take a look to the attached topology,i have router-partner F0/0 assigned a public ip address to connect over Internet using ipsec to his location,now i need to limit the connection to just 16 Mbps,the customer has access to this cpe over the Internet so i Can't hard code the interface using the bandwidth command to 16Mpbs,is it possible to limit it to 16 mbps on my border coz the traffic pass via these border to the internet

thanks

14 REPLIES

limit band to 16mbps

Hi Ibrahim

depends on the Equiptment you have, but in general most Cisco Gear understands Traffice Shaping and Policing as part of QoS. So if you dig a litte into the documentation for your gear. You will get an Idea.

HTH

Patrick

limit band to 16mbps

Hi Ibrahim,

It is also depends if the interface on the Border router is used only by this customer.

In this case, you can just apply a traffic shaping or policing to shape or drop the traffic that exceeds the 16Mbps.

If the interface to the internet is also used by other customers (not displayed in the figure) you have to differentiate the traffic to this interface for every customer and then police or shape the traffic according to your requirments.

It should be noted that if you need to limit the traffic in both direction that only traffic policing can be applied to the inbound direction of the BR's interface.

Hope that helps,

Vasilis

New Member

limit band to 16mbps

Hi

Thanks for ur reply

can u guys post sample confg for a similar setup

thanks

Jamil

limit band to 16mbps

You can use the next good link as reference for traffic policing

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfpoli_ps1835_TSD_Products_Configuration_Guide_Chapter.html

and the next for traffic shaping

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfdts.html

I would recommend to use traffic shaping for the outbound traffic

Hope that helps

Vasilis

New Member

limit band to 16mbps

Hi Vasilis ,Hi patrick

the cpe of the partner isn't directly connected to our border , i give him connectivity to his location from my borders

pls advise

thanks

jamil

limit band to 16mbps

Hi jamil

your coustomer is connected to your switched infastructure? If you have switches there you can do the job on the first switch, with policing. Or must the job done on your border routers?

if you look here you find an idea for policing.

https://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml#cg23

Patrick

New Member

limit band to 16mbps

Hi Patrick

yes his connected to my infrastructure switching

can u pls post me a sample how to do it either on the border and the switch

thanks

jamil

Re: limit band to 16mbps

Hi Jamil

May be something like this:

!!!! please test it some where safe and recalculate values: !!!!

This for you first switch where cpe is connected.

HTH



Patrick

!

ip access-list to-cutomer 
permit ip any host 192.168.0.1 (customer address)

!

ip access-list from-cutomer 
permit ip host 192.168.0.1 (customer address) any 
!
class-map  Class-to-Cutomer
 
match access-group name 
to-cutomer 
!
class-map  Class-from-Cutomer

  match access-group name 
to-cutomer 

!
policy-map policy-to-customer
 class 
Class-to-Cutomer
  police 16000000 8000 exceed-action drop
exit
exit
!
policy-map policy-from-customer
 class 
Class-from-Cutomer
  police 16000000 8000 exceed-action drop
exit
exit
!
interface GigabitEthernet1/0/20
 description Interface-pointing-to-Customer
 
service-policy input 
policy-from-customer
!
interface GigabitEthernet1/0/1
 description Interface-pointing-border-1
 
service-policy input 
policy-to-customer
!
interface GigabitEthernet1/0/2
 description Interface-pointing-border-2
 
service-policy input 
policy-to-customer
!

Message was edited by: Patrick Marc Preuss

New Member

limit band to 16mbps

ThanksPatrick

limit band to 16mbps

Hi Jamil,

I would recommend to use traffic shaping for the outbound traffic instead of policing.

It uses the router buffers to delay the traffic instead of dropping the exceeded traffic.

For the inbound traffic you can apply only policing.

Hope that helps,

Vasilis

New Member

Re: limit band to 16mbps

Hi Vasilis ,

Pls would you pls post a sample so that i can use it as reference!pls specify where it should be applied on the border or on the switching where the CPE is connected,its already mentioned by Mr.Patrick, thanks to him for his great input

Hi Patrick

what is ur recommendations ?Policing or shaping?

jamil

limit band to 16mbps

Hi Jamil,

It depends on the switch...if this is multilayer switch and can support traffic shaping/policing I would recommend to apply the config to the SW.

In general, it is better to shape/police the traffic as close to the source as possible in order to not overwhelm your network with additional traffic.

Patric's  example has taken into consideration only the traffic from customer to the internet.

You have also to shape or police  the traffic from the internet to the customer. Moreover, if this interface is used only for this customer your configuration could be much more simple since you do not need the class- maps.

A possible config.

policy-map INTERNET-TO-CUSTOMER

class class-default

shape average 16000000

int g0/2

service-policy output INTERNET-TO-CUSTOMER

policy-map policy-from-customer

class class-default

  police 16000000 8000 exceed-action drop

  exit

int g0/2

service-policy input policy-from-customer

Hope that helps!

Vasilis

limit band to 16mbps

Hi Vasilis

both direction should have be i i thought from (gi 1/0/20) and to (gi 1/0/1, gi 1/0/2)  cutomer. when you have dual uplinks to your core from customer. maybe i missed it day was long:-) and should only be a starting point ...

and i aggree try to get the traffic as early as possible, confrom the traffic on the borders can be an idea. 

Patrick

New Member

Re: limit band to 16mbps

thanks guys

382
Views
36
Helpful
14
Replies