Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Line protocol up problem up: cable removed !!

Hi,

I am facing a very strange problem in the gigabit ethernet card of router.

Even if we physically disconnet the router ethernet cable the line protocol shows up only.

If we check show int gig0/1

it shows protocol up !!

Can it be IOs problem.

Due to this some other functions are hampering like interface tracking.

Any experience please share.

Thanks

subodh

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Line protocol up problem up: cable removed !!

subodh

Is it possible that the interface has been configured with "no keepalive"? Configuring the interface this way will produce exactly the symtpoms that you describe in keeping the interface line protocol up even when the interface is not connected. If that is not the issue then please post the complete interface configuration, the output of show interface for the interface, and the output of show version.

HTH

Rick

3 REPLIES
Hall of Fame Super Silver

Re: Line protocol up problem up: cable removed !!

Hello Subodh,

verify the interface configuration: if it is an RJ-45 interface if you disable the keepalive the interface stays up up even if the cable is unplugged and you can even ping it !

For fiber based GBIC no keepalive + no negotiate could produce the same results.

post the interface config and a show int

Hope to help

Giuseppe

New Member

Re: Line protocol up problem up: cable removed !!

Hi,

Thanks a Lot.

On our gi0/1 we have following "no" commands

no keepalive

no cdp enable

no mop enable

I will remove " no keepalive" and default keepalive will be set to 10 seconds and then I will actually remove the cable and will post the result. As the network is under production it may take a little while a day max.

Thanks a lots again.

Subodh

Hall of Fame Super Silver

Re: Line protocol up problem up: cable removed !!

subodh

Is it possible that the interface has been configured with "no keepalive"? Configuring the interface this way will produce exactly the symtpoms that you describe in keeping the interface line protocol up even when the interface is not connected. If that is not the issue then please post the complete interface configuration, the output of show interface for the interface, and the output of show version.

HTH

Rick

199
Views
10
Helpful
3
Replies
CreatePlease login to create content