Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

BP
New Member

Link failover with Ethernet ???

I have two routers one (R1) with a ethernet link to ISP A and the other (R2) with a DS3 link to ISP B. All traffic is set to go over the ethernet on R1. It's also setup to run HSRP on the inside ethernet links so if R1 failed all traffic would go to R2 over ISP B. we have BGP running to also favor ISP A link when not in a failover.

My question is if we have a failure in the ethernet link (i.e. some cut the ethernet cable(stupid vendor!!!)) that stops all traffic out that link but the port will remain up how do I have it sense that the ethernet link is down or atleast not a vailid port and have all traffic fail over to the backup router.

Everywhere i look I see how to do it with serial links but nothing about a mix of serial and ethernet.

Thanks in advance I am sure there is a answer out there I am just not seeing it.

5 REPLIES
Silver

Re: Link failover with Ethernet ???

Enhanced object tracking is the thing for you

www.cisco.com/univercd/cc/td/doc/product/ software/ios122/122newft/122t/122t15/fthsrptk.htm

or you could always run a Routing protocol with ur SP over the ethernet

BP
New Member

Re: Link failover with Ethernet ???

thanks attrgautam

after reading the link it looks like the tracking of the line-protocol is what I want. Besides adding the tracking option to the outside ethernet interface on R1 what other configuration is needed? I can't see how I would configure the routers to get HSRP to work on the outside interfaces due to different IP addr ranges or I am just blind and not seeing the option I need.

Thanks again

i.e

R1

interface FastEthernet0/0

description LAN INTERFACE

ip address 10.0.0.1 255.255.255.0

no ip redirects

no ip proxy-arp

duplex full

standby 1 ip 10.0.0.3

standby 1 timers 3 10

standby 1 priority 95

standby 1 preempt

interface FastEthernet3/0

description WAN INTERFACE

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip proxy-arp

duplex full

track 1 interface ethernet 3/0 line-protocol

R2

interface FastEthernet0/0

description LAN INTERFACE

ip address 10.0.0.2 255.255.255.0

no ip redirects

no ip proxy-arp

duplex full

standby 1 ip 10.0.0.3

standby 1 timers 3 10

standby 1 priority 95

standby 1 preempt

interface Serial2/1.1 point-to-point

description DS3

bandwidth 44210

ip address 172.16.1.1 255.255.255.252

frame-relay interface-dlci 1 IETF

Silver

Re: Link failover with Ethernet ???

Yes you can track even static routes that is what i had in mind. So point one default to the Ethernet link and track the route with say the next hop of ethernet. If the tracking fails it will switch over to tht serial link

Check this link out

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123newft/123limit/123x/123xe/dbackupx.htm

This should help you out

New Member

Re: Link failover with Ethernet ???

Is this a fiber link?

IS it posible to run UDLD on the interface ?

BP
New Member

Re: Link failover with Ethernet ???

no this is a straight Cat6 copper link between me and my carrier

99
Views
0
Helpful
5
Replies
CreatePlease login to create content