Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Link from 2 different ISPs

Kindly,have a look to the attached diagram!

i have 2 wireless connection from 2 different ISPs(ISPA;ISPB)ISP A Terminate link at R1;ISPB Treminate link at R2;i want to achieve the following setup:if the first Link(ISPA)fail the second link (ISPB) TAKE OVER.R1 ITS PRIMARY;R2 ITS SECONDERY;also i want to take into my consideration the LOAD Balence and the redandancy.

How can i achieve like this setup?

10xs for ur reply

27 REPLIES

Re: Link from 2 different ISPs

Hi Sayed

With the kinda topology you have in placei would suggest to lookout for redundancy in place instead of load balancing.

If you are not having a pool of ips on your own you can have HSRP in combination with NAT which can serve the purpose of both redundancy and access to internet.

Do refer the below link for configuring up the same..

http://www.cisco.com/en/US/partner/products/ps6350/products_configuration_guide_chapter09186a008044edaa.html

regds

New Member

Re: Link from 2 different ISPs

Hi regds !

10xs for ur reply;

1)the above link DIDN't open need a CCO account;polz provuide another?

2)plz provise a simple config for this Situation

10xs

Re: Link from 2 different ISPs

New Member

Re: Link from 2 different ISPs

HI!

with nat configuration we can achieve my goal:

if the primary Link(ISPA)Goes down the 2nd Link(ISPB) WILL Take over?shoul this work?

10xs

Re: Link from 2 different ISPs

Ali,

you will get all most all the answers from this link:

http://www.cisco.com/warp/public/619/3.html

take a look at this link for configuration:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t4/ftnthsrp.htm

regards

Devang

Re: Link from 2 different ISPs

New Member

Re: Link from 2 different ISPs

HI Devang,long Time!!!

10xs for ur reply;i will try this...

ALI

New Member

Re: Link from 2 different ISPs

HI EXPERT's!

am confused here about which solution do i use

1)Statful NAT

OR

2)Static NAT in an HSRP Envirment.

Plz Help

10xs

Re: Link from 2 different ISPs

ali,

you have two things in redundancy... one is statful and other is statless...

stateful failover is to continue active flows without interruption if the master fails over to the backup.

it means here you can have your session flow is continue even though your active will goes down...

that will be more clear by the following links:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hiap_c/ch20/haiphsrp.htm

http://www.cisco.com/univercd/cc/td/doc/product/webscale/css/css_750/redundgd/redndncy.htm

so its all depend your need...

regards

Devang

New Member

Re: Link from 2 different ISPs

HI Devang!

did u check my Diagram?i want to achieve if the 1 Link from ISPA Goes Down;the 2nd link from ISPB SOULD Take care

10xs

Re: Link from 2 different ISPs

then you can go for normal HSRP with the NAT so it will reduce the complexity with your configuration...

static nat with HSRP

Re: Link from 2 different ISPs

this is the thing which you are looking for i guess:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123newft/123t/123t_7/gtsnatay.htm

regards

Devang

New Member

Re: Link from 2 different ISPs

HI!

R1:F0/0:10.10.100.2/24

F0/1:202.10.10.1/30(ISPA Real ip address)

********************************************

R2:F0/0:10.10.100.3/24

F0/1:194.126.10.1/30(ISPB Real ip address)

How could i Config my 2 routers using SNAT With HSRP?

10XS FOR UR GREAT HELP

Re: Link from 2 different ISPs

Active Router Configuration

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 105 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.n

standby 10 track Fa 0/1

!

!

ip nat inside source static/pool -----redundancy HSRP1

ip classless

ip route a.b.c.0 255.255.255.0 fa 0/1

Standby Router Configuration

interface fa0/0

ip address 10.10.100.3 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 100 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.n

standby 10 track fa 0/1

!

ip nat inside source static/pool -----redundancy HSRP1

ip classless

ip route a.b.c.0 255.255.255 fa 0/1

ali here in ip nat command you can use the static map or nat pool whatever you are looking for... for command reference this is the link: http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087c4c.html

regards

Devang

New Member

Re: Link from 2 different ISPs

hi Devang!

10xs 10xs for ur times to Help me.this the 1 time that am working with like this scenario(HSRP With Nat)

BUT IN UR CONFIG AM NOT SEE THE REAL DIFFERENT IPs ON BOTH ROUTERS?

10xs

New Member

Re: Link from 2 different ISPs

any reply Here;guys i have only 1 real ip on each router?

e.g real ip(1) router 1

real ip(2) router 2

2 different ISP

10xs

Re: Link from 2 different ISPs

ali real ip will come in to the picture when you are going to configure the nat...

like this

ip nat inside source static internalIPaddress globalipaddress redundancyHSRP1

so on both the router you will have different global ip address in the above statement...

regards

Devang

New Member

Re: Link from 2 different ISPs

hi

the command like this:

1)ip nat inside source static 10.10.100.1 10.10.100.254 202.10.10.1 redundancyHSRP1?

2)do i need acces-list to permit this traffic?

10xs

New Member

Re: Link from 2 different ISPs

hi Devang!

1)what this does:ip route a.b.c.0 255.255.255 fa 0/1

?)a.b.c.0:which network?the ISP NETWORK?

2)IP nat inside source static HERE THE IP ADDRESS OF THE ISPA?

10XS

Re: Link from 2 different ISPs

ip route statement here is for your own internal network... 10.10.100.0... you are indicating traffic of your network to outside interface...

ip nat inside source static 10.10.100.n IPaddressofISPA (on active router)

ip nat inside source static 10.10.100.m IpaddressofISPB (on standby router)

regards

Devang

Re: Link from 2 different ISPs

ali,

try the above configuration... its seems to be interesting... i might be gofor the configuration scenario in my office lab in this weekend... let me know it works or not so i can do it in my lab...

its nice to work with you, i learned lots of thing during the providing solution of your scenarios... hay i am sorry if some time i had provide you the out of track solution... i am still learning lots of things i am not that much expert but mostly i am dealing with some basic stuff... after 10 days i am planning to take BGP exam... let see...

thank you very much

regards

Devang

New Member

Re: Link from 2 different ISPs

HI!

HERE WHICH IP ADDRESS DO I CONFIGURE IN MY SITUATION?

ip nat inside source static 10.10.100.n ?

ip nat inside source static 10.10.100.m ?

10.10.100.X

10.10.100.Y

THE X=?

THE Y=?

10XS

Re: Link from 2 different ISPs

ali this is the ip address of the source which you want to NAT to the Public ip address...

might be any PC server or what ever... i am trying to find out the multiple inside IP buinding to the out side global ip address...

regards

Devang

Re: Link from 2 different ISPs

ali use this for nat...

on Active router

ip nat inside source list 1 interface fa0/1 (activerouterinterface connected to the ISPA) overload

!

access-list 1 permit 10.10.100.0 0.0.0.255

on standby router

ip nat inside source list 1 interface fa0/1 (activerouterinterface connected to the ISPB) overload

!

access-list 1 permit 10.10.100.0 0.0.0.255

New Member

Re: Link from 2 different ISPs

Devang my freind!

maybe this config not work in situation like my Case,let see the comments for others experts in this forum.

thanks al ot Devang

Re: Link from 2 different ISPs

yup...

i tried to give you the solution let see... i will check it out in my lab...i think i had created some complexity in confugration as well as in explanation also...

sorry for wasting your time...

thanks and regards

Devang

New Member

Re: Link from 2 different ISPs

Devang MY FREIND DONT GOT ME WRONG PLZ!APPRECIATE UR TIME TO HELP ME OUT.

10XS PLZDONT GET ME WRONG.

139
Views
45
Helpful
27
Replies