Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Links from 2 ISPs

HI EXPERTS!

Kindly,have a look to the attached diagram;as well as to the Config provided from Devang!

i have 2 wireless connection from 2 different ISPs(ISPA;ISPB)ISP A Terminate link at R1;ISPB Treminate link at R2;i want to achieve the following setup:if the first Link(ISPA)fail the second link (ISPB) TAKE OVER.R1 ITS PRIMARY;R2 ITS SECONDERY.e.g continuous internet access in case on of link goes down

How can i CONFIGURE like this setup?can i do load Balence?

Config like this:

*****************

active router(R1)

*****************

interface fa0/0

ip address 10.10.100.2 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 105 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.1

standby 10 track Fa 0/1

!

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit 10.10.100.0 0.0.0.255

!

int f0/1

ip address 202.10.10.1 255.255.255.252

ip nat outside

Standby Router(R2)

******************

interface fa0/0

ip address 10.10.100.3 255.255.255.255.0

no ip redirects

ip nat inside

standby 10 priority 100 preempt

standby 10 name HSRP1

standby 10 ip 10.10.100.1

standby 10 track Fa 0/1

!

ip nat inside source list 1 interface fa0/1 overload

access-list 1 permit 10.10.100.0 0.0.0.255

!

int f0/1

ip address 194.126.10.1 255.255.255.252

ip nat outside

THIS CONFIG WORK FOR MY SCENARIO?

10xs for ur reply & for ur examination!

9 REPLIES
Hall of Fame Super Blue

Re: Links from 2 ISPs

Hi Ali

Assuming that the clients are in the same subnet as your fa0/0 interfaces on R1 & R2

yes it looks like this config will work fine. Be aware thought that if the primary link fails all existing connections will be dropped from a user perspective as the source IP addresses will then change to new public IP address of R2's f0/1 interface.

This will not load balance though. Is that what you want or do you just wan redundancy in case the primary link goes down ?

If you want load balancing between both links you could look at Glbp. A link is attached:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_white_paper09186a00801541c8.shtml#wp1027177

HTH

Jon

New Member

Re: Links from 2 ISPs

Hi both 2 routers & Switch on the same VLan;do i need static/Default route to the outside interface(real ip address)

10xs

Silver

Re: Links from 2 ISPs

Generally... In this kind of scenarion. Mean 2 Internet links and Load balancing.. people are prefering REDWARE product for solution.

Regards,

Dharmesh Purohit

Silver

Re: Links from 2 ISPs

Yes, Global load balancing should work in that scenario.

Regards,

Dharmesh Purohit

New Member

Re: Links from 2 ISPs

Hi!

is GLBP Have a track interface?to test the link coming from the ISPs?what could be my config with GLBP?PLZ POST IT..

10xs

Hall of Fame Super Blue

Re: Links from 2 ISPs

Hi Ali

yes you can track interfaces with GLBP. Basically you give each router a weighting and if the tracked interface goes down you can reduce the weighting so that this router is not used to forward traffic.

There is an example of how to do this in the document i sent.

Let me know if i can help any more

Jon

New Member

Re: Links from 2 ISPs

HI Jon

could u plz convert MY previous Config to GLBP.

10XS

New Member

Re: Links from 2 ISPs

Just a question...

What routers and IOS are you using? Not all routers will support GLBP, and especially not the IOS if older.

New Member

Re: Links from 2 ISPs

Hi,

Use Global Load Balancing which works well.

153
Views
10
Helpful
9
Replies
CreatePlease to create content