Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

links with two differnet ISP

Hi everybody. I am working in Isp and We have own ip range (for example 10.100.50.0/16). We have Internet link with one Isp where had written our ip range and other info. Now WE got another link from diffrent Isp and we have two link but we havn't AS own number and the problem is that second Isp cannot write our ip address because we have only on way through which we go. We deside some our client will go through second ISp.

I configuration nat for second ISP and two route-map but after that I wrote ip nat outside command in the interface which look to second ISP the client which I decide to work through second link working but I have some problem with that:

1) some url not open like such http://www.google.com http://www.freebsd.org

2)mrtg stop working normali and some adsl client not working at all. After that I remove ipnat outside config and copy start run client begin working but dialup client not tracert do, the network begin work slowly only after that I had reload router which return to old config everything work good.

This my config :

interface GigabitEthernet0/1.710

description Main Link to ISP2

encapsulation dot1Q 710

ip address 192.168.10.50 255.255.255.248 (ip address and net second ISP)

ip nat outside

no ip virtual-reassembly

no snmp trap link-status

no cdp enable

interface GigabitEthernet0/3.310

description Main Link to ISP1

encapsulation dot1Q 310

ip address 172.50.50.230 255.255.255.252 (Ip address and net to fisrt ISP LINK)

no snmp trap link-status

interface GigabitEthernet0/2.100

description Oustide VLAN

encapsulation dot1Q 100

ip address 10.100.50.1 255.255.255.240 (my own ip address in our own ip range for example)

ip nat inside

ip virtual-reassembly

ip policy route-map ISP2

no snmp trap link-status

ip nat outside source list 150 interface GigabitEthernet0/1.710

access-list 150 permit ip 10.100.60.0 0.0.0.127 any ( dial-up pool that placed in Nas server Cisco AS5300 which need reroute to second ISP)

route-map to ISP2 permit 10

match ip address 150

set ip next-hop 192.168.10.49

route-map azon-nat permit 10

match interface GigabitEthernet0/1.710

ip nat inside source route-map azon-nat interface GigabitEthernet0/1.710 overload

I need forward some client to second link ISP. Maybe I do some mistake.

1) how can I do it in right way ?

2) this config has mistake ? if it has which one?

If anyone can help me it need urgenly

thanks before

4 REPLIES

Re: links with two differnet ISP

Hi Friend,

Have you obtained the Ip range from an organization like ARIN, APNIC or is it provided by the upstream ISP.

In the Latter case, you will not be able to route as one ISP would not accept the ISP block of the 2nd provider

HTH, rate if it does

Narayan

New Member

Re: links with two differnet ISP

I have my own ip range and I have two ISP ip address for connection to each ISP only for connection.

If any one knows ho do it please help it need urgently

New Member

Re: links with two differnet ISP

interface GigabitEthernet0/1.710

description Main Link to ISP2

encapsulation dot1Q 710

ip address 192.168.10.50 255.255.255.248 (ip address and net second ISP)

ip nat outside

no ip virtual-reassembly

no snmp trap link-status

no cdp enable

interface GigabitEthernet0/3.310

description Main Link to ISP1

encapsulation dot1Q 310

ip address 172.50.50.230 255.255.255.252 (Ip address and net to fisrt ISP LINK)

no snmp trap link-status

interface GigabitEthernet0/2.100

description Oustide VLAN

encapsulation dot1Q 100

ip address 10.100.50.1 255.255.255.240 (my own ip address in our own ip range for example)

ip nat inside

ip virtual-reassembly

ip policy route-map ISP2

no snmp trap link-status

access-list 150 permit ip 10.100.60.0 0.0.0.127 any ( dial-up pool that placed in Nas server Cisco AS5300 which need reroute to second ISP)

route-map to ISP2 permit 10

match ip address 150

set ip next-hop 192.168.10.49

route-map azon-nat permit 10

match interface GigabitEthernet0/1.710

ip nat inside source route-map azon-nat interface GigabitEthernet0/1.710 overload

now it's working but have some trouble here

1) not all site is open in .com space example www.google.com and some other.

second sometime router was frozen until I wri te no ip nat outside but after that all link work slowly lan and other client works slowly until I reload the router with old config.

What's wrong in this config

thanks before

New Member

Re: links with two differnet ISP

I have found and resolved problem myself.

Dns was not correct and I was change it to correct dns and I add second rule to route map for local paket.

THanks all for help to me :)))))

171
Views
0
Helpful
4
Replies
CreatePlease to create content