Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LLQ Help Required

I want to configure LLQ so that one user get fix amount of bandwidth but still not able to configure it see the belwo mention configuration for LLQ

I want to configure LLQ on my Router which has 2 FE interface.

I want only specific application 10.1.4.3 always gets Bandwidth 74990 in either case. and one user get 8 kbps.

I configure the router with below mention command but still not able to get the desired result.

both users are able to get bandwidth in MB and no LLQ is working.

version 12.4

!

!

class-map match-all testclass2

match access-group 160

class-map match-all testclass

match access-group 150

!

!

policy-map testpolicy

class testclass

priority 8

class testclass2

priority 74990

!

!

interface FastEthernet0/0

bandwidth 8000

ip address 10.1.3.1 255.255.255.0

ip nat outside

ip virtual-reassembly

load-interval 30

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.1.4.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.3.2

!

ip nat inside source list 100 interface FastEthernet0/0 overload

!

access-list 150 permit ip host 10.1.4.3 any

access-list 160 permit ip host 10.1.4.5 any

Router-C#show policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: testpolicy

Class-map: testclass (match-all)

91678 packets, 5680284 bytes

30 second offered rate 698000 bps, drop rate 0 bps

Match: access-group 150

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 8 (kbps) Burst 200 (Bytes)

(pkts matched/bytes matched) 9/612

(total drops/bytes drops) 0/0

Class-map: testclass2 (match-all)

144133 packets, 8696430 bytes

30 second offered rate 898000 bps, drop rate 0 bps

Match: access-group 160

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 5990 (kbps) Burst 149750 (Bytes)

(pkts matched/bytes matched) 22/1251

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

27 packets, 2235 bytes

30 second offered rate 0 bps, drop rate 0 bps

13 REPLIES

Re: LLQ Help Required

HI Wasim, [Pls Rate if HELPS]

class class-default and fair-queue are missing.

class-map match-all testclass2

match access-group 160

class-map match-all testclass

match access-group 150

!

!

policy-map testpolicy

class testclass

priority 8

class testclass2

priority 74990

class class-default

fair-queue

!

interface FastEthernet0/0

interface FastEthernet0/1

? Service-policy output testpolicy

The above was not applied in any of the Interface ?

Hope I am Informative.

Pls Rate if HELPS

Best Regards,

Guru Prasad R

Community Member

Re: LLQ Help Required

Please see the updated configuation i have modified it but still not able to restrict the user,

Building configuration...

*May 29 15:25:44.768: %SYS-5-CONFIG_I: Configured from console by console

Current configuration : 1247 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router-C

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool users

network 10.1.4.0 255.255.255.0

default-router 10.1.4.1

!

!

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

class-map match-all testclass2

match access-group 160

class-map match-all testclass

match access-group 150

!

!

policy-map testpolicy

class testclass

priority 8

class testclass2

priority 5990

class class-default

fair-queue

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.3.1 255.255.255.0

duplex auto

speed auto

service-policy output testpolicy

!

interface FastEthernet0/1

ip address 10.1.4.1 255.255.255.0

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.3.2

!

!

ip http server

no ip http secure-server

ip nat inside source list 100 interface FastEthernet0/0 overload

!

access-list 150 permit ip host 10.1.4.3 any

access-list 160 permit ip host 10.1.4.5 any

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

!

end

Router-C#

Router-C#sh run

Building configuration...

Current configuration : 1247 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router-C

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

ip dhcp pool users

network 10.1.4.0 255.255.255.0

default-router 10.1.4.1

!

!

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

class-map match-all testclass2

match access-group 160

class-map match-all testclass

match access-group 150

!

!

policy-map testpolicy

class testclass

priority 8

class testclass2

priority 5990

class class-default

fair-queue

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.3.1 255.255.255.0

duplex auto

speed auto

service-policy output testpolicy

!

interface FastEthernet0/1

ip address 10.1.4.1 255.255.255.0

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.3.2

!

!

ip http server

no ip http secure-server

ip nat inside source list 100 interface FastEthernet0/0 overload

!

access-list 150 permit ip host 10.1.4.3 any

access-list 160 permit ip host 10.1.4.5 any

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

!

end

I m trying to restrict the user to bandwidth 74990 but still failling user is able to download in MB

Community Member

Re: LLQ Help Required

can anyone help me out

Super Bronze

Re: LLQ Help Required

Recently I stumbled across Cisco LLQ documentation that the implicit policer only rate limits when there's interface congestion. The simple solution would be to add a police statement within the LLQ class so the class will never exceed its allocated bandwidth regardless of whether other traffic causes interface congestion. Something like:

policy-map testpolicy

class testclass

priority 8

police 8000

class testclass2

priority 74990

police 74990000

Bronze

Re: LLQ Help Required

Hi Wasiim,

As said by Joseph, please remember that QoS queuing policies(not even LLQ) never kicks in if you don't have congestion. If your bandwidth utilization is low, then never expect any participation of QoS.

Regards...

-Ashok.

With best regards... Ashok ----------- Pls kindly rate if helpful or answered your question.

Re: LLQ Help Required

Hi,

Totally agree with Joseph and Ashok. The action of policing with LLQ depends upon if there is congestion > Policing will only be done if congestion occurs - with no congestion if the bandwidth required is more than the priority it won't be policed - but the extra packets will not be moved from the tail to the head of the queue (prioritized) like the conforming bandwidth, meaning that only the conforming bandwidth is prioritized and moved from the tail to the head of queue regardless there is congestion or not - implying that the prioritization is what is always policed and not the packet flow.

BR,

Mohammed Mahmoud.

Community Member

Re: LLQ Help Required

thanks for the useful information. few more questions, I will have 6 MB bandwidth on my internet rotuer, I want that only specific traffic of video conferenceing server always get 386 KBps bandwidth.

will that above mention configuration will in live enviroment.

I have vsat link, which is terminate on Gigabit ethernet interface, is there any need to change the bandwidth on physical interface which is 1000 Mbps to actually bandwidth of 6 MB or leave it as it is

Re: LLQ Help Required

Hi wasim,

Changing the bandwidth command will not change the actual bandwidth that ISP has provided.It's hard to make the gigabit interface to get congestion. If you want to restrict the bandwidth all the time then policing is good way to go. Joseph provided a good one.

HTH

Thot

Super Bronze

Re: LLQ Help Required

If you want to provide a minimum guarantee of bandwidth for some traffic, that can be accomplished by the bandwidth statement within a CBWFQ's class. If you want to limit the bandwidth within the CBWFQ class, then you want to shape or police it.

Whether or not to manage your gig interface that you know will be reduced to 6 Mbps depends on whether you expect traffic above 6 Mbps to create quality issues and whether you can manage such a situation better. (Usually I find the answer is yes to both questions. In your case, you might benefit from something as simple as a 6 Mbps shaper on the gig interface leading to the vsat link.)

Community Member

Re: LLQ Help Required

Thanks for the reply, you mean to say there is no need to change anything on gig interface.

I have to make the policy and reserve the bandwidth and apply that policy on the gig interface. nothing to change not even bandwidth on the interface.

class-map match-all testclass2

match access-group 160

!

class testclass2

priority 386

class class-default

fair-queue

interface gig0/0

ip address 10.1.3.1 255.255.255.0

duplex auto

speed auto

service-policy output testpolicy

access-list 160 permit ip host 10.1.4.5 any

will that confiugration give 368 BW to this source in any case, and rest of the traffic treated as normal.

I will just apply this policy on interface nothing else is required on interface.

Super Bronze

Re: LLQ Help Required

No, if you're going to apply any policy at all, and you know the bandwidth is constricted downstream, then you should shape for that restriction.

e.g.

(Something like)

class-map match-all testclass2

match access-group 160

!

policy-map testpolicy

class testclass2

priority 386

class class-default

fair-queue

policy-map vsat-shaper

class class-default

shape 6000000

service-policy testpolicy

interface gig0/0

ip address 10.1.3.1 255.255.255.0

duplex auto

speed auto

service-policy output vsat-shaper

access-list 160 permit ip host 10.1.4.5 any

The above will guarantee your host at 10.1.4.5 with at least 368 Kbps of bandwidth, with priority queueing. All other traffic will FQ all other available bandwidth, up to 6 Mbps.

Re: LLQ Help Required

Hi,

Correct me if I'm missing something over here:

1. I dont see any Service-Policy command on either of the interface

2. If you are assigning more than 1 LLQ in a given Policy-Map, I guess the Router will combine the LLQ and make it one.

If I were you, I would have given the 8kbps traffic LLQ and the 74990 kbps traffic CBWFQ so that former one would get guaranteed bandwith.

HTH,

Please rate all helpful posts

Kind Regards,

Wilson Samuel

Community Member

Re: LLQ Help Required

If u see above I have applied the service policy on interface gig 0/0.

170
Views
6
Helpful
13
Replies
CreatePlease to create content