Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LLQ Problems on PA-MC-STM-1 in 7206 VXR

I have configured CBWFQ on an E1 Interface of the PA-MC-STM-1 card. I configured 3 classes: Voice, Video, class-default. Class Voice is the priority queue.

When I congest the link by oversubscribing the default class the latency in the priority queue increases up to 1000ms. As expected, drops occur in class-default only. Class Voice is shown as "strict priority queue".

Is there an option to reduce the buffer size allocated to the priority queue?

Any suggestions?

Thanks,

Olaf

7 REPLIES

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

Hi,

my guess is the hardware queue is too long. Can you try to set tx-ring to smaller values?

To my knowledge there is no parameter "priority queue length" as in fact all packets in the priority queue should be serviced immediately into hardware queue.

Regards, Martin

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

How much bandwidth did you specify in 'priority ' command? Size of priority queue is directly influenced by allocated bandwidth. Maximum delay packet spends in the queue can be determined as /. Generally you shouldn't assign more than 30% to the LLQ.

New Member

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

I have reserved 500k for the priority queue. When I apply the same policy-map to an E1 card on an c2600 LLQ works perfect.

I wonder whether there is an general issue with MC-STM1 card and LLQ? Any recommedation for an IOS for MC-STM-1 and LLQ? I am using an NPE-G1.

policy-map TEST

class VOIP_Test

priority 500

class VIDEO_Test

bandwidth 200

class class-default

bandwidth 800

random-detect

New Member

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

I have reserved 500k for the priority queue. When I apply the same policy-map to an E1 card on an c2600 LLQ works perfect.

I wonder whether there is an general issue with MC-STM1 card and LLQ? Any recommedation for an IOS for MC-STM-1 and LLQ? I am using an NPE-G1.

policy-map TEST

class VOIP_Test

priority 500

class VIDEO_Test

bandwidth 200

class class-default

bandwidth 800

random-detect

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

Hi, Ilya,

I doubt, that your statement can be justified. Priority queue packets should not be delayed at all in the SOFTWARE queue. The only delay could arise from the hardware queue of the device. Also auto qos voip configures a 70% priority queue for voip and this works well in many cases.

So again, my opinion on the case described here is: either software bug or hardware queue can lead to the described behaviour.

I would first try to lower the size of the hardware queue.

Another (not so likely) idea: what device is connected to the 7206? Are there any indications of a large input queue or even input drops? If so, lower the input queue (1000 packets per default).

Regards, Martin

New Member

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

Reducing the tx-ring-limit did not make any difference. Finally i could fix the problem by upgrading IOS to GD-Release 12.3.19.

Thanks,

Olaf

Re: LLQ Problems on PA-MC-STM-1 in 7206 VXR

Martin,

this is true as long as priority packets are not delayed in priority queue itself - there's no way for one priority packet to be more important than another priority packet. So size of LLQ (reserved bw) does affect delay.

I tested NPE-G1 last year with Agilent N2X and with QoS applied (LLQ 30%) I could push about 230Mbps via gigabit ports through the box without loss and delays. Haven't tested with STM-1 though.

203
Views
0
Helpful
7
Replies