Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Load Balance on 3825

Hi All,

i have a c3825 ( that now is standard with 2 GigabitEthernet interface but i can install any module ) and i need to connect both my AS-links versus internet on it. So how can i do load balance between any interface to get best result from my double internet connection??

Thank for any answer

  • WAN Routing and Switching
Everyone's tags (3)
5 REPLIES
Purple

Load Balance on 3825

Hi,

Cisco routers don't do load-balancing, they do load-sharing and the default is per src-dst IP pair.

You can verify which path traffic will take with the show ip cef exact-route command specifying the src and dst IPs.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Load Balance on 3825

Alain ty for your answer .. but if u can be more specific on configuration .. couse u are sure much more skilled then me in Cisco world.

Purple

Load Balance on 3825

Hi,

for traffic to be load-shared you need equal cost(metric) routes installed for the same prefix(in your case the default route).

So just configure 2 static default routes pointing to the next-hop or dialer interface if you are doing PPPoE.

example:

ip route 0.0.0.0 0.0.0.0 dialer1

ip route 0.0.0.0 0.0.0.0 dialer 2

For NAT: here's an example with fe0/0 being LAN interface

int f0/0

ip add 192.168.1.254 255.255.255.0

ip nat inside

no shut

int dialer 1

ip nat outside

int dialer2

ip nat outside

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

route-map DIALER1

match ip address 101

match interface dialer1

route-map DIALER2

match ip address 101

match interface dialer2

ip nat inside source route-map DIALER1 interface dialer1

ip nat inside source route-map DIALER2 interface dialer2

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Load Balance on 3825

thnks so much Alain

Super Bronze

Re: Load Balance on 3825

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

If your IOS (with correct feature set) supports it, OER/PfR can load balance your egress.

194
Views
9
Helpful
5
Replies
This widget could not be displayed.