Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Load balancing 1841 with 2 adsl wic's in the same lan.

I have Cisco 1841 router with 2 adsl wic's ,2 Internet connections from the same ISP and i 'd like to do load balancing per-destination in the same lan. I have IOS 12.4(1a).

I 'm trying to set up fastethernet0/0 , 2 atm's and 2 dialers.

I want to setup with nat inside in fastethernet0/0 and nat outiside on both dialers,with pap authentication pvc 8/35 , ip address negotiated on dialers,

encapsulation aal5mux ppp dialer.

Can you help me with the config file?

5 REPLIES
Bronze

Re: Load balancing 1841 with 2 adsl wic's in the same lan.

Hello,

here is a sample configuration for your setup.

ip cef

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer1

description ISP1_Connection_1

ip address negotiated

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer2

description ISP1_Connection_2

ip address negotiated

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication pap callin

ppp pap sent-username USERNAME password PASSWORD

!

ip nat inside source route-map ISP1_Connection_1 interface Dialer1 overload

ip nat inside source route-map ISP1_Connection_2 interface Dialer2 overload

!

access-list 1 permit 192.168.1.0

!

route-map ISP1_Connection_1 permit 10

match ip address 1

match interface Dialer1

!

route-map ISP1_Connection_2 permit 10

match ip address 1

match interface Dialer2

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

!

dialer-list 1 protocol ip permit

Regards,

Nethelper

Community Member

Re: Load balancing 1841 with 2 adsl wic's in the same lan.

Thank you very much nethelper.

I 'd like to ask you about the physical atm interfaces atm0/0/0 and atm0/1/0 .

I do not configure the atm0/1/0 interface ?

I have 48 pc's in the lan.

All the pc's they 'll share both connections from atm0/0/0 ?

For example:

PC01 going internet from connection ISP1

pc02 going internet from connection ISP2

pc03 going internet from connection with less load.

Best Regards

alvergam39

Bronze

Re: Load balancing 1841 with 2 adsl wic's in the same lan.

Hello,

the sample configuration given is based on two PVCs on the same physical interface. In your case, with physical interfaces ATM0/0/0 and ATM0/1/0, the configuration would look like this:

interface ATM0/0/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

!

interface ATM0/0/0.1 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0/1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/1/0.2 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 2

The load balancing is per-destination (which is the default). That means that e.g. PC01 going to www.cisco.com will go through ISP1, PC02 going to www.microsoft.com will go through ISP2, and so forth.

Regards,

Nethelper

Community Member

Re: Load balancing 1841 with 2 adsl wic's in the same lan.

Thank You again nethelper .

You help me a lot,and your configuration file was right.

Best Regards

alvergam39.

Community Member

Re: Load balancing 1841 with 2 adsl wic's in the same lan.

Hello again nethelper

Thank you very much for your config.

I have a little problem with DHCP server in my Lan.

I have a DHCP server in my network at 192.168.0.1 , and when i plugging the router on the lan i havent internet .

It must work as relay agent ?

Can you help me with this .

Best Regards

alvergam39

552
Views
15
Helpful
5
Replies
CreatePlease to create content