Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Load Balancing between a Serial & Ethernet Link

I currently have a Location that has a DS3 terminated into a 7206VXR Router.  We are currently experiencing over 90% Utilization on the DS3 Interface during Peak Periods.  As our Fiber buildout to the Site is over 3-6 Months away we are trying to put a Band-Aid on the Bandwidth till then.  Our only Cost Effectivie Solution is to feed the Site with another 20 megs via another Ethernet drop-off to the 7206VXR.

What is the Best Case Practice or Solution to either Load Balance or Combine the Bandwidth so I don't have to break up the Network.  If I did have to break up the Network I would like to have Redundency between both the Serial Interface and the Ethernet Interface in case one of them goes down.  Here below is the Current Interfaces for each Bandwidth Leg.  Currently we are just routing out the Serial1/0 (DS3 Interface) for all Customers.

interface Serial1/0 (Full DS3 Interface)
description CO-DS3
ip address 4.2.2.2 255.255.255.252
ip nat outside
dsu bandwidth 44210
framing m13
cablelength 10
serial restart-delay 0

interface GigabitEthernet0/2 (20 Meg Bandwidth via 100 meg Copper physical Link)
ip address 5.2.2.2 255.255.255.252
duplex auto
speed auto
media-type rj45
negotiation auto

The Network consists of about 3 VLAN's (Management, Private IP Pool, Public IP Pool) that we use for our DSLAM Boxes to provide Customer Internet and Management of the DSLAM Devices.

The Solution that I have used in the past is to add (2) IP Routes as you see below:

ip route 0.0.0.0 0.0.0.0 4.2.2.1

ip route 0.0.0.0 0.0.0.0 5.2.2.1

My concern for this way is that I do have Equal Cost Paths for this Solution.  Again one is a 45 meg link (4.2.2.1) and the other one is 20 meg link (5.2.2.1) ..

What is the Best way to implement my 20 Meg link into the Equation so I can utilize the Bandwidth without Overloading it before my 45 meg link.

Any Help or Suggestions ?

-Thanks

Everyone's tags (4)
2 REPLIES
Hall of Fame Super Silver

Re: Load Balancing between a Serial & Ethernet Link

Hello Joshua,

you should use a dynamic routing protocol for this.

if all devices are Cisco routers you could use EIGRP with variance command to provide load balancing over unequal cost paths

note: you need to tune bandwidth on g0/2 to reflect true speed of the link

int gi0/2

bandwidth 20000

router eigrp 100

network 4.2.2.0 0.0.0.3

network 5.2.2.0 0.0.0.3

! other network commands to advertise local IP subnets

network 10.0.0.0

! variance command

variance 2

!

EIGRP AS 100 must be used on both devices

if you are using OSPF you could find a workaround by implementing FR on the DS3 link, creating two point-to-point subinterfaces in order to create three equal cost paths

(this can be feasible or not depending on the type of WAN service you have bought)

one side needs to be configured as fr dce with

int ser1/0

enc frame-rel

! only on one side

frame-rel intf-type dce

no ip address

int ser1/0.20 point-to-point

frame-relay interface-dlci 20

bandw 20000

ip address 4.4.2.2 255.255.255.252

nt ser1/0.30 point-to-point

frame-relay interface-dlci 30

bandw 20000

ip address 4.4.2.6 255.255.255.252

router ospf 10

network 4.4.2.0 0.0.0.3 area 0

network 4.4.2.4 0.0.0.3 area 0

network 5.2.2.0 0.0.0.3 area 0

! internal networks

network 10.0.0.0 0.255.255.255 area 0

note also that you may need to add NAT outside to g0/2 too

Hope to help

Giuseppe

Hall of Fame Super Silver

Re: Load Balancing between a Serial & Ethernet Link

Joshua

I faced a similar situation in a customer network where they had 2 outbound links of different bandwidths. The solution that we implemented was to have the default route pointed out the link with higher bandwidth and to use Policy Based Routing to select certain traffic and send it out the other link. They chose web traffic and Email to go out the smaller link, but you could experiment with selecting various types of traffic until you get a mix that provides the amount of utilization that you want.

HTH

Rick

2282
Views
0
Helpful
2
Replies
CreatePlease login to create content