Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Load Balancing Question

I am trying to load balance 2 internet circuits. One circuit comes in via a T-1 DSU port and the other comes in via a ethernet port. I can get both connections live on the 3640 router I am using. However, all the traffic wants to go out on the T-1 side and not the Ethernet side. Any help would be appreciated as I am still fairly new to config'ing Cisco routers. Here is the config as it stands right now:

service timestamps debug datetime localtime

service timestamps log datetime localtime

no service password-encryption

!

hostname RTR_INT1

!

logging buffered 32768 informational

no logging console

enable secret XXXXX

enable password XXXXXX

!

memory-size iomem 15

ip subnet-zero

no ip source-route

ip cef

!

!

no ip domain-lookup

!

no ip bootp server

!

!

!

interface Ethernet0/0

description To Inside LAN

ip address 65.x.x.x.x.255.240

half-duplex

no cdp enable

!

interface Serial0/0

no ip address

shutdown

no cdp enable

!

interface Ethernet0/1

description To ISP1

ip address 63.x.x.x.x.255.248

half-duplex

no cdp enable

!

interface Ethernet0/1.1

no cdp enable

!

interface Serial0/1

description To ISP2

bandwidth 1536

no ip address

ip accounting output-packets

encapsulation frame-relay

no fair-queue

frame-relay lmi-type ansi

hold-queue 75 out

!

interface Serial0/1.1 point-to-point

bandwidth 1536

ip unnumbered Ethernet0/0

ip access-group 100 in

ip accounting output-packets

no cdp enable

frame-relay interface-dlci 500 IETF

!

interface Serial1/0

no ip address

shutdown

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/1.1

ip route 0.0.0.0 0.0.0.0 63.33.183.1

ip http server

ip pim bidir-enable

!

no cdp run

line con 0

password XXXXXX

login

transport preferred none

line aux 0

password XXXXXX

login

modem InOut

transport input all

flowcontrol hardware

line vty 0 4

password XXXXXX

login

transport preferred none

!

end

3 REPLIES
Silver

Re: Load Balancing Question

ip route 0.0.0.0 0.0.0.0 Serial0/1.1

ip route 0.0.0.0 0.0.0.0 Ethernet 0/1

And check if it works. This is because a static route to the interface gets preference over Static route to IP. But pointing to ethernet interface is not advised as it can create lots of ARP entries. I Suggest you get an IP for the Serial Link as well

HTH

Re: Load Balancing Question

Hi,

I've an additional comment to say if you may allow me.

I think that it is recommended to have the static routes to the physical interfaces (not to the next hop) when applying loadbalancing.

Because in the case of static routes to physical interface when the interface goes down the route is removed from the routing table, but in the case of static route to a next hop, the route won't be removed from the routing table when the interface goes down --> causing packets to be dropped.

regards,

Mohammed

New Member

Re: Load Balancing Question

I'm afraid the previous comment is incorrect. When an interface goes down, the routing table gets reported and all the routes learned over that interface get flushed.

You could specify both the interface and the next-hop too.

Cheers

87
Views
0
Helpful
3
Replies
CreatePlease to create content