Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Load balancing question

Hello,

I have 2 T-1's coming into a single 1841 router. On the 1841 I have NAT configured for the internal traffic destined outbound. The router is also running CEF.

My goal is to load share across the two T-1's. Will the following configuration work as desired?

int s0/0

description ISP1

ip addr 10.0.0.2 255.255.255.252

!

int s0/1

description ISP2

ip addr 172.16.1.2 255.255.255.252

!

int f0/0

description lan

ip addr 192.168.1.1 255.255.255.0

!

!

ip nat inside source route-map ISP1 pool ISPONE overload

ip nat inside source route-map ISP2 pool ISPTWO overload

ip nat pool ISPONE 172.16.1.3 172.16.1.3 prefix-length 28

ip nat pool ISPTWO 10.0.0.3 10.0.0.3 prefix-length 28

!

route-map ISP1 permit 10

match ip address 1

match interface Serial0/0

!

route-map ISP2 permit 10

match ip address 1

match interface Serial0/1

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

ip route 0.0.0.0 0.0.0.0 10.0.0.1

ip route 0.0.0.0 0.0.0.0 172.16.1.1

Thanks

Brian

5 REPLIES
Hall of Fame Super Bronze

Re: Load balancing question

Instead of

match interface Serial0/0

use

set interface Serial0/0

However, I prefer going with

set ip next-hop [ip at remote router's serial]

New Member

Re: Load balancing question

Thanks for the response. Since I am trying to load balance between the two T-1's I don't think using the SET statement will work will it? If I use the SET statement it will direct traffic out of that specific interface rather than load balancing between the two.

Hall of Fame Super Bronze

Re: Load balancing question

New Member

Re: Load balancing question

Thanks for the help but I took a chance and put that config into production and it worked perfectly.

Hall of Fame Super Bronze

Re: Load balancing question

Very nice.

104
Views
0
Helpful
5
Replies