Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Load Balancing using 2 DSL Connexions on a Cisco 1811 ??

Hi guys,

i have a cisco 1811 router (spoke) with 2 DSL connecions from my provider he is using DMVPN to connect to a 2811 (Hub).

My question is how could i share (load balacing) my traffic using both DSL connections ?

5 REPLIES
Hall of Fame Super Silver

Re: Load Balancing using 2 DSL Connexions on a Cisco 1811 ??

Hello Jawad,

or you use multilink PPP over ATM to make use of both DSL (this requires cooperation with DSL provider).

or you need to use two mGRE tunnels on both ends again if this is provided by the service provider it requires its intervention.

But to do this also the hub router needs two WAN links to be able to support two mGRE tunnels (this is my idea I may be wrong on this)

Hope to help

Giuseppe

Community Member

Re: Load Balancing using 2 DSL Connexions on a Cisco 1811 ??

both DSL are PPPoE and i dont think the provider is wiiling to help me with anything..

the way it s working now is fallback, that means if the DSL1 is down automatically DMVPN brings another tunnel over the DSL2.

Also the Hub router is configured with 2 IP on his WAN port.

thanks for help

Jawad

Hall of Fame Super Silver

Re: Load Balancing using 2 DSL Connexions on a Cisco 1811 ??

Hello Jawad,

>> Also the Hub router is configured with 2 IP on his WAN port.

so the second option is possible:

you need to have two mGRE on the remote with equal parameters and you will have load balancing

and two mGRE on the Hub too

Hope to help

Giuseppe

Community Member

Re: Load Balancing using 2 DSL Connexions on a Cisco 1811 ??

Hi

i already have 2 tunnels with equals like this:

interface Tunnel1

bandwidth 1000

ip address 11.0.0.2 255.255.255.0

ip mtu 1400

ip nhrp authentication cisco

ip nhrp map 11.0.0.1 x.x.104.7

ip nhrp map multicast x.x.104.7

ip nhrp network-id 111

ip nhrp holdtime 450

ip nhrp nhs 11.0.0.1

ip tcp adjust-mss 1360

delay 1000

tunnel source Dialer1

tunnel destination x.x.104.7

tunnel key 111

tunnel protection ipsec profile profile

!

interface Tunnel2

bandwidth 1000

ip address 12.0.0.2 255.255.255.0

ip mtu 1400

ip nhrp authentication cisco

ip nhrp map multicast x.x.104.8

ip nhrp map 12.0.0.1 x.x.104.8

ip nhrp network-id 112

ip nhrp holdtime 450

ip nhrp nhs 12.0.0.1

ip tcp adjust-mss 1360

delay 1000

tunnel source Dialer0

tunnel destination x.x.104.8

tunnel key 112

tunnel protection ipsec profile profile

is that what you mean by two mGRE or something else ? or should i add some specific command to the 2 tunnels ?

Thanks

Hall of Fame Super Silver

Re: Load Balancing using 2 DSL Connexions on a Cisco 1811 ??

Hello Jawad,

this is near to what I was thinking you should be able to use both if you run a routing protocol over the two mGRE tunnels using the same parameters

What routing protocol are using over the two mGREs ?

EIGRP, OSPF ?

Hope to help

Giuseppe

437
Views
0
Helpful
5
Replies
CreatePlease to create content