Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Load balancing wifi Links

Hi Guys,

I hope one of yuo can help me with a small network design. I intend to put 2 wireless p2p links in a company that has 2 premises. These buildings are very close(200M apart). I want to load balance over the wifi links i.e. 54mbps one way and 54mbps the other way. I beleive that i can do this using static routing. Perhaps with a secong static route on each router with a higher admin distance to provide failover.(please correct me if you have any better ideas.

I am trying to spec routers for this job. I beleive that i will need 2 routers. Each router must should have 3 ethernet ports. on each router i will need 2 wan ports for the wireless links and one LAN port for connectivity to the LAN on each side.

I'm now not sure what routers to get because the 1841 only has 2 FE ports and the 2821 only has 2 GE ports. NM's are not available for the 1841 and NM' for the 2821 only seem to be for swicthing.

I am open to all ideas. If i am missing something that would make this design any easier, i would be greateful.

regards

Stephen

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Load balancing wifi Links

Yes, you can use static routing. Having two static routes will load balance the traffic across the two links. But, because the wifi radios will be using ethernet interfaces, you will not be able to achieve fail over. If you use higher admin distance, you will no longer have load balance, and you will still not have fail-over. The reason for this is because the static route with the higher admin distance will not be installed in the routing table. And it will never be installed, because when the primary links goes down the ethernet interface will still be up, hence the primary route will not be pruged. If you really want to use static route and have failver, then consider static routes with object tracking. This is mre cumbersome to configure though. Check the following link

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

My advice though to achieve load balance and fail-over will be to run a routing protocol like eigrp within the two routers. The configuration for these routing protocols are easy enough.

You are right with respect to your need for the 3 ethernet interfaces. You are also right that the extra interfaces for the 1800 and 2800 are switching modules. To use these series of routers then, you will need to create SVI interfaces, and route between the SVI interfaces. If you do not want to do this, the 1760 router can take 2 WIC-1-Enet interfaces, making the total number ethernet interfaces to be three.

IF you have issues configuring the SVIs, please let us know.

8 REPLIES
Purple

Re: Load balancing wifi Links

Hi Stephen,

While you can get the HWIC-1GE-SFP for the 2821 (to give you an extra GE), you need to consider how much traffic you intend to pass over it. It's rated for 87Mbps so if it is less than that, you should be fine and the 2821 is the box for you... Note that the ethernet switching modules for the 2821 will let you do layer 3 termination.

To get load-balancing over 2 links, simply configure two static default routes (with the same AD) and enable CEF which will give you per-destination load-sharing.

Hope that helps - pls rate the post if it does.

Regards,

Paresh

Silver

Re: Load balancing wifi Links

Yes, you can use static routing. Having two static routes will load balance the traffic across the two links. But, because the wifi radios will be using ethernet interfaces, you will not be able to achieve fail over. If you use higher admin distance, you will no longer have load balance, and you will still not have fail-over. The reason for this is because the static route with the higher admin distance will not be installed in the routing table. And it will never be installed, because when the primary links goes down the ethernet interface will still be up, hence the primary route will not be pruged. If you really want to use static route and have failver, then consider static routes with object tracking. This is mre cumbersome to configure though. Check the following link

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

My advice though to achieve load balance and fail-over will be to run a routing protocol like eigrp within the two routers. The configuration for these routing protocols are easy enough.

You are right with respect to your need for the 3 ethernet interfaces. You are also right that the extra interfaces for the 1800 and 2800 are switching modules. To use these series of routers then, you will need to create SVI interfaces, and route between the SVI interfaces. If you do not want to do this, the 1760 router can take 2 WIC-1-Enet interfaces, making the total number ethernet interfaces to be three.

IF you have issues configuring the SVIs, please let us know.

Re: Load balancing wifi Links

Hi guys,

thanks for the responses... Just a few notes.

I am not stuck to static routing i would be more than happy to implement EIGRP.

Also, having looked into pricing etc... i am very happy to install a 1760 with thw WIC-1ENET cards.

They are resonably price.

(Leaves a thought tho, why do Cisco not provde sinlge port Fa cards for 18,28,38, series routers)

It looks like i will go with The 1870 and EIGRP.

Thanks Again

Stephen

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
Silver

Re: Load balancing wifi Links

I am not sure why, cisco does not provide the fast ethernet cards for the 1800 and 2800 series. But they have for the 3800. Check the following link for the list of fast ethernet interfaces for the 3800.

http://www.cisco.com/en/US/products/ps5855/products_relevant_interfaces_and_modules.html

The 1800 series routers though are much more powerful and have more memory than the 1760.

Re: Load balancing wifi Links

PS :)

What is an SVI and how does it work

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
Purple

Re: Load balancing wifi Links

Hi Stephen,

A switch virtual interface (SVI) represents a VLAN of switch ports as one interface to the routing or bridging function in the system. Only one SVI can be associated with a VLAN, but you need to configure an SVI for a VLAN only when you wish to route between VLANs.

Paresh

Purple

Re: Load balancing wifi Links

Here's an example:

Router#vlan database

Router(vlan)#vlan 1

Router(vlan)#vlan 2

Router(vlan)#exit

Router#configure terminal

Router(config)#interface vlan 1

Router(config-if)#ip address 1.1.1.1 255.255.255.0

Router(config-if)#no shut

Router(config-if)#interface vlan 2

Roouter(config-if)#ip address 2.2.2.2 255.255.255.0

Router(config-if)#no shut

Router(config-if)#interface FastEthernet 0/1/0

Router(config-if)#switchport access vlan 1

Router(config-if)#interface Fast Ethernet 0/1/1

Router(config-if)#switchport access vlan 2

Router(config-if)#exit

Interfaces fast0/1/0 and 0/1/1 are connected to the ethernet switching modules and will switch between all other ports belonging to the same VLAN. Inter-vlan routing will also happen due to the SVIs. The 'interface vlan x' are the SVIs.

Hope that helps - pls rate the post if it does.

Paresh

Silver

Re: Load balancing wifi Links

The additional ethernet interfaces, like the HWIC-4ESW on the 1800 are switch interfaces, therefore, you can not assign ip addresses to them nor can you route in between the interfaces. Rather, you can create SVI interfaces and route between those. An SVI Interface is a Switched Virtual Interface. Basically, you create a vlan interface, and assign the ip address to the vlan interface. The physical interface is now put in a vlan access mode and assigned that vlan id.

Practically, it works just like as if the ip address was assigned to the interface.

703
Views
0
Helpful
8
Replies