Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Load Balancing with Thresholds

Hi,

I have a Cisco router with 2 WAN interfaces speaking EIGRP to the service provider for redundancy and load sharing purposes.

One link is an ADSL2+ service with relatively high latency (120ms), and the other link is a symmetrical 4M/4M link with very low latency (2ms).

What I would like to do is have the router choose the 4M/4M link for all traffic until the latency on the 4M/4M reaches about 120ms.  At which point, I would like the router to start "overflowing" traffic to utilise the ADSL2+ link until the latency has dropped below 100ms on the 4M/4M.  Is this possible with the use of "ip sla" and EIGRP, or any other mechanisms?  I am running 12.4(20)T5 Adv IP Svcs IOS.

Here is a sanitised version of my configuration currently.  Thanks in advance!

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 10000
!
no aaa new-model
clock timezone aest 10
clock summer-time aedt recurring last Sun Oct 2:00 last Sun Mar 3:00
!
!
dot11 syslog
ip source-route
!
!
!
!
ip cef
login on-failure log
login on-success log
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet0
description 4M/4M Link
switchport access vlan 2
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description Local LAN
ip address xxx.xxx.71.49 255.255.255.248
!
interface Vlan2
description 4M/4M Link
bandwidth 4000
ip address xxx.xxx.157.106 255.255.255.252
delay 200
!
interface Dialer1
description ADSL2+ Link
bandwidth 1000
ip address negotiated
encapsulation ppp
delay 50000
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname user1
ppp chap password user1
!
router eigrp 39
variance 20
traffic-share min across-interfaces
network xxx.xxx.104 0.0.0.3
network xxx.xxx.71.28 0.0.0.0
network xxx.xxx.71.48 0.0.0.7
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1 254
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 120 0
logging synchronous
login local
no modem enable
transport output all
line aux 0
transport output all
line vty 0 4
exec-timeout 120 0
logging synchronous
login local
transport input all
transport output all
!
scheduler max-task-time 5000
end

129
Views
0
Helpful
0
Replies