Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Load balancing

Hi Netpros,

A quick question. How can we loadbalance 2 leased lines on 2 routers with static routes. Both the links are of the same bandwidth. What will be the configuration to be used.

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Load balancing

Hello,

on each WAN router configure one static route to the destination and redistribute it into your IGP. This could look like:

interface Serial0

ip address 1.2.3.1 255.255.255.252

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

router ospf 10

redistribute static subnets

network 10.1.1.1 0.0.0.0 area 0

ip route 192.168.0.0 255.255.0.0 1.2.3.2

The same config (with adjusted IP addresses etc.) could be used on the second WAN router.

This works in case there is another router in your area 0 performing the actual load balancing. Other dynamic IP routing protocolls like RIPv2 or EIGRP will do as well.

In case your two WAN routers will be default gateway for directly attached PCs, then you should have a look at GLBP (Gateway Load Balancing Protocol), which is an "enhanced version of HSRP".

A good description of GLBP and configuration examples are found in "Configuring GLBP" at

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fb97.html

The above possibilities can be even combined (like GLBP in remote site and OSPF in the HQ/data center).

Hope this helps! Please rate all posts.

Regards, Martin

1 REPLY

Re: Load balancing

Hello,

on each WAN router configure one static route to the destination and redistribute it into your IGP. This could look like:

interface Serial0

ip address 1.2.3.1 255.255.255.252

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

router ospf 10

redistribute static subnets

network 10.1.1.1 0.0.0.0 area 0

ip route 192.168.0.0 255.255.0.0 1.2.3.2

The same config (with adjusted IP addresses etc.) could be used on the second WAN router.

This works in case there is another router in your area 0 performing the actual load balancing. Other dynamic IP routing protocolls like RIPv2 or EIGRP will do as well.

In case your two WAN routers will be default gateway for directly attached PCs, then you should have a look at GLBP (Gateway Load Balancing Protocol), which is an "enhanced version of HSRP".

A good description of GLBP and configuration examples are found in "Configuring GLBP" at

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fb97.html

The above possibilities can be even combined (like GLBP in remote site and OSPF in the HQ/data center).

Hope this helps! Please rate all posts.

Regards, Martin

93
Views
0
Helpful
1
Replies
CreatePlease to create content