Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

load-ballance don't work

i want to do load-ballance between the two atm , and the problem is that any time the all transmit pass throuh one atm ,and it's don't do a load-ballance between the two atm.what is my problem?

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Internet

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool lan

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

dns-server 192.110.202.222 216.8.172.83

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.2.1 255.255.255.0

ip nat inside

duplex auto

speed auto

hold-queue 100 out

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 2000000

dialer-group 1

keepalive 11

ppp pap sent-username xxxx password xxxx

!

interface Dialer2

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 2

dialer idle-timeout 2000000

dialer-group 2

keepalive 11

ppp pap sent-username xxx password xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

!

ip http server

ip nat inside source route-map Connection_1 interface Dialer1 overload

ip nat inside source route-map Connection_2 interface Dialer2 overload

!

access-list 1 permit 192.168.2.0 0.0.0.255

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

route-map Connection_1 permit 10

match ip address 1

match interface Dialer1

!

route-map Connection_2 permit 10

match ip address 1

match interface Dialer2

!

!

control-plane

!

banner login ^CCCCCCCCC

*************************************************************************

M E H I S H N E T W O R K

S n i f 888

This system is the property of Mertif Enterprise

Disconnect IMMEDIATELY if you are not an authorized user!

*************************************************************************

^C

!

line con 0

line aux 0

line vty 0 4

password fprxct123

login

!

end

Hadraha_Internet#

2 REPLIES

Re: load-ballance don't work

Suppose that all traffic is sent out on int dialer1?

This is because the first clause of your route map matches for this route. The second clause is then simply not checked while a match has already been found.

I have seen lots of people attmpting Internet load balancing. For your case it will not work because you try to split up between two different nat translations.

Best advice to achieve some balancing on this setup is to divide user in two groups and match those with different acl's. Then send one group out interface 1 and the rest out interface 2. It's not real load balancing but it is probably the best you can achieve.

Regards,

Leo

New Member

Re: load-ballance don't work

In addition to the previous post, you can also try PBR to do this. PBR occurrs before NAT, therefore you can match on incoming traffic and set the interface you want. That would require to split the internal subnet. Also (if your device supports CEF) as another option, why not get rid of your route-maps altogether and allow CEF to load balance on a per source-destination basis. Routing also occurs before NAT. Instead of using ip nat inside source route-map...use ip nat inside source list. I haven't tried it but I can't see any reason why it should not work.

HTH

E.

121
Views
0
Helpful
2
Replies
CreatePlease to create content