Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Local Director 417

Hi,

I am trying to place local Director to load balance for 8 terminal servers.

The network setup is like this.

VLAN 10 - 192.168.1.x / 24

Cisco 3550 - Fa0/0 -------------à user Network

Cisco 3550 - Fa0/1 -----------à Local Director (User Facing Interface)

VLAN 20 - 192.168.2.x /24

Cisco 3550 - Fa0/10 ----------------à Local Director (Server Facing interface)

Cisco 3550 - Fa0/11 ---------------à Server1

..

…

..

Cisco 3550 - Fa0/19 ----------------à Server8

Virtual IP : 192.168.2.10

Config

==========

: Saved

: LocalDirector 417 Version 4.2.1

syslog output 20.3

no syslog console

enable password 000000000000000000000000000000 encrypted

hostname LocalDirector

no shutdown ethernet 0

no shutdown ethernet 1

no shutdown ethernet 2

shutdown ethernet 3

shutdown ethernet 4

shutdown ethernet 5

interface ethernet 0 auto

interface ethernet 1 auto

interface ethernet 2 auto

interface ethernet 3 auto

interface ethernet 4 auto

interface ethernet 5 auto

mtu 0 1500

mtu 1 1500

mtu 2 1500

mtu 3 1500

mtu 4 1500

mtu 5 1500

multiring all

no secure 0

no secure 1

no secure 2

no secure 3

no secure 4

no secure 5

ping-allow 0

ping-allow 1

ping-allow 2

no ping-allow 3

no ping-allow 4

no ping-allow 5

ip address 192.168.2.100 255.255.255.0

arp timeout 30

no rip passive

rip version 1

failover ip address 0.0.0.0

no failover

failover hellotime 30

password xxxxxxxxxxxxxxxxxxxxxx encrypted

telnet 192.168.0.0 255.255.0.0

snmp-server enable traps

snmp-server community public

no snmp-server contact

no snmp-server location

virtual 192.168.2.10:0:0:tcp is

real 192.168.2.11:0:0:tcp is

real 192.168.2.12:0:0:tcp is

name 192.168.2.10 Virt

name 192.168.2.12 Serv1

name 192.168.2.11 Serv2

no names

bind 192.168.2.10:23:0:tcp 192.168.2.11:23:0:tcp

bind 192.168.2.10:23:0:tcp 192.168.2.12:23:0:tcp

I can ping the virtual IP from user desk but unable to connec to the server..as well as I can connec the server with its real ip..... :(

Please advise what is the wrong on this...config.

Thanks in adv

  • WAN Routing and Switching
7 REPLIES
New Member

Re: Local Director 417

Hi Gurus,

Can someone please help me on this its urgent...

New Member

Re: Local Director 417

I am surprised that no one is there to help me to fix the local director issue..?!?!!!

New Member

Re: Local Director 417

Hello,

Have you tried using port numbers, say 443, 80, or 23 in the configs (virtual, real, and bind) depending on how you are trying to connect?

New Member

Re: Local Director 417

Thanks for your reply.

Yes, I tried it for port 23...but unsuccessful.... in place of Server I used a router (assigned only IP address & Default route to its ethernet interface. no other config on that)

New Member

Re: Local Director 417

Have you tried something like this:

route 0.0.0.0 0.0.0.0 192.168.x.x

virtual 192.168.2.10:23:0:tcp is

real 192.168.2.11:23:0:tcp is

bind 192.168.2.10:23:0:tcp 192.168.2.11:23:0:tcp

New Member

Re: Local Director 417

Yes, I did....but no joy...yet.... :(

Silver

Re: Local Director 417

I've only touched the Local Director a few times but I think you need to consider the following:

1- The Local Director is a bridge. Having the user facing interface in VLAN10 and in network 192.168.1.0, and the server interface in VLAN 20 and in network 192.168.2.0 seems like there may be a conflict there. Consider having the user interface and server interface in the same VLAN.

2- Again, the Local Director acts like a bridge. Having both interfaces of the LD on the same switch and acting as a bridge between the users and the servers will probably not work. Consider having the LD user interface attached to the network switch and then a separate switch just for the servers attach to the other interface of the LD. All traffic to and from the servers will then have to pass through the LD.

Hope this helps

167
Views
0
Helpful
7
Replies