Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Local preference bgp

Hi

For 124 network i have given the local prefernce value as 300 but when i excuted the command value is not displaying ?

But 500 value is displaying .

route-map AIR, permit, sequence 10

  Match clauses:

    ip address prefix-lists: DEFAULT

  Set clauses:

    local-preference 300

Router-RSA#show ip bgp

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*  0.0.0.0          124.x.x.x            0             0 9XXX i

*>                  202.x.x.x          0    500      0 9XXX i

11 REPLIES
Purple

Local preference bgp

Hi,

could you post output of sh ip prefix

Regards.

Alain

Don't forget to rate helpful posts.

Local preference bgp

Hi,

I understand you are talking about the default route, not 124 network?

Are you sure the  prefix-lists DEFAULT is matching it?

And the route-map AIR is applied correctly?

If yes, have you tried

clear ip bgp * soft

on your router?

HTH,

Milan

Community Member

Local preference bgp

ip prefix-list DEFAULT: 1 entries

   seq 5 permit 0.0.0.0/0

Community Member

Local preference bgp

Hi,

Do post your config excluding sensitive info for us to conclude

Regards,

Rustom Billimoria

CCIE R&S# 24798

Sent from my BlackBerry® smartphone from Tata Indicom

Community Member

Local preference bgp

Hi

I have even excuted the command clear ip bgp  still local prefernce is not displaying for 300.

Router-RSA#show route-map

route-map DEFAULT-SCY-SIF, permit, sequence 10

  Match clauses:

    ip address prefix-lists: DEFAULT

  Set clauses:

    local-preference 400

  Policy routing matches: 0 packets, 0 bytes

route-map DEFAULT-PRY-SIF, permit, sequence 10

  Match clauses:

    ip address prefix-lists: DEFAULT

  Set clauses:

    local-preference 500

  Policy routing matches: 0 packets, 0 bytes

route-map AIR-IN, permit, sequence 10

  Match clauses:

    ip address prefix-lists: DEFAULT

  Set clauses:

    local-preference 300

  Policy routing matches: 0 packets, 0 bytes

route-map AIR-OUT, permit, sequence 10

  Match clauses:

    ip address prefix-lists: AIR-OUT

  Set clauses:

  Policy routing matches: 0 packets, 0 bytes

route-map SIF-OUT, permit, sequence 10

  Match clauses:

    ip address prefix-lists: SIF-OUT

  Set clauses:

  Policy routing matches: 0 packets, 0 bytes

ip prefix-list AIR-OUT seq 5 permit 202.x.x.x/24

!

ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0

!

!

ip prefix-list SIF-OUT seq 5 permit 202.x.x.x/24

Local preference bgp

Hi,

it seems route-map DEFAULT-PRY-SIF is applied on the default route prefix received, not route-map AIR-IN.

Can you paste the config part where you are applying the route maps?

HTH,

Milan

Community Member

Local preference bgp

yA route-map DEFAULT-PRY-SIF is applied on the default route prefix BUT WHEN ever SIF goes down .route-map AIR-IN

will be used .so when i excute show ip bgp when SIF goes down  local prefernce value for AIR is not displayed.

Local preference bgp

Hi,

I believe the  route-map AIR-IN might not be applied for some reason.

Otherwise you should see LP 300 in ypur original output.

HTH,

Milan

Community Member

Local preference bgp

Hi

It is applied when i shutdown interface to which SIF is applied than traffic is going through AIR_IN routemap

Community Member

Local preference bgp

Hi Milan,

I reconfigured the bgp and clear ip bgp now it is working fine.

Thank Milan fot u help

Local preference bgp

Hi Prashant,

Do you have any other route-map entry with lower seq number which already matches the default route?

Did you apply the route map to the other neigbor (124.x.x.x) to in direction?

Did you try clear ip bgp with this neigbor?

Hope that helps,

Vasilis

698
Views
0
Helpful
11
Replies
CreatePlease to create content