Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LOOPBACK ON A 2950 SWITCH

Hi

My company has requested me to install a switch on a WAN link.

They requested I configure a loopback address.

I configured the switch vlan1 with an ip/mask and no shut it.

The WAN link goes through the switch no problem.

When I configure an Loopback addrees ie

switch#config t

switch(config)#interface loopback 1

switch(config)#int loopback 1

^

% Invalid input detected at '^' marker.

However if you question mark int ?

switch(config)#int ?

looback is shown as a vaild command.

any one have any ideas?

5 REPLIES
New Member

Re: LOOPBACK ON A 2950 SWITCH

The ^ should be under Loopack

Cisco Employee

Re: LOOPBACK ON A 2950 SWITCH

Hi Friend,

2950 is a pure layer 2 switch so it does not need a loopback interface. The command will be present because 2950 works on basic IOS train which have this command but 2950 platform does not support this command.

HTH

Ankur

*Please rate helpfull post

Hall of Fame Super Silver

Re: LOOPBACK ON A 2950 SWITCH

Richard

Ankur gives a good explanation that the 2950 as a layer 2 switch does not support loopback interfaces and that loopback does show in help because it works out of a standard template for help in IOS.

In addition it may be helpful to point out that layer 2 switches can have only a single active virtual interface with an IP address. You indicate that you have configured VLAN 1 and given it an IP address. If you were to configure another VLAN (perhaps VLAN 2) and give it an IP address your would find that VLAN 1 shuts down. There can be only 1 active virtual interface with an IP address on the layer 2 switch.

HTH

Rick

New Member

Re: LOOPBACK ON A 2950 SWITCH

Thanks for the info

New Member

Re: LOOPBACK ON A 2950 SWITCH

Hello ankur,

I am also have the same problem.

I wonder why i can input the command interface loopback 0 on ios c2950-i6q4l2-mz.121-9.EA1.bin

but not on c2950-i6q4l2-mz.121-12c.EA1.bin

338
Views
18
Helpful
5
Replies