cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
367
Views
0
Helpful
4
Replies

loss of BGP community attribute

att-sgcops
Level 1
Level 1

I have 2 routers running BGP:

R7 config~~~~~~~~~~~~~~~~~~~~~~~~~~~

router bgp 700

redistribute connected route-map t1

neighbor 20.20.20.5 remote-as 500

neighbor 20.20.20.5 send-community

route-map t1 permit 10

set community no-export

~~~~~~~~~~~~~~~~~

but from the BGP table, I cannot see the "no-export" attribute:

R7#sh ip bgp 6.6.6.6

BGP routing table entry for 6.6.6.6/32, version 2

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Advertised to non peer-group peers:

20.20.20.5

Local

0.0.0.0 from 0.0.0.0 (8.8.8.8)

Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, best

R7#

why I cannot see it?

4 Replies 4

att-sgcops
Level 1
Level 1

the whole config, some parts may be no relavalent.

R7#sh run

Building configuration...

Current configuration:

!

! Last configuration change at 10:17:02 UTC Tue Apr 13 1993

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname R7

!

!

!

class-map chris

match none

class-map COS2_TRAFFIC

match none

!

!

!

ip subnet-zero

ip domain-list ccnp.com

ip domain-list ccna.com

ip domain-name ccie.com

ip name-server 10.1.1.1

ip name-server 10.1.1.2

ip name-server 10.1.1.3

!

tag-switching tdp router-id Loopback7

cns event-service server

!

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 7.7.7.7 255.255.255.255

!

interface Loopback1

ip address 6.6.6.6 255.255.255.255

!

interface Loopback2

ip address 8.8.8.8 255.255.255.255

!

interface Loopback7

no ip address

!

interface Ethernet0/0

ip address 20.20.20.7 255.255.255.0

ip directed-broadcast

ip policy route-map vfilter

half-duplex

max-reserved-bandwidth 76

!

interface Serial0/0

ip address 137.20.25.1 255.255.255.0

traffic-shape group 101 64000 8000 8000 1000

!

interface Serial0/1

no ip address

shutdown

clockrate 64000

!

router bgp 700

redistribute connected route-map t1

neighbor 20.20.20.5 remote-as 500

neighbor 20.20.20.5 send-community

!

ip classless

no ip http server

ip pim rp-address 10.1.23.3

!

access-list 1 permit 6.6.6.6

access-list 2 permit 7.7.7.7

access-list 3 permit 8.8.8.8

access-list 12 permit 30.1.1.5

access-list 33 permit any

access-list 101 deny udp any any range 16348 32767

access-list 101 permit ip any any

route-map setCom permit 10

match ip address 1

set community 65542

!

route-map setCom permit 20

match ip address 2

set community 65543

!

route-map setCom permit 30

match ip address 3

set community 65544

!

route-map setCom permit 40

!

route-map t1 permit 10

match ip address 33

set community no-export

!

route-map addas permit 10

match ip address 1

set as-path prepend 777

!

route-map addas permit 20

match ip address 2

set as-path prepend 666

!

route-map addas permit 30

!

!

snmp-server engineID local xxxx

snmp-server view test snmp excluded

snmp-server community secret RW 1

snmp-server community public RO 2

snmp-server trap link ietf

snmp-server trap-source Ethernet0/0

snmp-server packetsize 512

snmp-server trap-timeout 45

snmp-server location singapore

snmp-server contact ATT

snmp-server tftp-server-list 3

snmp-server manager

tftp-server flash:c2600-js56i-mz.121-3.T.bin alias upload

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

login

transport input lat pad v120 mop telnet rlogin udptn nasi

line aux 0

line vty 0 4

privilege level 15

login

transport input lat pad v120 mop telnet rlogin udptn nasi

!

ntp clock-period 17208882

ntp server 200.200.100.1

end

Harold Ritter
Cisco Employee
Cisco Employee

It appears that prefix 6.6.6.6/32 is originated via a network statement because of its Origin attribute being set to IGP. Can you confirm that.

If it is the case then it this normal that the community no-export is not set on this prefix since the route-map t1 is configured on the "redistribute connected" statement.

You could also use the route-map t1 on the netwrok statement to solve this issue.

Hope this helps,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

now see my new configuration:

hostname R7

interface Loopback0

ip address 7.7.7.7 255.255.255.255

!

interface Loopback1

ip address 6.6.6.6 255.255.255.255

!

interface Loopback2

ip address 8.8.8.8 255.255.255.255

!

interface Loopback7

no ip address

!

interface Ethernet0/0

ip address 20.20.20.7 255.255.255.0

ip directed-broadcast

ip policy route-map vfilter

half-duplex

max-reserved-bandwidth 76

!

interface Serial0/0

ip address 137.20.25.1 255.255.255.0

traffic-shape group 101 64000 8000 8000 1000

!

interface Serial0/1

no ip address

shutdown

clockrate 64000

!

router bgp 700

redistribute connected route-map t1

neighbor 20.20.20.5 remote-as 500

neighbor 20.20.20.5 send-community

no auto-summary

!

ip classless

no ip http server

ip pim rp-address 10.1.23.3

!

access-list 1 permit 6.6.6.6

access-list 2 permit 7.7.7.7

access-list 3 permit 8.8.8.8

access-list 12 permit 30.1.1.5

access-list 33 permit any

access-list 101 deny udp any any range 16348 32767

access-list 101 permit ip any any

route-map t1 permit 10

match ip address 1

set community no-export

!

route-map t1 permit 20

match ip address 2

set community no-advertise

!

route-map t1 permit 30

match ip address 3

set community local-AS

end

the Origin attribute changed to imcompleted, but still not able to see the attribute:

R7#sh ip bgp 6.6.6.6

BGP routing table entry for 6.0.0.0/8, version 4

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Advertised to non peer-group peers:

20.20.20.5

Local

0.0.0.0 from 0.0.0.0 (8.8.8.8)

Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

R7#sh ip bgp 7.7.7.7

BGP routing table entry for 7.7.7.7/32, version 19

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Flag: 0x208

Advertised to non peer-group peers:

20.20.20.5

Local

0.0.0.0 from 0.0.0.0 (8.8.8.8)

Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

R7#sh ip bgp 8.8.8.8

BGP routing table entry for 8.8.8.8/32, version 20

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Flag: 0x208

Advertised to non peer-group peers:

20.20.20.5

Local

0.0.0.0 from 0.0.0.0 (8.8.8.8)

Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

This doesn't look normal indeed. What version of IOS is running on this box?

Thanks,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card