Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Lost Configuration?

Hi, after going through the password recovery procedure (console) we are no longer getting access to our configuration.  In other words, when we go into romrom we get the router> and then router# prompt and then we would typically get the our_router_name# prompt but it never goes to our router config and stays at the router# default.  When we go back into 0x2102 it just goes to the default (blank) router config instead of our config. I hope that makes sense....Have we lost our default config?  Is there anyway to see the all alternate configs on the router?                    

8 REPLIES
Bronze

Re: Lost Configuration?

Use "show startup"
If your config is there do " copy start runn" very careful here. If you do the opposite you will lose your config.

Sent from Cisco Technical Support iPhone App

New Member

Re: Lost Configuration?

Just shows the default (blank) config when I do that.  But wouldn't that to be expected since it's booting into the default config at startup?

Silver

Re: Lost Configuration?

Try "dir nvram:". This should show you if there is a config file in your NVRAM. Sounds like your config might have gone to the great recycle bin in the sky though

New Member

Re: Lost Configuration?

This is what I get when I try that:

      

62   -rw-  829    startup-config

62   ----     5    private-config

1    -rw-    0    ifindex-table

  2   ----     12   persistent-data

Any suggestions from that?

Thanks for all the input,I really appreciate it.

Silver

Re: Lost Configuration?

Type:

more nvram:startup-config

That will show you what is in the startup-config file.

New Member

Re: Lost Configuration?

Just shows the default (blank with none of our info) config when I do that.  So, I take it that it's gone? 

Silver

Re: Lost Configuration?

Pretty much. You could try a "dir flash:" just to verify that there is not a stray config in there.

Thank goodness you did regular backups of your config to a TFTP server...

...you did do regular backups right?

New Member

Re: Lost Configuration?

There is just the single config in the flash directory.  Tried booting to that with no change.

A backup would be nice, wouldn't it?  They are checking with their previous support group but it's not looking likely.  Will have to reconfigure it unfortunately it seems.  Doesn't look like they had any documentation on it at all.  I am looking at it after the fact so trying to catch up with what happened.  Thanks again for the help.

153
Views
0
Helpful
8
Replies
CreatePlease to create content