Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LOTS of Reading, Out of Ideas

Well, I did a lot of reading and a lot of searching (excruciating details below) and am still not able to get to my server from outside on the web.

ssh dev.optuserv.com  (the domain I've set up) results in:

ssh_exchange_identification: Connection closed by remote host

All accesses to the static IP itself result in:

ssh 50.76.70.249

ssh: connect to host 50.76.70.249 port 22: Connection refused

Any ideas?

Mark

WHAT I DID:

updated config file for ethernet port 0 as follows:

vi /etc/sysconfig/network-script/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=50.76.70.249
PREFIX=8
GATEWAY=50.76.70.254
DNS1=xx.yy.zz.ww
ONBOOT=yes

port was up okay -- tried four different values for DNS1 (see below)

I'd purchased the domain from Pair.com -- optuserv.com -- and had, at Pair.com's consulting, added a prefix,

so their nameserver would recognize "dev.optuserv.com"

I configured the Cisco RV220 modem with their tool for configuring routers and firewalls, using the selections "Networking"->"WAN Setup"->"Static IP" as follows (text extracted from the Cisco web-based tool):

Internet Connection Type:   Static IP

Static IP Settings

IP Address:        50.76.70.249

Subnet Mask        255.255.255.248

Default Gateway    50.76.70.254

Primary DNS Server 75.75.75.75

Secondary DNS Server    (Optional)   75.75.76.76

MTU Size                               

MTU Type:    X  Default                

                Custom                         

MTU Size: Default (1500)                       

Bytes (Range : 1200                            

- 1500, Default : 1500)                          

Router MAC Address

MAC Address Source (Use Default Address)         

MAC Address             (left blank) 

I tried the config files with both the primary and secondary dns nameservers provided by Comcast -- 75.75.75.75 and 75.75.76.76, then the two dns name servers provided by Pair.com and restarted the links each time.  Ethernet 0 came up fine and the others failed, as expected, since nothing is hooked to the other ethernet ports.

In all cases, 50.76.70.154 (the Comcast-provided gateway) resulted in a prompt from the BH SSH handler, which I assume is the Comcast-provided Netgear cable modem.

All accesses to dev.optuserv.com resulted in:

ssh dev.optuserv.com

ssh_exchange_identification: Connection closed by remote host

All accesses to the static IP itself resulted in:

ssh 50.76.70.249

ssh: connect to host 50.76.70.249 port 22: Connection refused

Is this just a case of waiting for the DNS information to propagate through the web?  But it seems I'm getting through with the domain name, "dev.optuserv.com"

Now what?

  • WAN Routing and Switching
3 REPLIES
Cisco Employee

LOTS of Reading, Out of Ideas

Mark,

You are getting two different results based on whether you SSH using a domain name or an IP address. Doing SSH to a domain name ends with "Connection closed by remote host" while SSH to an IP address ends with "Connection refused". This suggests that the FQDN dev.optuserv.com does not correspond to the IP address 50.76.70.249 because "Connection refused" means that the SSH TCP port 22 is closed, while "Connection closed" means that it is open and listened on.

Can you actually double check that the dev.optuserv.com resolves to 50.76.70.249? Try pinging it, or use nslookup (in Windows) or host (in Linux) to resolve the name.

Also, your PREFIX variable in the ifcfg-eth0 appears to be incorrect - you have set it to 8. I doubt you have the entire /8 network for yourself.

Best regards,

Peter

Purple

LOTS of Reading, Out of Ideas

Hi Peter,

It also seems that he has configured this IP on the gateway too.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

LOTS of Reading, Out of Ideas

Well, folks, all these replies have led me in the right direction, so many thanks!

I've received comments on that PREFIX value, so I'm not sure why I was instructed to use that or if I'd just misinterpreted it, and let my original skepticism go.

There were some configuration details in how the Cisco router was set up using the GUI "wizard" software, and moving that to within our LAN took care of that.

The config files just needed the PREFIX fix.  After that, we loaded the other two machines, made some changes in the subnet settings at pair.com, and things are working swimmingly!

Thanks again!

Mark

212
Views
0
Helpful
3
Replies