Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Low Internet Upload speed

Hi,

We are receiving low internet upload speed (6-8Mps) at our office location. The download speed is good (50Mbps).

Got in contact with the ISP Comcast and tried testing it bypassing our internal n/w i.e. connecting my laptop directly to Cienna (Comcast GW)

and both speeds were around 50Mbps.

Testing the same through my router the speed goes down. Just the Upload speed.

Could there be a configuration in our router thats causing this? Moreover we have few other offices near by with the similar router config but they seem to be getting good speeds.

FYI on the internet interface thee settings are

'duplex full

speed auto'

Any insight will be highly appreciated. Thanks

2 ACCEPTED SOLUTIONS

Accepted Solutions

Low Internet Upload speed

As Leo noted above,

(ROUTER)#sh run int g0/2

interface GigabitEthernet0/2

description FW_Link

ip address 10.xx.xx.xx xx.xx.xx.xx

ip access-group 120 in

ip nat inside

ip nat enable

ip virtual-reassembly in

duplex full <----

speed 100 <----

end

These are manually set, the side going to the ASA, is it setup as auto/auto or manually configured?

Hall of Fame Super Gold

Low Internet Upload speed

So configuring the interface speed and duplex settings to auto/auto would resolve the issue?

Clear the counters and change the speed and duplex to auto/auto.

13 REPLIES

Re: Low Internet Upload speed

Sounds like from Comcast's perspective everything works as expected.

I'm assuming from the Cienna Comcast GW, it's connected to the Router, and then to your local lan.

Have you tried a new cable going from the router to the cable modem, also what router do you have?

It's also possible that someone is hogging your upload bandwidth, and when you run a test, that's all your

seeing is 6 to 8Mbps.

Community Member

Low Internet Upload speed

John,

Yes the Cienna is connectd to router. router to FW n lan.

The cable between Cienna and router is pretty new. Will still try swapping it after office hours.

Router - Cisco 3925

FW - ASA 5515

Is there a way to find out if someone is using up the bandwidth.

Thanks for your help.

Re: Low Internet Upload speed

On your router, the port going to the cable modem and the port going to the ASA, can you post a 'show int x/x' for each port?

After you do that, clear the statistics for that interface.

Community Member

Low Internet Upload speed

Please find below the run config for the 2 interfaces. For int g0/1, speed was 100. Changed it to 'auto' last night.

The ACL 199 and 120 are to allow/stop telnet access.

(ROUTER)#

(ROUTER)#sh run int g0/1

Current configuration : 219 bytes

!

interface GigabitEthernet0/1

description Cienna_EDI_Link

ip address 50.xx.xx.xx 255.255.255.252

ip access-group 199 in

ip nat outside

ip nat enable

ip virtual-reassembly in

duplex full

speed auto

ipv6 enable

end

(ROUTER)#sh run int g0/2

interface GigabitEthernet0/2

description FW_Link

ip address 10.xx.xx.xx xx.xx.xx.xx

ip access-group 120 in

ip nat inside

ip nat enable

ip virtual-reassembly in

duplex full

speed 100

end

Low Internet Upload speed

Ninja,

Sorry for the delay, I've been pretty busy at work today. I see you ran the 'show run int gi0/1 and gi0/2' command, can you run the 'show int gi0/1 andshow int gi0/2' and paste that config, excluding any private information?

Community Member

Low Internet Upload speed

Been checking for your reply whole day.

Thanks for spending time on it out of your busy schedule.

(ROUTER)#sh int g0/1

GigabitEthernet0/1 is up, line protocol is up

  Hardware is PQ3_TSEC, address is XXXXXXXX

  Description: EDI_Link

  Internet address is 50.XX.XX.XX/XX

  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full Duplex, 1Gbps, media type is RJ45

  output flow-control is XON, input flow-control is XON

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1561000 bits/sec, 227 packets/sec

  5 minute output rate 300000 bits/sec, 166 packets/sec

     15458530 packets input, 15054104366 bytes, 0 no buffer

     Received 59 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     9857268 packets output, 2393627370 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     1 lost carrier, 0 no carrier, 17724 pause output

     0 output buffer failures, 0 output buffers swapped out

(ROUTER)#

(ROUTER)#sh int g0/2

GigabitEthernet0/2 is up, line protocol is up

  Hardware is PQ3_TSEC, address is XXXXXXXXXXXX

  Description: FW_Link

  Internet address is 10.XX.XX.XX/XX

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 5/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full Duplex, 100Mbps, media type is RJ45

  output flow-control is unsupported, input flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 466

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 543000 bits/sec, 351 packets/sec

  5 minute output rate 2177000 bits/sec, 475 packets/sec

     14968797 packets input, 3762142601 bytes, 0 no buffer

     Received 4160 broadcasts (0 IP multicasts)

     39311 runts, 5 giants, 0 throttles

     191160 input errors, 191157 CRC, 5 frame, 3 overrun, 0 ignored

     0 watchdog, 3699 multicast, 0 pause input

     21324023 packets output, 18667280563 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     2407 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     12 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

(ROUTER)#

Hall of Fame Super Gold

Re: Low Internet Upload speed

GigabitEthernet0/2 is up, line protocol is up

39311 runts, 5 giants, 0 throttles

191160 input errors, 191157 CRC, 5 frame, 3 overrun, 0 ignored

Nuts.  Those CRC are pretty high.

Sounds like you've got a bad cable.

Hall of Fame Super Gold

Re: Low Internet Upload speed

Full Duplex, 100Mbps, media type is RJ45

This could be what's causing the CRC errors.  Is the port's speed and duplex setting hard-coded?

Low Internet Upload speed

As Leo noted above,

(ROUTER)#sh run int g0/2

interface GigabitEthernet0/2

description FW_Link

ip address 10.xx.xx.xx xx.xx.xx.xx

ip access-group 120 in

ip nat inside

ip nat enable

ip virtual-reassembly in

duplex full <----

speed 100 <----

end

These are manually set, the side going to the ASA, is it setup as auto/auto or manually configured?

Community Member

Low Internet Upload speed

The cable is new. Will still replace it.

I manually configured the speed(100) and duplex(full) settings on the interface.

On the ASA they are set to auto/auto. Didnt touch that.

So configuring the interface speed and duplex settings to auto/auto would resolve the issue?

Hall of Fame Super Gold

Low Internet Upload speed

So configuring the interface speed and duplex settings to auto/auto would resolve the issue?

Clear the counters and change the speed and duplex to auto/auto.

Community Member

Low Internet Upload speed

Resolved.

Till before I was making changes at the EDI link and not the FW link thinking it was the issue between the Cienna and my router connection.

Thanks to John and Leo for their time!!!

Hall of Fame Super Gold

Low Internet Upload speed

Thanks for taking the time to rate our posts. 

361
Views
5
Helpful
13
Replies
CreatePlease to create content